No announcement yet.

AMD Catalyst 12.9 Beta Linux Driver Released

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Installed this yesterday on LinuxMint with an HD6870 that drives dual 23" monitors and so far no issues.


    • #12
      Originally posted by Rigaldo View Post
      Does It support xorg 1.13? If not, that would explain how I can't ge it to work on Ubuntu quantal .. :|
      Nope doesn't look like it has Xorg 1.13 support. All i got was
      X Error of failed request:  BadRequest (invalid request code or no such operation)
      out of glxinfo or when tying to open amdcccle


      • #13
        Originally posted by mard0 View Post
        Nope doesn't look like it has Xorg 1.13 support. All i got was
        X Error of failed request:  BadRequest (invalid request code or no such operation)
        out of glxinfo or when tying to open amdcccle

        "This release of AMD Catalyst Linux introduces support for the following new operating systems.

        Ubuntu 12.10 early look support
        RHEL 6.3 production support"

        Are they trolling us..?

        From what I read it might be a decent release, although I hoped I could run it on quantal already .. :/


        • #14
          It does NOT work on Ubuntu 12.10.

          I tried it on Kubuntu 12.10, and the X server will fail to load when it tries to load the fglrx module.

          AMD stupidity continues.

          I have a Geforce GTX 560 in the mail that should arrive tomorrow. This Catalyst nonsense will no longer be an issue.

          I was hoping that AMD would get their open source strategy in full swing, but they seem to have abandoned r600/evergreen a while ago.

          My guess is that Catalyst would stop supporting my 5000 series card before the open source driver is a capable replacement.


          • #15
            Let's not give up all hope, it's still beta. It might work fine on xorg 1.13 and Ubuntu 12.10 by final version .. Hopefully ..!
            Besides, it's not that easy to switch graphics card on my laptop now .. xD


            • #16
              It figures that Catalyst has just started to behave right after I decided to go with Nvidia this time. The last two years with Catalyst has been a complete disaster and their open source driver is not fit to run anything much past desktop effects.

              I give up.

              I know that my Nvidia card is never guaranteed to have a credible open source alternative to Forceware (or whatever they are calling that now, my last Nvidia card with from the 9000 series), but it doesn't appear that AMD will either.

              I went to test out a Kubuntu 12.10 image today, excited that this Catalyst 12.9 beta might #%#$ing work, like, you know, their release notes said it would, but AMD has jacked me around again.

              I see the open source driver has inched forwards again, but it still has no fan control and my computer sounds like it is about to take off and fly around the room.

              I'm counting the hours left until I can rip this Radeon card out and replace it with something that supports the new distributions well before they are officially released. Among other things, like, not interfering with Wine.

              I also understand that Nvidia supported direct rendering under kwin before that was officially released too.

              The Catalyst team is a day late and a dollar short every time. If it was just one thing they were doing with their Linux driver that was incompetent, I might not have to come down as hard on them, but it's just so messed up in so many ways.

              Oh yeah, Nvidia has public betas quite frequently, and I never remembered them painting a FOR TESTING USE ONLY thing on my desktop that I had to figure out how to remove.


              • #17
                This version doesn't look good for me. I have intel+amd switchable graphics in my laptop. So fglrx not only doesn't support x-server 1.13 but also doesn't work with newest intel drivers (>=2.20.3). Also I noticed that fglrx requires relatively old versions of Mesa (8.0.4).

                By the way, does anybody know about news of the seamless support of switchable graphics in fglrx? It would be great to have something like bumblebee for amd cards.


                • #18
                  It seems the guys from Ubuntu already solved the issue for xorg-server 1.13:


                  Can anybody else try and confirm it?


                  • #19
                    Yes, that's true. fglrx driver for Xserver 1.13 support is already available in Ubuntu 12.10 repository.


                    • #20
                      I made deb package for Ubuntu quantal, it compiles good, install OK but nothing more, unity crash at launch, no 3D acceleration.