No announcement yet.

AMD Catalyst Linux 12.6 Beta Has Arrived

  • Filter
  • Time
  • Show
Clear All
new posts

  • #41
    Originally posted by Kano
    Verified that weird crash on debian wheezy with xserver 1.12.0, 1.12.1, As it was a beta, i want a 2nd one...
    Installed on my Debian SID, also upgraded the xserver to 1.12.902 on the upgrade and fglrx doesn't work. It keeps with a cursor blinking after gdm3 load, and in the xorg log file it apears "no free vt" error. Is that the crash do you say?


    • #42
      Originally posted by Gusar View Post
      Just checking...

      When you guys talk about "overheating", do you actually mean the machine shuts down because the temp exceeds a threshold, or is the laptop simply hotter but otherwise functional?
      Depends on what you call functional. With the fglrx drivers I usually have about 45?C CPU temperature on idle and about 65-70?C under heavy load. With the radeon drivers I get 60?C minimum and under heavy load the CPU goes up to 85-90?C. This does not shut down the system, but it is not healthy at all, so I wouldn't call that functional.


      • #43
        The radeond driver is very problematic, first of all the temperature is very high than the binary driver, I get 92 degrees with my laptop hp pavilion dv6 2120, but when I use catalyst driver I get 71/82 degrees. The second problem is that the driver radeon don't had a video aceleration like xvba-video, For me that I have an amd x2 is impossible to watch a movie 1080p with the radeon driver


        • #44

          You see a bit more in the log file, but the result is of course no X running. I installed a 32 bit system to compare and there X starts with xserver 1.12. I want a new beta with debian 64 bit support, kernel 3.4/3.5 support and maybe with dx10 hardware pci ids... btw. in the debian fglrx packaging a valid signature file was added, so when you run a 32 bit system you will not see a testing watermark. The problematic part is still that sometimes the control file is only for consumer hardware but not for the workstation (firegl) ones. I can accept a whitelist which is exactly the same for the fglrx kernel module for amdcccle and the (useless) control file but not when there are only a subset of the ids. The driver is generic by nature, it usually works even when amd did not test it - and when they tested it it does not mean that the driver is bug free anyway. So just an extra annoying thing than something useful. No win user ever saw a watermark with a beta driver, there even those drivers are promoted in


          i think it was the first time that the linux driver link was on the same beta page, usually they called it hotfix for whatever.


          • #45
            I want that driver too Kano, an xserver 1.12, amd64 compatible one...

            By the way, the error I say is this:

            Fatal server error:
            [    80.563] xf86OpenConsole: Cannot find a free VT


            • #46
              Hmmm... for me this driver still doesn't work with kernel 3.4. I have a dual intel/ati 6770 HP laptop. With kernel 3.3 I get:
              [     8.432] (II) Loading PCS database from /etc/ati/amdpcsdb
              [     8.434] ukiDynamicMajor: found major device number 253
              [     8.434] ukiDynamicMajor: found major device number 253
              [     8.434] ukiOpenByBusid: Searching for BusID PCI:1:0:0
              [     8.434] ukiOpenDevice: node name is /dev/ati/card0
              [     8.434] ukiOpenDevice: open result is 8, (OK)
              [     8.434] ukiOpenByBusid: ukiOpenMinor returns 8
              [     8.434] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
              [     8.696] (II) Turned on the discrete card
              and X starts. But with 3.4:
              [    10.576] (II) Loading PCS database from /etc/ati/amdpcsdb
              [    10.587] ukiDynamicMajor: failed to open /proc/ati/major
              [    10.588] ukiDynamicMajor: failed to open /proc/ati/major
              [    10.588] (EE) Fail to open device PCI:1:0:0
              I'm using xf86-video-intel-2.19 and xorg-server-1.12. The ati driver was compiled with the 3.4 patch.
              Any ideas?


              • #47
                Duh, my module was not loading. The same error I had some time ago:

                fglrx: Unknown symbol old_rsp (err 0)
                old_rsp is introduced in the patch. So I don't know how to solve it.

                (edit) And now I know. I had to disable CONFIG_X86_X32 (x32 ABI). I tried removing that kernel option and it worked. At last, I have a 3.4 kernel with 1.12 xorg-server and fglrx.
                Last edited by zequav; 06-06-2012, 04:16 AM.