Announcement

Collapse
No announcement yet.

Kernel Module Pkg Error with FC7 - multiple questions

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Kernel Module Pkg Error with FC7 - multiple questions

    I am encountering some strange behavior from the ati driver install on FC7.

    I just upgraded to FC7 and I have an ATI Radeon x700 series video card. Before installing the drivers, my resolution maxed out at 800x600, but now I am at my max resolution. However the kernel module, the DRI, and aparently the 3d acceleration is not working. On top of that, after a log out, my screen goes black and I am not returned to the log in page or the base terminal. I have a feeling this is related to the kernel module.


    Question 1: as you will see below it does the kernel module installation for the 2.6.20-2925.13.fc7xen kernel which is not the latest release. I have the devel pkg installed for that kernel, but the kernel core 7 comes with and defaults to is 2.6.22.1-41.fc7. How can I get it to work with the latest kernel headers instead?

    Question 2: none the less, why doesn't it work with the 2.6.20 xen kernel in the first place? The reason may well be connected.

    Here is all the info, anybody who could help please, please lend me a hand. It is really frustrating.

    ATI installer: ati-driver-installer-8.39.4-x86.x86_64.run

    ATI BuildPKG output:
    ATI module generator V 2.0
    ==========================
    initializing...
    OsRelease=2.6.20-2925.13.fc7xen
    major=2
    minor=6
    patch=20
    extra=-2925.13.fc7xen
    SMP=1
    smp=-SMP
    iii=
    AGP=1
    CC=gcc
    cc_version=
    cleaning...
    patching 'highmem.h'...
    assuming new VMA API since we do have kernel 2.6.x...
    Assuming default VMAP API
    Assuming default munmap API
    doing Makefile based build for kernel 2.6.x and higher
    make -C /lib/modules/2.6.20-2925.13.fc7xen/build SUBDIRS=/tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x modules
    make[1]: Entering directory `/usr/src/kernels/2.6.20-2925.13.fc7-xen-i686'
    CC [M] /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
    /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:46:2: error: #error unknown or undefined architecture configured
    In file included from /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/drm_proc.h:41,
    from /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:366:
    /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/drmP.h:126:1: warning: "DRM_DEBUG_CODE" redefined
    /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:179:1: warning: this is the location of the previous definition
    /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:484: warning: initialization from incompatible pointer type
    /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'firegl_stub_open':
    /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:607: warning: assignment discards qualifiers from pointer target type
    /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke_do_mmap':
    /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1968: warning: assignment makes pointer from integer without a cast
    /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke_request_irq':
    /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2806: warning: passing argument 2 of 'request_irq' from incompatible pointer type
    /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke_smp_call_function':
    /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4330: warning: passing argument 1 of 'smp_call_function' from incompatible pointer type
    /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'KCL_has_pat':
    /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4512: warning: passing argument 2 of 'constant_test_bit' from incompatible pointer type
    /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4512: warning: passing argument 2 of 'variable_test_bit' from incompatible pointer type
    /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: At top level:
    /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5280: warning: 'kmem_cache_t' is deprecated
    make[2]: *** [/tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
    make[1]: *** [_module_/tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/ATI-fglrx-8.39.4-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x] Error 2
    make[1]: Leaving directory `/usr/src/kernels/2.6.20-2925.13.fc7-xen-i686'
    make: *** [kmod_build] Error 2
    build failed with return value 2
    error: Bad exit status from /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/rpm-tmp.263 (%install)


    RPM build errors:
    Bad exit status from /tmp/ATI-fglrx-8.39.4-1-18344-root/tmp/rpm-tmp.263 (%install)

    Some Other Pkg Info:
    rpm -qa | grep kernel
    kernel-2.6.21-1.3194.fc7
    kernel-2.6.22.1-41.fc7
    kernel-devel-2.6.22.1-41.fc7
    kernel-xen-2.6.20-2925.13.fc7
    kernel-xen-devel-2.6.20-2925.13.fc7
    kernel-xen-2.6.20-2925.9.fc7
    kernel-headers-2.6.22.1-41.fc7


    rpm -qa | grep qt
    pinentry-qt-0.7.2-14.fc7
    qt-3.3.8-4.fc7
    avahi-qt3-0.6.17-1.fc7
    scim-qtimm-0.9.4-7.fc7
    poppler-qt-0.5.4-7.fc7
    dbus-qt-0.70-1.fc7
    qt-designer-3.3.8-4.fc7
    qt-devel-docs-3.3.8-4.fc7
    qt4-x11-4.3.0-9.fc7.1
    qt-devel-3.3.8-4.fc7
    qt4-4.3.0-9.fc7.1

    Xorg log error:
    (II) fglrx(0): driver needs X.org 7.1.x.y with x.y >= 0.0
    (II) fglrx(0): detected X.org 7.1.0.0
    (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed! *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO) *
    (WW) fglrx(0): * no 3D acceleration available *
    (WW) fglrx(0): ********************************************* *
    (II) fglrx(0): FBADPhys: 0xd0000000 FBMappedSize: 0x08000000
    (==) fglrx(0): Write-combining range (0xd0000000,0x8000000)
    (II) fglrx(0): FBMM initialized for area (0,0)-(1280,8191)
    (II) fglrx(0): FBMM auto alloc for area (0,0)-(1280,1024) (front color buffer - assumption)
    (II) fglrx(0): Largest offscreen area available: 1280 x 7167
    (==) fglrx(0): Backing store disabled
    (==) fglrx(0): Silken mouse enabled
    (II) Loading extension FGLRXEXTENSION

    I think this will be fixed with the kernel module properly installed.

    Thanks again for any input on these issues. The thing I really need some help on is the reason for the blank screen prior to a logout, or why x won't restart.

    Thanks in advance,

    Adam

  • #2
    fglrx doesn't work with xen out-of-the-box. Why are you using a xen kernel anyway?!

    Try using this patch.

    Do you need instructions for the patching?
    1. try to install fglrx (it fails)
    2. cd /lib/modules/fglrx
    3. copy the patch from the link to a file (say.. patch.diff)
    4. patch -p0<patch.diff
    5. cd build_mod&&./make.sh&&cd ../&&./make_install.sh

    Question 1: as you will see below it does the kernel module installation for the 2.6.20-2925.13.fc7xen kernel which is not the latest release. I have the devel pkg installed for that kernel, but the kernel core 7 comes with and defaults to is 2.6.22.1-41.fc7. How can I get it to work with the latest kernel headers instead?
    ehmm...I have no idea what you wanted to say. Is your running kernel 2.6.22, but your kernel sources tree 2.6.20? Try to...rephrase.

    Hope that helps.

    Comment


    • #3
      Thanks for the patch, it worked like a charm for compilation. However when I went to do the install script. I recieve this error, which makes no sense to me.

      ./make_install.sh
      - recreating module dependency list
      - trying a sample load of the kernel modules
      FATAL: Module fglrx not found.
      failed.


      Originally posted by Xipeos View Post
      ehmm...I have no idea what you wanted to say. Is your running kernel 2.6.22, but your kernel sources tree 2.6.20? Try to...rephrase.
      The thing is, I don't want to run the xen kernel, i want to run the 2.6.22 fc7 kernel. That is the kernel that i normally run anyway. But, the ati install script chose to install using the 2.6.20 xen fc7 kernel for reasons. That was the purpose of that question. I want to know how i can make it compile for the 2.6.22 kernel instead of the xen kernel.

      My instinct on this tells me that they do a find in the module directory and take the top value, or the oldest kernel module, which would be the 2.6.20 xen kernel. I don't want to to delete the xen kernel. I just want it to compile the modules for the 2.6.22 kernel.

      Thanks again for your help.

      Adam
      Last edited by aja2002; 08-07-2007, 02:34 PM.

      Comment


      • #4
        Originally posted by aja2002 View Post
        Thanks for the patch, it worked like a charm.
        I didn't write the patch. Glad it helped though.

        Originally posted by aja2002 View Post
        My instinct on this tells me that they do a find in the module directory and take the top value, or the oldest kernel module, which would be the 2.6.20 xen kernel.
        That made me laugh so much It actually looks at whatever is linked to /usr/src/linux, as that's where the kernel build environment is supposed to be located/linked. Maybe you have the same "problem" as this guy (read the last post for the "solution").

        EDIT: response to your edit. It can't load the module because it's installed in a different folder. Different kernel versions get different /lib/modules/xxx folders. So your 2.6.22 kernel will look in /lib/modules/2.6.22 but the installer put the module in 2.6.20xen (the same version as the build environment). Don't try to copy/move it because it most likely won't work. Read above and relink your kernel build env.
        Last edited by Xipeos; 08-07-2007, 02:43 PM.

        Comment


        • #5
          That was totally it. I built the pkgs and installed the rpms, and everything is working quite nicely now.

          By the way i realized what the problem was with the make_install.sh, i had a conflict with another package that revealed itself when i was installing the rpms. So people check your pkg dependencies.

          Thanks man, good looks.

          Adam

          Comment

          Working...
          X