No announcement yet.

Ubunty Gutsy Tribe 3 fglrx problem / Asus M2A-VM HDMI

  • Filter
  • Time
  • Show
Clear All
new posts

  • Ubunty Gutsy Tribe 3 fglrx problem / Asus M2A-VM HDMI


    I previously ran Fedora Core 6 with an ATI gfx and i know there is some trouble with the ATI driver on linux, but i upgraded my computer to Asus M2A-VM HDMI motherboard, with an on board Radeon X1250, i couldn't get Fedora 7 to run the fglrx driver, but neither couldn't i get it to work on my old system, with an 9600XT, so i thought i want to try Ubuntu, it worked fine with 2GB ram. Maybe i have to mention i have 4GB ram so i have to run 64Bit, and i had some trouble to get it to work because a problem in the SB600 chipset that said, that the sata controller could run 64Bit, when i couldn't. But anyways i couldn't get Feisty to run with the kernel have fixed the sata problem) with the fglrx driver, it just turned into black screen when it should show the login screen, so i thought it could be a problem with the ubuntu restricted modules, so i upgraded to Gutsy (i know it is still an alpha) and i worked 1 time, after an reboot it didn't work with the kernel it installed 2.6.22-8 i just got black screen again. s? it didn't help, but when i boot with i works fine, but without Direct Rendering, or it almost work fine, after the last reboots it began to flicker the screen sometimes.
    Hope someone have a solution.

    (Sorry for my bad English, if there is something you want to get explained, so say so)

    Rasmus Pedersen

  • #2
    I'm not familiar with ATI or Gutsy (yet), but have you tried just upgrading the fglrx module instead of using the ones included in the restrcted modules package? There may be a more recent version available that hasn't made it into the repositories.


    • #3
      I've downloaded the driver from ATI and build the package for gutsy, installed it, build and installed the kernel module, restarted X and i got black screen and i can't switch to console or nothing it's just freezes. And no errors in Xorg.0.log it just stops after "[DRI] installation complete"

      If i disable the DRI module in my xorg.conf i can login to X. But then it uses the Mesa driver. so i suspect there it has something to do with the DRI module.

      BTW. it was exactly the same thing that happened in Feisty


      • #4
        I have similar experience with ASUS M2A-VM and UBUNTU 7.04. I checked the ATI accelerated graphic driver in Restricted Drivers Manager. After reboot I have got a black screen. I returned to VESA in rescue mode.
        The next time I checked the ATI driver and then run these two commands:
        sudo aticonfig --initial
        sudo aticonfig --overlay-type=Xv
        These time it worked OK after reboot.

        I found the solution at this link:


        • #5
          The instructions are really interesting to read, but I would never follow em Worth to mention that the aticonfig tool does not really write beautyful xorg.conf files. I prefer sed/perl expressions to write the correct options. I added Ubuntu support to my fglrx script a while ago - at that time the only way to use the ati-installer on newer Ubuntu systems with dash as default was to change the symlink to bash. I fixed the installer on the fly... Lateyly I added autochangeing of the sources.list as I require module-assistant from universe - the script is so generic that it does not only work on Kanotix, but on Debian and Ubuntu too. And maybe on others which are compatible. What I don't like on Ubuntu is that there is no way to boot the live cd in a "nice" way without starting X. Only the stupid single user mode workaround can be used - and i have a gfx card that will not work with ati or vesa driver. Next time you can just run this:

          As the latest drivers do not always work, you can specify any older (basically newer too) release with -v option like

          sudo sh -v 8.39.4

          Login into vt1 (ctrl-alt-f1) to execute script. What is not supported is the mixed use of the Ubuntu restricted modules package and this script. Best never touch it...


          • #6
            Originally posted by Kano View Post
            Next time you can just run this:

            I registered just to say thanks. You're the best man. This post saved me huge headaches.


            • #7
              motherboard and 4gb of memory


              It's the motherboard's inability to properly do IO when it has 4gb of memory. I was pulling my hair out trying to make the ati video driver work, then when I tried to switch Linuxes, I couldn't see the SATA drive.

              I noticed an article about the SATA driver couldn't do DMA properly above a certain memory address when there was 4gb of memory. I pulled 2 dimms and everything works.

              I made a support ticket with ASUS about this.


              • #8
                I use Fiesty 7.04 Xubuntu 64-bit on Biostar 690G motherboard with 2GB RAM and have no problems at all.
                Using only Fiesty fglrx inside distribution and works

                Yes, I tried Gutsy and I want to say:
                Don`t!. it is testing version for developers only,
                use 7.04 for everyday use.