No announcement yet.

AMD Catalyst 11.10 is out.

  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Originally posted by Kano View Post
    When you install deb packages you dont get an uninstall script.
    It is good or bad

    it is safe remove here is anyone tested it maybe safe then rm or purge


    • #62
      Originally posted by AozRoon View Post
      I am running a HD5850 card on a kubuntu 11.10 64bits OS.

      After installing the catalyst drivers (11.9 or 11.10) I can no more log in. Actually, after installation & reboot, I reach the login screen and if I fill the user/password and press return, I see quickly a black screen and then go back to the login screen.

      Notice that juste after installation, I get the following message if I try a :
      $sudo aticonfig --initial -f
      aticonfig: error while loading shared libraries: cannot open shared object file: No such file or directory
      Even :
      $amdcccle: error while loading shared libraries: cannot open shared object file: No such file or directory
      Any idea to fix that ? Thanks !
      Have you installed all the necessary packages? Especially the 32 bit ones?


      • #63
        Have you installed all the necessary packages? Especially the 32 bit ones?
        Yes, the 32bit package is installed.

        I did not generate the .deb but did an automated installation (as I am always doing since kubuntu 8.04...). Could it come from this ?


        • #64

          You dont need the script as you can simply uninstall the packages.


          • #65
            Originally posted by chronniff View Post
            I'm just curious as to whether we do have the same problem, because I agree if its not just happening on my system then something could be wrong with the build scripts, and u would be second person to confirm this issue besides myself
            After removing of directly installed driver I can not install Catalyst 11.10 anymore - nor DEB-packages installation nor direct installation doesn't work for me anymore. Then there is probably something broken not only in package generation script but also in uninstall script. No one version of Catalyst before doesn't make so many troubles for me.


            • #66
              Do you used this to make deb files. Working fine here in 32bit and x64 clean install. It maybe safe remove old debs from software center or from synaptic.
              Create .deb packages.

              $ sudo sh ./ --buildpkg Ubuntu/oneiric

              You maybe have broken packages try to fix them, unfinished intstall. Is card detected $ fglrxinfo


              • #67
                didn't work for me either

                The best way to install fglrx script is with Kano's script, IMO. So, I downloaded last script to install fglrx from Kano's site, then executing the script. The result is out of sync for my monitor.

                Then grabbing the driver directly from amd site, and installing it directly (sh ati...) with the same result.

                A pity, cause driver prior to this one is work for me.

                Anyone can help? Kano? Bridgman? Anyone?


                • #68
                  after installing from amd website with sh

                  before reboot
                  try also sudo aticonfig --initial or amdconfig --initial
                  so it will write new xorg.conf

                  worked for me perfectly that way when i used amd cards
                  alltho every time kernel update happens u will have to install driver again.
                  in that case deb packages are better imo, tho i didnt have success with deb packages somehow.


                  • #69
                    if you guys have problems Ubuntu 11.10 with login screen unable to log in because no screen simply go to restart pc in then in crub edit GFX simply RENAME plaplaGFX and force to boot F10 key. It helps to go login screen with picture and uninstall or reinstall drivers when needed.

                    Dont forget aticonfig --initial -f


                    • #70
                      @xpander: Well, if you don't know, kano's script does the magic for you (make ke deb packages, running aticonfig, among others).
                      @Margus: debian testing 64bit on KDE 4.6.5 here.