Announcement

Collapse
No announcement yet.

Using fglrx under Debian

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Using fglrx under Debian

    Okay guys, this is what I never expected to do: I ask you for help installing fglrx properly on Debian.

    A year ago, I never had problems with this. Then I used scripts from Kano (Kanotix) and after that from h2 (Sidux) to install fglrx and never had problems.

    For some reason I now want to install them myself again. These are the steps I've tried with Debian/sid and Debian/etch.

    ###.1

    Install kernel headers, fakeroot, dh-make, gcc, and all other stuff listed on several sites. Then dl the driver from AMD.

    ###.2

    As root, I create the packages with
    sh ./ati....run --buildpkg Debian/etch (or sid)
    Then install fglrx-driver, fglrx-kernel-source and fglrx-amdcccle.

    ###.3

    m-a prepare
    m-a update
    m-a a-i fglrx
    depmod -a

    The kernel module gets built succesfully and installed without any errors.

    ###.4

    I tried both, aticonfig --initial and just change the driver to fglrx. Then add

    Section "Extensions"
    Option "Composite" "Disable"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "off"
    EndSection

    ###.5

    modprobe fglrx - it gets loaded without errors and
    init 5 again / start kdm.

    --- black screen ---

    I tried some things with linking this and that, with installing fglrx-driver_dev and more... it not even runs with Mesa.

    What else could I do?

    Btw.: is the ATI Installer fixed for Debian? All sites advise you to create debs. I didn't have problems installing it with the ATI Installer but I had the same problems. Is it still broken?

    - d2kx

  • #2
    Not sure about what's causing your problem. I'm guessing you're running non-1.3.0

    If you are running xserver 1.3.0, there's your problem.

    You didn't mention any error in the xorg log, so I'm guessing it's just dying on you without error? What you describe is the classic description of the incompatibility of fglrx on xserver 1.3.0 but it's not in etch (stable), just sid (unstable) and lenny (testing)

    As for creating debs, highly recommended. Let the package management system handle your actual changes to the system. Back up the debs if you need to switch rapidly between various packaged versions. And so on.

    Worked for me with 8.37.6; haven't tried 8.38.7 and don't intend to upgrade my fglrx until I can also upgrade my xserver.

    Anyway, if it is a 1.3.0 problem and you need the old version of the xserver for downgrade purposes, this page should have an appropriate 1.1.1 build handy.

    Comment


    • #3
      Etch has Xorg Server 1.1.1, Sid has 1.3. Both had the same error. I already tried the Option "MonitorLayout" "Auto,Auto". Just Black Screen, but my BenQ FP71V+ doesn't switch off/standby.

      I think I should install fglrx with the scripts I talked about earlier and then have a look at the Xorg.conf. It works fine on Xorg Server 1.3.

      Comment


      • #4
        Originally posted by d2kx View Post
        Etch has Xorg Server 1.1.1, Sid has 1.3. Both had the same error. I already tried the Option "MonitorLayout" "Auto,Auto". Just Black Screen, but my BenQ FP71V+ doesn't switch off/standby.
        On my side, I run 8.38 on Debian/sid using the method you mentioned without much problem (e.g. the usual bunch of flgrx bugs)

        When I start X I get a black screen for several seconds, but the display comes on. The black screen is long enough for my LCD display to power off.

        HTH

        Comment


        • #5
          I had a similar problem with etch too. To fix it I either could use the fglrx version from non-free or recompile the kernel with a newer version of libstdc++5. I did not have any problems with the kernel I compiled using the latest from etch's repo (3.3.6) and fglrx 8.39.4.

          I hope this helps.

          Comment


          • #6
            Originally posted by Shae View Post
            I had a similar problem with etch too. To fix it I either could use the fglrx version from non-free or recompile the kernel with a newer version of libstdc++5. I did not have any problems with the kernel I compiled using the latest from etch's repo (3.3.6) and fglrx 8.39.4.

            I hope this helps.
            Yes, it helped. Thanks a lot! I just installed libstdc++5 and recompiled the module.

            Comment

            Working...
            X