Announcement

Collapse
No announcement yet.

Sampling info about that mouse freeze bug

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • PsynoKhi0
    started a topic Sampling info about that mouse freeze bug

    Sampling info about that mouse freeze bug

    Ticket on the unofficial bugzilla: http://ati.cchtml.com/show_bug.cgi?id=141

    I'd like to make a thread a bit more structured than the comments gathered here and there on this forum, in order to pin down possible causes.

    Could anyone using fglrx in here please post the following info:
    Affected by the bug: Yes/No
    Graphics card:
    Number of displays:
    Distribution (name, version, architecture):
    Desktop environment:
    Compositing: On/Off
    fglrx version(s) I've used on that distribution, with that bug:
    fglrx version(s) I've used on that distribution, without that bug:
    ATI Catalyst Control Center settings:
    Things I've tried to solved it (if affected):
    Affected by the bug: No
    Graphics card: HD4670 512MB
    Number of displays: 1
    Distribution (name, version, architecture): openSUSE 11.4 64bit
    Desktop environment: KDE
    Compositing: Off
    fglrx version(s) I've used on that distribution, with that bug: none
    fglrx version(s) I've used on that distribution, without that bug: 11.3 through 11.7 (from AMD's website)
    ATI Catalyst Control Center settings: Default
    Things I've tried to solved it (if affected): obviously none, though my first thought would be to try using SWCursor
    Last edited by PsynoKhi0; 07-30-2011, 06:37 PM.

  • Michael_S
    replied
    Originally posted by PsynoKhi0 View Post
    Sorry, missed that:
    Code:
    sudo service gdm stop
    Replace gdm with the appropriate session manager (kdm, lxdm...) if needed.

    Summing up so far:
    It seems to affect desktop cards based on the HD5000 and HD6000 series, on distributions shipping kernel 2.6.38 and later, with fglrx version 11.5+

    More input appreciated!
    Thank you! I stopped gdm, installed the 11.8 driver, restarted, and everything is fine. Sweet!

    My hat is off to anyone who contributed to fixing the problem, either by information gathering or helping to write the fix. Thanks!

    Leave a comment:


  • hag1976
    replied
    Affected by the bug: Yes
    Graphics card: HD5770
    Number of displays:1/2
    Distribution (name, version, architecture):Kubuntu 11.04
    Desktop environment: kde
    Compositing: On
    fglrx version(s) I've used on that distribution, with that bug: 11.5-11.8
    fglrx version(s) I've used on that distribution, without that bug:
    ATI Catalyst Control Center settings:
    Things I've tried to solved it (if affected):

    The bug affects me only when I connect only one display to the card to the DVI connector /only the monitor - a Philips LCD/. When I connect a second display to the hdmi connector /a LG LCD TV/, the bug does not affect me on my primary display. /clone or multiple displays - it doesn't matter/

    Leave a comment:


  • NTICompass
    replied
    Originally posted by Dandel View Post
    Just a quick update... Installing Catalyst 11.8 fixes the issue completely. (even with hardware cursor enabled)
    Confirming this. 11.8 fixes the problem for me on Gentoo x86_64 (kernel 3.0.1-gentoo).

    Leave a comment:


  • Dandel
    replied
    Originally posted by Dandel View Post
    Affected by the bug: Yes (whenever i move the mouse to the lower right corner)
    Graphics card: HD5770 1024MB
    Number of displays: 1
    Distribution (name, version, architecture): Ubuntu 10.10 (amd64)
    Desktop environment: Gnome
    Compositing: On and Off (No change)
    fglrx version(s) I've used on that distribution, with that bug: 11.5 TO 11.7 (AMD'S website )
    fglrx version(s) I've used on that distribution, without that bug: 11.3 through 11.7 (from AMD's website)
    ATI Catalyst Control Center settings: Default
    Hardware Cursor Enabled: Yes.
    Things I've tried to solved it (if affected): Disabled Tear-Free (no help), and use composition free desktop (no help)
    Just a quick update... Installing Catalyst 11.8 fixes the issue completely. ( even with hardware cursor enabled )

    Leave a comment:


  • xpander
    replied
    Originally posted by xpander View Post
    Affected by the bug: No
    Graphics card: HD 5770 1GB
    Number of displays: 1
    Distribution (name, version, architecture): Linux Mint 11 x86_64
    Desktop environment: Gnome 2.x
    Compositing: On and Off
    fglrx version(s) I've used on that distribution, with that bug: 11.5, 11.6, 11.7
    fglrx version(s) I've used on that distribution, without that bug: 11.4, 11.8, OpenGL4.2 Beta driver
    ATI Catalyst Control Center settings: default , with/without tearfree and vsync
    Things I've tried to solved it (if affected): installed 11.8
    corrected mine

    Leave a comment:


  • RussianNeuroMancer
    replied
    Not only for you. In other forums peoples also reports the same.

    Leave a comment:


  • Amrod
    replied
    Originally posted by Amrod View Post
    PC

    Affected by the bug: No
    Graphics card: HD5770 1GB
    Number of displays: 1
    Distribution (name, version, architecture): Slackware64, current, x86_64 multilib
    Desktop environment: Enlightenment DR17
    Compositing: Off
    fglrx version(s) I've used on that distribution, with that bug: 11.5, 11.6
    fglrx version(s) I've used on that distribution, without that bug: <= 11.4 , 11.8
    ATI Catalyst Control Center settings: default setting
    Upgrading to 11.8 solved the problem only to me?

    Leave a comment:


  • NTICompass
    replied
    Affected by the bug: Yes
    Graphics card: XFX Radeon HD 5770
    Number of displays: 1
    Distribution (name, version, architecture): Gentoo amd64 (2.6.39-gentoo-r3)
    Desktop environment: GNOME 2
    Compositing: On
    fglrx version(s) I've used on that distribution, with that bug: 11.6,11.7
    fglrx version(s) I've used on that distribution, without that bug: Haven't tested
    ATI Catalyst Control Center settings: Default
    Things I've tried to solved it (if affected): Disable v-sync (didn't work)
    Last edited by NTICompass; 08-15-2011, 10:30 PM. Reason: Added kernel version

    Leave a comment:


  • xpander
    replied
    got it working allready with Kano's Script
    thx!

    Code:
    #!/bin/sh
    DRIVER=/usr/lib/xorg/modules/drivers/fglrx_drv.so
    for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
     sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER
    done
    no more "Testing Only" watermark :P


    btw couldnt edit my previous post

    Leave a comment:

Working...
X