No announcement yet.

CrossfireX refuse to work (X)Ubuntu 11.04

  • Filter
  • Time
  • Show
Clear All
new posts

  • CrossfireX refuse to work (X)Ubuntu 11.04

    im trying to get a 5770 and 5750 to run in CrossfireX in Xubuntu and Ubuntu 11.04 as well.
    Official AMD drivers cannot be used, because they are bugged. The bug is that when you move your mouse cursor to the lower right section of the screen you will get a 3 second frame freeze.
    Proprietary drivers dont show this malfunction.
    Aticonfig and AMDCCCLE are not able to set up a CrossfireX configuration.
    Upon using aticonfig --initial the following message appears:
    Fail to link to, please check whether driver is installed correctly
    Upon using aticonfig properly to set up a CrossfireX configuration --lscs reports:
    Candidate Combination:
    Master: 1:0:0
    Slave: 2:0:0
    CrossFire is disabled on current device
    CrossFire Diagnostics:
    CrossFire can work with P2P mapping through GART
    No matter how i try, CrossfireX remains disabled.
    In AMDCCCLE the second device 5750 remains as an unknown adapter, while the active display and device are properly used and displayed.


  • #2
    Originally posted by oldskool69 View Post
    Official AMD drivers cannot be used, because they are bugged. The bug is that when you move your mouse cursor to the lower right section of the screen you will get a 3 second frame freeze.
    Proprietary drivers dont show this malfunction.
    The official AMD drivers *are* the proprietary drivers (in the sense that we officially *release* proprietary drivers while we only officially *contribute* to the open source drivers). Do you mean that the open source drivers don't show this malfunction ?


    • #3
      well, if the catalyst drivers from the amd website and the proprietary driver, which needs to be activated in natty, are the same, then maybe the last working version number withhout that bug is 11.4. is also bugged in proprietary drivers.

      if the drivers are the same, why do i have better performance with proprietary 11.4 than with catalyst 11.4 built for natty?

      i have crossfire, why cant i use it? why wont ati and linux not let me use or even configure it?

      why isnt KMS nor xorg.conf able to detect and configure all devices properly? i spent DAYS trying hard!

      if you can tell me, how to get crossfire working, id be very happy, but i think that wont happen, because, at the time linux, as well as amd programmers, just don give a shit about it.

      i mean, you make 3 driver versions with an invisible logo bug that freezes up a pc?

      you guys are just worst shit the internet has ever witnessed, fuck ati and fuck amd.

      i give a shit about ati and crossfire until its supported in 5 years, when noone needs it, because actually noone ever needed it.

      and if you need it, it wont work, coz your fucked from behind by linux and ati secretly and efficiently.

      actually there are MANY applications that are running so BAD or slower in crossfire-mode, while in single mode they run ok or faster - its hilarious.

      hail to nvidia! im gonna sell my fucking ati cards!

      thread closed.
      Last edited by oldskool69; 07-30-2011, 09:44 AM.


      • #4
        Welcome to Phoronix!
        fglrx work flawlessly in openSUSE here.
        Have a nice day.

        Sarcasm aside: spouting insults and cursing when people offer their help is a poor decision.
        If you have a problem with the mouse freeze, take it here:
        Last edited by PsynoKhi0; 07-30-2011, 06:14 PM.


        • #5
          FWIW, crossfire does not work out of the box, at least with 11.04. You have to manually create a crossfire chain, and reboot (not just restart X) for the cards to be crossfire-enabled, the little 'diagnostic' box remains blank no matter what. Overclocking and fan control will only be possible on the master card after that.

          I don't know what OpenSUSE does to work around the fglrx braindamage but I'll give it a shot to see if it works flawlessly for me too -- in Ubuntu fglrx is simply awful and gets worse throwing crossfire into the mix. I had the same issues OP is reporting and then some, but I've been able to work around most of them, at least using one of my two GPUs.

          While the OP failed to google for the problem the solution is there in aticonfig help, right there under "Multiple display adapter options:" It isn't easy, but it is possible to get crossfire to half-assedly limp along under Linux. But really, you should do research BEFORE buying hardware. It's unreasonable to buy hardware, try it, find it isn't supported on Linux and then rage. It wouldn't have taken much to discover crossfire + linux = a multi-week journey of discovery, experimentation and ultimately disappointment.

          And is reporting bugs on an unofficial bugzilla going to help in any way? I think hope and prayer would be just as effective if not more so.


          • #6
            Originally posted by v8envy View Post
            And is reporting bugs on an unofficial bugzilla going to help in any way?
            Much better approach than insulting people.

            If you have an issue with the mouse freeze thingie, make sure you post a reply in the post I've recently created regarding that, might be able to see some pattern.


            • #7
              ahahaha, i googled everything there is regarding crossfire and linux! and i tried everything!

              i also configured it the ways you mentioned, but its still not working, because it simply cannot work!

              in windows crossfire is working, yeah, but not in linux. only one of the two cards is working.

              get real, dudes.

              i insulted amd for their poor support and they deserve it.

              3 driver versions with an invisible logo freeze bug?

              11.8 will come out and it will still have the bug.

              i wonder why noone of you cant post a true method of enabling crossfire and running it verifiable?
              Last edited by oldskool69; 08-01-2011, 11:27 AM.


              • #8
                i just installed nvidia driver on ubuntu 11.04 on a samsung laptop dual core with nvidia 9200M gs and two monitors, and after a while all worked nice...

                im sorry ati, i aprreciate your performance under windows, i must say!

                and maybe there is an easy way to get crossfire working...

                teh laptop got 60fps in glxgears :O !!!


                • #9
                  And obviously Eyefinity Crossfire works

                  So you might just have done something wrong?

                  Forgot to run aticonfig after making changes to xorg.conf maybe?
                  Last edited by PsynoKhi0; 08-02-2011, 02:58 PM.


                  • #10
                    well i ran aticonfig like 300 times in the last days?

                    but, whats the exact configuration for crossfire?

                    sudo aticonfig --crossfire-plz=on???

                    its not mentioned anywhere!

                    as a result, any aticonfig combination you can try doesnt work...