Announcement

Collapse
No announcement yet.

AMD 8.37.6 -- The no R600 or AIGLX Support Version

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Michael
    started a topic AMD 8.37.6 -- The no R600 or AIGLX Support Version

    AMD 8.37.6 -- The no R600 or AIGLX Support Version

    The AMD/ATI fglrx 8.37.6 driver is now available... It contains X server 1.3 naming fix, AMDCCCLE v1.0 (adds translations and the 3D page), RHEL5 support, and some random fixes.

    https://a248.e.akamai.net/f/674/9206...ux_8.37.6.html

    Originally posted by Phoronix
    It was a year ago that AMD/ATI had delivered the fglrx 8.25.18 display driver, which corrected a bug causing issues with the Radeon X1000 512MB video cards, added new product support, and squashed a variety of other bugs. Well, today AMD delivered the 8.37.6 Linux display driver. Affecting this driver the most is support for X server version 1.3 and appended several other fixes along with a slight upgrade to the AMD Catalyst Control Center Linux Edition. While no AIGLX support was added or no new features introduced, the upgrade should be worth the time
    http://www.phoronix.com/vr.php?view=10069


    FEDORA USERS, READ THIS
    Okay, here's the scoop on Fedora 7. WIth AMD fixing the X 1.3 problem, the drivers will build. However, when you install the RPMs for Fedora 7, aticonfig will crash and will remove your xorg.conf (though the original is renamed). If you manually update your xorg.conf and then restart X, fglrx will fail to load and you'll find a backtrace in your Xorg.0.log. So if you need the fglrx drivers to survive, don't upgrade to Fedora 7 just yet. Stay tuned to the forums for more information. This issue with 8.37 should not cause problems with Fedora Core 6 or previous versions.

  • Michael
    replied
    Originally posted by Alistair View Post
    Michael: Direct question for the ATI folks if you could

    Given a working and functional setup that gets my ATI X1650Pro AGP 512Mb card up and running with opengl and fglrx drivers in xorg,
    WHY is it that although glxgears and fgl_glxgears indicate the x1660pro card is producing 1.5 to 1.75 times the framerate of my 9600 agp card in default size, when I am playing World Of Warcraft in full screen on 1440x900 screen the x1650Pro agp card runs at about 1/2 to 1/4 the framerate of my ATI 9600 card?

    I will note that the framerates in wow **when in small enclosed areas** or when ** looking straight up at the sky ** on the x1650Pro are 1.3 to 1.5 times faster. I am using the configuration (bios agp gart=512, video vram=256 in boot command line and xorg.conf maxgartsize=256) that works to get opengl working on the 1650pro to run the the 9600 --

    I've got AGP 8x mode enabled on the x1650pro but somehow I get the idea that areas with lots of textures or texture work to be done are the cause of the dropoff in framerate. I am currently running the 8.37.6 drivers - and in fact have reasonable confidence in them as they have subtly improved the quality of my 2D rendered objects (my desktop fonts are clearly smoother and sharper than on 8.35, although fonts in things like Konsole and kwrite dont appear to have benefitted as much as fonts on webpages and on kicker components)

    not that I'm whining (much) but I'm suspecting that this is a code path issue and likely fairly easy to resolve.
    Have you tried any Linux native games other than using WINE/Cedega to compare the performance? Cedega and the fglrx drivers haven't been best mates. In a game like Quake 4 or Enemy Territory you should notice improved performance.

    Leave a comment:


  • Alistair
    replied
    truely odd behaviour of PCIE based AGP card in linux

    Michael: Direct question for the ATI folks if you could

    Given a working and functional setup that gets my ATI X1650Pro AGP 512Mb card up and running with opengl and fglrx drivers in xorg,
    WHY is it that although glxgears and fgl_glxgears indicate the x1660pro card is producing 1.5 to 1.75 times the framerate of my 9600 agp card in default size, when I am playing World Of Warcraft in full screen on 1440x900 screen the x1650Pro agp card runs at about 1/2 to 1/4 the framerate of my ATI 9600 card?

    I will note that the framerates in wow **when in small enclosed areas** or when ** looking straight up at the sky ** on the x1650Pro are 1.3 to 1.5 times faster. I am using the configuration (bios agp gart=512, video vram=256 in boot command line and xorg.conf maxgartsize=256) that works to get opengl working on the 1650pro to run the the 9600 --

    I've got AGP 8x mode enabled on the x1650pro but somehow I get the idea that areas with lots of textures or texture work to be done are the cause of the dropoff in framerate. I am currently running the 8.37.6 drivers - and in fact have reasonable confidence in them as they have subtly improved the quality of my 2D rendered objects (my desktop fonts are clearly smoother and sharper than on 8.35, although fonts in things like Konsole and kwrite dont appear to have benefitted as much as fonts on webpages and on kicker components)

    not that I'm whining (much) but I'm suspecting that this is a code path issue and likely fairly easy to resolve.

    Leave a comment:


  • Michael
    replied
    Originally posted by Xipeos View Post
    Then perhaps it's a kernel problem? If that's the case then you can probably use the vanilla kernel (unless it breaks some drivers/features specific to fedora).
    Not a kernel problem.

    Leave a comment:


  • Xipeos
    replied
    Originally posted by lenrek View Post
    He is talking about FC7, and it is a known problem, at least for now.

    http://www.phoronix.net/forums/showthread.php?t=3085
    Originally posted by Michael
    They are not X.Org related and I will explain more in the very near future
    Then perhaps it's a kernel problem? If that's the case then you can probably use the vanilla kernel (unless it breaks some drivers/features specific to fedora).

    Leave a comment:


  • lenrek
    replied
    Originally posted by Xipeos View Post
    ...
    This, of course, only if you're not too lazy or incapable of departing from your distro setup tools.
    He is talking about FC7, and it is a known problem, at least for now.

    http://www.phoronix.net/forums/showthread.php?t=3085

    Leave a comment:


  • Xipeos
    replied
    Originally posted by fanATic View Post
    You're completely right gfxdrone.ATI or AMD had enough time,don't care for merging.It's their tradition,lousy linux support.They already had their punch with detonators and this wake them up from dreams for making catalyst drivers.First of all, I don't even like name of drivers "frgl" (it reminds me of fireGL and Quadro line).Second, on their driver page, on linux driver's, Radeon X1950 (pro)is not listed, unlike on Windows tm's driver page.Again no AIGLX and,yes Michael no Xorg 7.2 support
    .I already try it.I will install FC7.Now I will sell my X1950pro and buy some nVIDIA instead (it seems now,no use of my 975XBX2 crossfire support ),maybe some 7100,7200 or something turbocache(no hypermemory warp speed) crap.At least I will have AIGLX and 3D support.I can run beryl on my noFX5200(Dawn)-64 MB card.So what is use of my powerful RV570? Only on XP,Vista? No thanks.Maybe improvement around folding@home, nice job ATi or maybe AMD, M$ is proud of you.
    And by the way nVIDIA drivers are some 13 MB's comparing to whoping 50 ATI's.So what's the problem CLI kind of driving.No problem for me.
    The fglrx driver DOES support X.org 7.2 and the installer should work without problems. For pre 8.37.6 drivers, you just had to "export X_VERSION=x710" before running the installer (doesn't anyone read those output messages?!), but the new one detects "X.org 7.1 or later"

    This, of course, only if you're not too lazy or incapable of departing from your distro setup tools.

    Leave a comment:


  • DarkFoss
    replied
    Personally I find these drivers to be better than any since the 8.28.8's.. glxgears went from 125 to over 2k
    Flatout under Cedega is smoother fps dipped to 44 but hovered around 70+ for the most part, although there is still plenty of pop-ups and missing textures. PPracer was a steady 125 fps aa enabled.. I haven't tried vid playback yet..

    For me these are keepers

    Leave a comment:


  • yoshi314
    replied
    ati really needs to get it together. i find it hard to believe in what is written in development cycle article.

    maybe the monthly release cycle is too frequent for linux team to actually implement *something* within the drivers.

    Leave a comment:


  • Nicolas
    replied
    Well. That was another useless driver release for me (and for most people).

    But hey, AMD/ATI development cycle shows that a driver version takes 11 weeks, due to testing and bla bla bla.

    I guess they have about 4 developers there:
    The first develops the "to-be-realeased" driver.
    The second developes the "next" version.
    The third pretends to test the drivers.
    And finally the fourth is on it's own on the "incredible new OpenGL driver".

    Jokes apart, I'm deeply disappointed, but I kind of expected this.

    I guess we just got confirmation that we will continue to receive monthly useless driver updates.

    By the time they implement AIGLX support, I really hope I have already updated my notebook, and I definitelly won't buy ATI anymore. I don't have any hope anymore, and I use Linux about 10 hours per day.

    I'm a developer and I really fail to understand why does it take SO LONG to solve the common problems that people have been pointing out for MONTHS already (if not years?). AIGLX can't be that hard to take months for them to start doing something. nVidia solved this problem quickly. My friend's running integrated Intel cards use AIGLX with no problems AND DECENT performance. I bet even with the ultra-slow performance of the AMD/ATI Linux OpenGL implementation, my X700 Mobility must have better performance then an Intel Integrated Video Card.

    I don't care about CCC and anisotropic/antialiasing options. Performance is bad as it is. Anti-aliasing/Aniso would just make things worse.

    Someone posted that AIGLX was useless. I don't think so. User Interface is very important.

    I'll check back when 8.53.6 is released with initial buggy betta AIGLX support...

    Leave a comment:

Working...
X