No announcement yet.

Notes on Acer Aspire One 522

  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Originally posted by PsynoKhi0 View Post
    The configuration discussed here is a bit different though, since it's one of the first CPU+GPU-in-one chips from AMD, while yours is based on the previous platform with IGP on the motherboard
    Ah! Apologies for that! We've only just got the earlier version over this side of the pond, so I was a bit hazy about the full spec!

    But I suspect that the HD problems will be the same, as this seems to be a general lack of interest in making these drivers work. I'm a bit puzzled as to why vdpau seems to be universally supported, but xvba largely ignored.

    Hopefully they'll catch up soon....!



    • #62
      Thats very simple: the xvba sdk was published too late and has never been fixed the way it should be. xvba was introduced about the same time as vdpau but nobody except a few oems could use it. h264 >l4.1 can still not played via the available xvba-video wrapper (there is a check in there if it is too complicated for xvba to avoid a crash). so in order to play a video with h264 l5.1 amd has to fix xvba first and there must be a mod to xvba-video. but as gb left sds who will do that? amd devs on their own, i doubt that...


      • #63
        Originally posted by dothebart View Post
        Currently I still have these problems:

        - if the atheros cable NIC is loaded, and no cable is plugged in, and networkmanager/wicd scans it, the system locks up.
        Digging around I noticed this machine ships with either "broadcom wireless + bluetooth" or "atheros 9285" wireless. In my case with the atheros wireless I can confirm the machine almost crashes instantly if no cable is connected during use or install from the liveUSB session (Ubuntu11.04-64). There is a very easy "FIX" instead of having the cable connected or quickly pressing FN+F3 which never worked for me. I haven't found out myself, but it really works!

        To have no crashes at all, turn on the machine, go in to the BIOS and (re)enable (if you disabled) netboot option. After that change the boot order and make sure the netboot option is selected at the top before everything else. As the second boot option you can choose USB/internal harddisk etc. The only downside is that it takes longer to boot, but wireless and ethernet work together perfect since on the Acer Aspire One 522-C5Dkk, Bios version 1.09 and ubuntu 11.04 64bit.

        Firmware related info:
        I was able to boot Debian-squeeze-live which ships without non-free firmware and I can tell that ethernet and wifi work out of the box :-)! Only the AMD ATI videocard needs atombios... but I can live with that.
        Last edited by walterav; 07-09-2011, 03:08 PM.


        • #64
          no lockup while having etherboot on

          ah, yes turning on the bios networkbooting option seems to work, but not after you're resuming from a suspend to disk :-(

          my workaround was to turn of network manager, which also solves the problem of the system locking up. (which might irretate evolution & friends)
          alternatively, if you don't need the cable NIC, you can simply not load the kernel module for it, and have no lockups either.


          • #65
            FWIW, the atl1c module causes lookups on my Lenovo G575 too (a brazos netbook too).


            • #66

              No wireless issues on this lappy though.


              • #67
                I got one

                Failed to install Ubuntu 11.04, Mint 11, OpenSUSE 11.4, Fedora 15. Can't boot Gentoo LiveCD.
                Finally got it runned with Debian 6. Wireless works fine, wired too. WebCam works.
                Had to install fglrx 11.7 to get 1280*720 resolution.

                Have problems with sound. Only could get sound out of the speaker using VLC(although output set to: default). No headphones. No Totem. No Rythmbox. No sound on u-tube. No sound in Nexuiz.

                Works about 6 hours with wi-fi on.


                • #68
                  Originally posted by Northwood-3179 View Post
                  Have problems with sound. Only could get sound out of the speaker using VLC(although output set to: default). No headphones. No Totem. No Rythmbox. No sound on u-tube. No sound in Nexuiz.
                  Works about 6 hours with wi-fi on.
                  Sound and switching to the headphone works since 3.1-pre2 horay to the alsa guys!


                  • #69
                    fewer problems with aptosid 64 than 32

                    Just bought the machine, aptosid imera xfce 32 bit, experienced radeon and atheros ethernet problem, all solved with "radeon.modeset=0 blacklist=atl1c" added to grub command line - and later to /etc/default/grub GRUB_CMDLINE_LINUX_DEFAULT line and issuing an update-grub.

                    It still can't switch back and forth to text mode, I still have to try proprietary drivers.

                    with aptosid imera 64 bit i don't need to blacklist anything, ethernet seems to work well, no probs switching to wifi and back. Still has the problem with text console.

                    With default drivers one can enable some kde4 desktop fx by choosing the shared memory opengl mode in desktop effects advanced options.

                    imera has Linux 2.6.39-3.slh.1-aptosid-amd64

                    On windows land, the windows7 first run had an app crashing, which didn't compromise the procedure, luckily.
                    7 has a good (apparent) start up time, bad shutdown time, overall it seems more sluggish compared to aptosid + disk encryption.

                    Nice netbook for the price.


                    • #70
                      Kubuntu 11.10

                      If you blacklist the atl1c module then other than the wired ethernet almost everything else works properly using Kubuntu 11.10 beta.

                      The open source Radeon graphics drivers from Xorg work very well. Headphones switch properly.

                      It seems as though the SD card reader does not automount. However it seems to work OK if you plug in a card, start Dolphin and mount it manually.

                      When you plug in say a TV screen using a HDMI cable, the screen size doesn't seem to adjust quite correctly, and sound isn't redirected to the HDMI output as you might expect.