No announcement yet.

Notes on Acer Aspire One 522

  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by Kano View Post

    I never heard about those issues with Kanotix, but if you don't need the broadcom wlan card feel free to send it to me, then i can test it myself. Maybe it is better than the r8192e_pci kernel module which never worked for my current card - only ndiswrapper works with it, but that at least perfectly.
    No... I'm gonna hang on to my BCM4313 TY very much. Or I might sell it to you...


    • #32
      Or just try Hellfire (ask via irc:// or U with that script:

      I do at least blacklist other possible modules in there. In the short way mentioned in this thread this is not done. Basically you can modify my script for rpm based systems too if you know a little bit about dkms. Just use mkrpm instead of mkdeb and then rpm instead of dpkg with correct options. Or make it generic and use dkms install after add with the same options - then it does not create a package (which can be uninstalled more easyly if needed) but still does work with any system that uses dkms.


      • #33

        Btw. accidentally I found out the freezes seem to come from the eth0 (which seems not be a real ethernet device), but not from the wlan0. So if it freezes, try to deactivate/not to use eth0 for a while.

        Will investigate further.


        • #34
          SD Reader working

          I used this advice and my SD reader works now.


          • #35
            Acer Aspire 4253 (AMD APU E350) works great with Ubuntu10.10

            the only thing should notice is that please install the Catalyst 11.1 from AMD support site and do not try the one from ubuntu search


            • #36
              Consider upgrading the ram in AO522


              I've just purchased the Acer Aspire One 522 and i would like to upgrade the ram from 1GB to 2 or 4GB. I cant find any information on the ram at and using their memory finder. Can any one tell me which type of ram are compatible with the Acer AO522.

              Thank you for your time,


              • #37
                re: RAM upgrade

                Read the original post in this thread. I quote the product name/number of a Kingston 4GB SODIMM that worked for me.


                • #38
                  Are you experiencing any issues with the wired network device? The device itself works well, but as soon as it is suspended (e.g. "ifconfig eth0 down"), the machine freeze. Unfortunately this also happens, when a network manager tries to find or to switch between networks (especially wireless vs. wired). My only solution at the moment is, to disable any network manager completely and to connect from the terminal. Test with kernels 2.3.35-2.3.38-rc6 on Gentoo and Ubuntu.

                  Also please can you tell me the status of the sound? Is the internal microphone is working anywhere? Most useful so far is configuring generic hda-intel, but not(!) not activate conexant patch. Still it does not mute internal speaker when I plug-in external headset.

                  Unfortunately no reply on alsa-devel mailing list so far.


                  • #39
                    Description, how to use Linux with Acer Aspire one 522.

                    I compiled a short summary, what is (not) working and how to configure. Still no solution w/ sound and freezes on network shutdown.



                    • #40
                      Does anybody know of any more newbie friendly guides? I took a look at yours, but to be honest, I had trouble understanding what I needed to do. I wanted to get a netbook to familiarize myself with Linux, but I'm starting to think this wasn't the best choice because of how confusing the setup of this one is.

                      I was able to get the video working at the right resolution by installing the proprietary driver that it recommended after I installed ubuntu, and then swapping out the config file with the one from the Catalyst driver, as recommended by a poster elsewhere (I think on the ubuntu forums). When I did that though, I started to get freezing problems. I could use it with the "unsupported hardware" watermark prior to that without freezing issues. I was not running on a wired network, so I do not think my freezing was related to eth0.

                      Specifically, what I don't understand when I follow your guide ( are what I need to do to update the kernel version. (I tried googling this, found several solutions, which I tried without luck) When I followed the steps I found, I ended up in states that would not boot to the GUI, so I always reinstalled ubuntu to revert it back.... I never did get it to completely run. And, my configuration was starting from what the ubuntu installer did, so it wasn't like I had anything special configured (which may have been my problem, who knows).

                      The other thing I have no clue what to do is what to do to set up the graphic settings. In the guide, you say

                      "I use the open source driver x11-drivers/xf86-video-ati (from git repository), which runs well supporting OpenGL, XV and suspend-to-ram. In order to use this driver you will need kernel-2.6.38 (from git-repository) and you need to install the IRQ microcode for r6xx/r7xx/Evergreen Radeon GPUs from x11-drivers/radeon-ucode and link it into the kernel:"

                      I know I don't have the updated kernel yet, so I can't do much here, but once I have that, where do I install the IRQ microcode to / how do I do it? Do I just copy the files somewhere? When I click your link, I see a bunch of .bin files. What do I do with those?

                      I am sorry that this is probably full of newbie questions... I have spent the last 2 days trying to set this up, and I'm at my wit's end. If I can't figure it out soon, I'll probably just go back to Windows. I'm not computer illiterate, I just haven't done much with Linux and hoped to learn, but it's pretty hard to figure out ...