Announcement

Collapse
No announcement yet.

AMD Puts Out A Beta Catalyst Linux Driver For The Public

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD Puts Out A Beta Catalyst Linux Driver For The Public

    Phoronix: AMD Puts Out A Beta Catalyst Linux Driver For The Public

    While NVIDIA puts out beta Linux graphics drivers quite often as a means of soliciting testing prior to declaring a new stable GPU driver update, AMD does not but rather they rely upon their NDA-covered select beta testers to put each Catalyst release through its paces before declaring a stable update in their timed monthly manner. Today though it seems AMD has put out a Catalyst Beta driver that's targeting their workstation customers (those with the FirePro / FireGL / FireMV hardware) but as in their usual unified manner, it will work with any supported Radeon (R600+ GPU) as well...

    http://www.phoronix.com/vr.php?view=OTA0Mg

  • noobish
    replied
    Originally posted by mugginz View Post
    Another thing it still does it when starting video playback via VLC or SMPlayer the monitor connected to the display port goes to black for about a second and then comes back. It's like when the playback software is grabbing a display context or something the driver probes that status of the port which throws the DP->DVI adaptor.
    That's caused by the player, in this case VLC, issuing `xset -dpms` to disable the screensaver. Disable vlc's disabling of the screensaver and it won't blank out. Hopefully AMD will find the root problem and fix it so I don't have to shake my mouse every 10 minutes during a movie

    Leave a comment:


  • PsynoKhi0
    replied
    Originally posted by BlackStar View Post
    It is. The Windows version is written in .Net.
    That I know, that's why I stick to the base driver + ATI Tray Tools.
    Still not getting your Mono pun though heh...

    Leave a comment:


  • mugginz
    replied
    Originally posted by devius View Post
    This may be a problem with compiz. Just a few hours ago I saw a computer with a Geforce GTS250 using the binary drivers exhibit the same behaviour. I don't know if vsync was activated in nvidia control panel though.
    It works fine on my HTPC with a lowly nVidia 8400
    .

    Leave a comment:


  • BlackStar
    replied
    Originally posted by devius View Post
    This may be a problem with compiz. Just a few hours ago I saw a computer with a Geforce GTS250 using the binary drivers exhibit the same behaviour. I don't know if vsync was activated in nvidia control panel though.
    To get vsync in compiz 0.8.x you need to set the correct refresh rate and enable the vsync option in compizconfig-settings-manager. Vsync should be set to application-controlled in the control panel.

    Unfortunately, compiz follows a somewhat uncommon vsync method to improve performance. This works fine on nvidia but is somewhat flaky on fglrx. The 11.1 (final) release is supposed to fix this at last!

    Leave a comment:


  • BlackStar
    replied
    Originally posted by PsynoKhi0 View Post
    Erm what? Please tell me it's just a sick joke.
    It is. The Windows version is written in .Net.

    Leave a comment:


  • devius
    replied
    Originally posted by mugginz View Post
    ....But even though GL Vsync is set to force on in Catalyst Control Center and Compiz is set to V-Sync on, it still tears like a b_stard when moving windows around.
    This may be a problem with compiz. Just a few hours ago I saw a computer with a Geforce GTS250 using the binary drivers exhibit the same behaviour. I don't know if vsync was activated in nvidia control panel though.

    Leave a comment:


  • PsynoKhi0
    replied
    Originally posted by BlackStar View Post
    Is this the driver with the new Mono-based control center?
    Erm what? Please tell me it's just a sick joke.

    Leave a comment:


  • BlackStar
    replied
    Is this the driver with the new Mono-based control center?

    Leave a comment:


  • mugginz
    replied
    Originally posted by Ragas View Post
    I think this is a problem in newer versions of Mesa.
    My Intel card does that too.
    Good to know.

    Leave a comment:

Working...
X