No announcement yet.

AMD Catalyst 10.10 For Linux Officially Released

  • Filter
  • Time
  • Show
Clear All
new posts

  • #41
    i dont even have this options in about:config


    • #42
      ah.. i have ff 3.6


      • #43
        Originally posted by bongmaster2
        omfg only 1 min to edit posts.....

        i had to add it to get it working.settings in the gui dont work.

        but its strange.
        ie9 testdrive fishtank does not get as much speed as before(almost as slow as without layers enabled)but does run as fast as with direct2d with gallium.
        Direct2D is a windows-only API, so it's not possible to use that in Linux. The equivalent API is XRender, which I can't remember if that's supported in FF yet or not. The layers support will work (using OpenGL vs Direct3D) and I'm guessing that's what is giving you any speedups you're seeing.

        The Direct2D acceleration API in fglrx is completely different from the Windows API, and it's used internally only (to increase the speed of XRender).


        • #44
          Right. The only connection between the new acceleration in fglrx (A2AA) and Direct2D is that the fglrx developers re-used a test option left over from Direct2D development to enable the new accel code before it became on by default.


          • #45
            after your "tweeks" i got fu**** up some sites, dunno why, only part or one page...



            same site, different effect, same source of problem


            • #46
              I just installed the 10.10 on SUSE 11.3 64 bit ( Asus HD 5750 )

              I can't open the control center. from the desktop.

              Solved the FF scrolling problem, by turning off smooth scrolling in FF.


              • #47
                Originally posted by bongmaster2
                well but direct2d does work as soon as i switch to r600g.
                everythings runs almost at fast as on windows then.
                Perhaps the same setting is enabling XRender acceleration after all, then. But it's definitely not Direct2D. That's like calling the layers acceleration Direct3D when it's actually using OpenGL.


                • #48
                  Originally posted by AnorexiasGrizzli View Post

                  try to compile with these files, they worked for me, i cant link a patch because the patch that i found didnt work with the latest catalyst, so i had to manually patch these it
                  Would someone repost the files. The link is no longer available.



                  • #49
                    Originally posted by DanaG View Post
                    "This release for Linux should also carry proper OpenGL ES 2.0 support" -- says who? The release notes say nothing about OpenGL ES.

                    I see no libEGL or libGLESv2 here! Even checking "strings" returns nothing relevant for any of the files in the package.
                    egrep 'glesx|GLESX' /var/log/Xorg.0.log returns
                    [   231.471] (II) LoadModule: "glesx"
                    [   231.471] (II) Loading /usr/lib64/xorg/modules/
                    [   231.472] (II) Module glesx: vendor="X.Org Foundation"
                    [   231.472] (II) Loading extension GLESX
                    [   231.472] (II) fglrx(0): GLESX enableFlags = 528
                    [   231.472] (II) fglrx(0): GLESX is enabled
                    Is that what you're looking for?

                    BTW, got a kernel update today on openSUSE 11.3 (fixing the RDS vulnerability) so I reinstalled fglrx 10.10. On first reboot I get the same FPS yoyo in Guild Wars (through WINE) as mentioned in the other fglrx 10.10 thread.