Announcement

Collapse
No announcement yet.

fglrx 10-10 has been released

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • fglrx 10-10 has been released

    https://a248.e.akamai.net/f/674/9206...x86.x86_64.run

    But the release notes are not available, yet.

  • #2
    No joy for Mandriva 2010.1:

    Generating package: Mandriva/2010.1
    Building package failed!
    rpmbuild output follows:
    Executing(%prep): /bin/sh -e /tmp/ati.VYxmEK/tmp/rpm-tmp.haqzQD
    + umask 022
    + cd /tmp/ati.VYxmEK/BUILD
    + '[' 1 -eq 1 ']'
    + '[' 1 -eq 1 ']'
    + '[' 1 -eq 1 ']'
    + cd /tmp/ati.VYxmEK/BUILD
    + rm -rf fglrx-8.783
    + /bin/mkdir -p fglrx-8.783
    + cd fglrx-8.783
    + ln -s /home/arichter/catalyst10.10/fglrx-install.W15xI3/x750_64a /home/arichter/catalyst10.10/fglrx-install.W15xI3/arch .
    + cp -a /home/arichter/catalyst10.10/fglrx-install.W15xI3/common .
    + echo 'Patch #3 (fglrx-authfile-locations.patch):'
    Patch #3 (fglrx-authfile-locations.patch):
    + /usr/bin/patch -U -s -p1 --fuzz=2 -i /home/arichter/catalyst10.10/fglrx-install.W15xI3/packages/Mandriva/fglrx-authfile-locations.patch
    + echo 'Patch #9 (fglrx-make_sh-custom-kernel-dir.patch):'
    Patch #9 (fglrx-make_sh-custom-kernel-dir.patch):
    + /usr/bin/patch -U -s -p1 --fuzz=2 -i /home/arichter/catalyst10.10/fglrx-install.W15xI3/packages/Mandriva/fglrx-make_sh-custom-kernel-dir.patch
    1 out of 5 hunks FAILED -- saving rejects to file common/lib/modules/fglrx/build_mod/make.sh.rej
    error: Bad exit status from /tmp/ati.VYxmEK/tmp/rpm-tmp.haqzQD (%prep)


    RPM build errors:
    Bad exit status from /tmp/ati.VYxmEK/tmp/rpm-tmp.haqzQD (%prep)
    Removing temporary directory: fglrx-install.W15xI3

    Comment


    • #3
      Originally posted by gukin View Post
      No joy for Mandriva 2010.1:

      Generating package: Mandriva/2010.1
      Building package failed!
      rpmbuild output follows:
      Executing(%prep): /bin/sh -e /tmp/ati.VYxmEK/tmp/rpm-tmp.haqzQD
      + umask 022
      + cd /tmp/ati.VYxmEK/BUILD
      + '[' 1 -eq 1 ']'
      + '[' 1 -eq 1 ']'
      + '[' 1 -eq 1 ']'
      + cd /tmp/ati.VYxmEK/BUILD
      + rm -rf fglrx-8.783
      + /bin/mkdir -p fglrx-8.783
      + cd fglrx-8.783
      + ln -s /home/arichter/catalyst10.10/fglrx-install.W15xI3/x750_64a /home/arichter/catalyst10.10/fglrx-install.W15xI3/arch .
      + cp -a /home/arichter/catalyst10.10/fglrx-install.W15xI3/common .
      + echo 'Patch #3 (fglrx-authfile-locations.patch):'
      Patch #3 (fglrx-authfile-locations.patch):
      + /usr/bin/patch -U -s -p1 --fuzz=2 -i /home/arichter/catalyst10.10/fglrx-install.W15xI3/packages/Mandriva/fglrx-authfile-locations.patch
      + echo 'Patch #9 (fglrx-make_sh-custom-kernel-dir.patch):'
      Patch #9 (fglrx-make_sh-custom-kernel-dir.patch):
      + /usr/bin/patch -U -s -p1 --fuzz=2 -i /home/arichter/catalyst10.10/fglrx-install.W15xI3/packages/Mandriva/fglrx-make_sh-custom-kernel-dir.patch
      1 out of 5 hunks FAILED -- saving rejects to file common/lib/modules/fglrx/build_mod/make.sh.rej
      error: Bad exit status from /tmp/ati.VYxmEK/tmp/rpm-tmp.haqzQD (%prep)


      RPM build errors:
      Bad exit status from /tmp/ati.VYxmEK/tmp/rpm-tmp.haqzQD (%prep)
      Removing temporary directory: fglrx-install.W15xI3
      You may want to try pulling the latest packaging script changes from Phorogit.com.
      Michael Larabel
      http://www.michaellarabel.com/

      Comment


      • #4
        for me googleearth and 10.10 hardlocks my system (magic sysrq key also doesn't work)

        both happens with or without compiz (/compositing) running

        I don't know if this is only related to a buggy googleearth binary/ebuild

        glxgears and fgl_glxgears runs fine, accelerated fullscreen flash also - so it could be limited only to googleearth

        the same also happened with the 10.10 preview/beta for ubuntu

        Comment


        • #5
          It is really poor that the driver does not support .36 kernel out of the box. You can fetch the 2 needed patches from the fglrx-packageing git in the Mandriva dir. I added the 2nd patch now into my script to support .36 final.

          http://kanotix.com/files/install-fglrx-debian.sh

          to install run it inside X (requires reboot, may keep old version file):

          sudo -i
          DISPLAY= sh install-fglrx-debian.sh -z

          otherwise it seems to work best when kdm/gdm was shut down manually before the script and rmmod fglrx longer before. I do the same in the script but maybe due to heavy system load something is different and it likes to crash then.

          Comment


          • #6
            Originally posted by Kano View Post
            It is really poor that the driver does not support .36 kernel out of the box.
            Correct me if I'm wrong, but aren't packaging/installation scripts managed by maintainers for each supported distro?
            Apply for a packager seat!

            Comment


            • #7
              That built the packages, thanks!

              Originally posted by Michael View Post
              You may want to try pulling the latest packaging script changes from Phorogit.com.
              I wasn't aware of the phorogit.com site, thanks, I just HATE hitting a wall and giving up, it's not the penguin way!

              Comment


              • #8
                @PsynoKhi0

                It is not normal that you have to patch a NEW driver when a final kernel was out before and rc stage of that kernel was several month long. There was more than enough time for AMD to add support for it. Nvidia has .36 support down to 173.xx directly - well i had to patch 96.xx there too.

                Comment


                • #9
                  Release Notes are out...

                  https://a248.e.akamai.net/f/674/9206...1010_linux.pdf

                  Same old bugs for me

                  Comment


                  • #10
                    Originally posted by Kano View Post
                    It is really poor that the driver does not support .36 kernel out of the box. You can fetch the 2 needed patches from the fglrx-packageing git in the Mandriva dir. I added the 2nd patch now into my script to support .36 final.

                    http://kanotix.com/files/install-fglrx-debian.sh

                    to install run it inside X (requires reboot, may keep old version file):

                    sudo -i
                    DISPLAY= sh install-fglrx-debian.sh -z

                    otherwise it seems to work best when kdm/gdm was shut down manually before the script and rmmod fglrx longer before. I do the same in the script but maybe due to heavy system load something is different and it likes to crash then.
                    man - I love that script

                    multi-purpose all-in-one kernel-version swiss knife catalyst installer

                    Comment

                    Working...
                    X