Announcement

Collapse
No announcement yet.

Tv Out with Radeon Xpress 200G

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tv Out with Radeon Xpress 200G

    Greetings,

    While trying to use Unbuntu 10.10 x64 I'm having some issues with the
    configuration of forcing TV-Out.

    Code:
    01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS480 [Radeon Xpress 200G Series] [1002:5954] (prog-if 00 [VGA controller])
            Subsystem: Hewlett-Packard Company Device [103c:2a26]
            Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 17
            Memory at d8000000 (32-bit, prefetchable) [size=128M]
            I/O ports at ee00 [size=256]
            Memory at fdef0000 (32-bit, non-prefetchable) [size=64K]
            [virtual] Expansion ROM at fde00000 [disabled] [size=128K]
            Capabilities: <access denied>
            Kernel driver in use: radeon
            Kernel modules: radeon
    This is a HP Multimedia 7050e amd athon x64 and is stock, other than the HDD. The Distro again is Unbuntu 10.10 x64

    My problem is that while I'm able to xrandr to add the mode, and switch to S-video, the graphics tear.. I've tried different refresh rates, to no avail. I was previously using 10.4 and had it working.

    My goal is not to have *ANY VGA* on this.. It's all S-video for a TV
    I'll take 800x600, but I know the card and TV can do 1024x768 (Via Windows XP)

    I formatted the box and started fresh, like an idiot I didn't document exactly what I did.. To be honest, I had fiddled with it so much, to get it to work, the documentation would require a forklift.

    I've tried with nomodeset off and on.. I've tried forcing video=789 and video=792 (No quiet, No splash) [So I can see the boot up process]

    As you may know, This IGP is NOT supported in the 'fglrx' and hasn't been since intrepid (I think).

    The Bios forces the IGP to only one memory option 64m. (There was a tweak out there saying setting the card to 128 would help)

    I'm not sure if going the mesa route is the way to go, or how 10.10 is setup.. I know that it got a heck of a lot farther than 10.4 did on first boot..

    Oh almost forgot.. before I was playing withe the nomodeset, the AGP Gart Bug was appearing.

    Anyway, if there's some super secret squirrel diff or package that helps with this, please let me know.. I'm re-doing the system as i speak, as i've tinkered with it so much, I've ganked it.. I'll post full lspci -nnv when i get it back on it's feet. Any other info please that you may need, let me know..

    Warm Regards,
    Gabriel

  • #2
    Uhh oh.. I may have mis-posted. this needed to be in the open source, not the closed source.. Sorry in advance..

    Comment

    Working...
    X