No announcement yet.

AMD catalyst 10.9 has been released

  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Originally posted by Qaridarium View Post
    only the 2D version number is right... this is a known bug just ignore it!
    I am ignoring it .

    The post is mostly to illustrate to others coming across this issue that the posts which claim that uninstalling the old driver and deleting /etc/ati, then rebooting and installing the new driver doesn't necessarily result in the correct version number being displayed by the Catalyst Control Centre.

    To many out there, no, you're not doing it wrong fglrx is (surprise, surprise)


    • #62
      The thing is harder to kill that Michael Myers
      If X is still running it just rebuilds itself.

      What I do after generating the Mandriva rpms is then use the --extract option.
      Reboot to init 3 upgrade the driver then as I reboot again pop in a live disk.
      Delete the old /etc/ati folder and paste in the new one from the extracted fglrx every time. May add a few minutes to the upgrade process but what the heck.
      Those who would give up Essential Liberty to purchase a little Temporary Safety,deserve neither Liberty nor Safety.
      Ben Franklin 1755


      • #63
        This driver as a bug in ubuntu:

        I applied the patch but the driver still fails to load. Any suggestion?


        • #64
          Originally posted by smartysmart34 View Post
          Shouldn't the rpm-package generated by the installer take care of this by itself?!?
          You'd think so, but don't worry the .deb packages don't do this either... You'd think that by now they'd embed a version string in the drivers and just have CCC read it from there...

          Hey! Someone else is bitching about the 1m edit timeout now too... lovely how it leads to masses of double, trip, quadruple, etc. posts.

          (Been trying out Android tablets recently(don't buy the Augen Gentouch78), and knew that nothing exciting would be happening w/fglrx anyways... wasn't surprised when I came back and saw most of the same old friendly bugs still around.)

          So what sort sort of OpenGL support are the OSS drivers up to now? Power management fully implemented yet? (Haven't been watching these for a while either as not much exciting was happening with them either, but it seems that I MAY have missed something over the last few months...)


          • #65
            The new Ubuntu kernel breaks wine... FFS! I was thinking it was FGLRX fault.

            At least the new kernel + this fix is breaking Wine. (4 driver versions tested 10-9, 10-8, 10-4, 10-4).

            If someone knows how to fix this I would be gratefull.


            • #66
              EDIT: Its breaks OpenGL inside Wine.

              OpenGL is working perfectly everywhere else.


              • #67
                i try install ati 10.9 at ubuntu 10.04 (2.6.32-24-generic) x64 and didnt work

                follow howto from and when
                first uninstall 10.8 then

                dpkg -i fglrx*.deb

                i have this errors:

                Selecting previously deselected package fglrx.
                (Reading database ... 161494 files and directories currently installed.)
                Unpacking fglrx (from fglrx_8.771-0ubuntu1_amd64.deb) ...
                Selecting previously deselected package fglrx-amdcccle.
                Unpacking fglrx-amdcccle (from fglrx-amdcccle_8.771-0ubuntu1_amd64.deb) ...
                Selecting previously deselected package fglrx-dev.
                Unpacking fglrx-dev (from fglrx-dev_8.771-0ubuntu1_amd64.deb) ...
                Selecting previously deselected package fglrx-modaliases.
                Unpacking fglrx-modaliases (from fglrx-modaliases_8.771-0ubuntu1_amd64.deb) ...
                Setting up fglrx (2:8.771-0ubuntu1) ...
                update-alternatives: using /usr/lib/fglrx/ to provide /etc/ (gl_conf) in auto mode.
                update-initramfs: deferring update (trigger activated)
                Loading new fglrx-8.771 DKMS files...
                First Installation: checking all kernels...
                Building only for 2.6.32-24-generic
                Building for architecture x86_64
                Building initial module for 2.6.32-24-generic

                Error! Bad return status for module build on kernel: 2.6.32-24-generic (x86_64)
                Consult the make.log in the build directory
                /var/lib/dkms/fglrx/8.771/build/ for more information.
                dpkg: error processing fglrx (--install):
                subprocess installed post-installation script returned error exit status 10
                dpkg: dependency problems prevent configuration of fglrx-amdcccle:
                fglrx-amdcccle depends on fglrx; however:
                Package fglrx is not configured yet.
                dpkg: error processing fglrx-amdcccle (--install):
                dependency problems - leaving unconfigured
                dpkg: dependency problems prevent configuration of fglrx-dev:
                fglrx-dev depends on fglrx; however:
                Package fglrx is not configured yet.
                dpkg: error processing fglrx-dev (--install):
                dependency problems - leaving unconfigured
                Setting up fglrx-modaliases (2:8.771-0ubuntu1) ...
                Processing triggers for ureadahead ...
                Processing triggers for man-db ...
                Processing triggers for python-gmenu ...
                Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
                Processing triggers for initramfs-tools ...
                update-initramfs: Generating /boot/initrd.img-2.6.32-24-generic
                Processing triggers for python-support ...
                Errors were encountered while processing:

                and now i cant install any version of fglrx, 10.7, ubuntu repository, xteam, always same error

                ubuntu 10.04 x64
                Radeon HD 4870

                any suggestion? help?

                (sorry for my very very bad english)



                • #68
                  Originally posted by Qaridarium View Post
                  10.8 can handle the standart 32 bit flash in 10.04 kubuntu and the 10.9 goes down if you switch from fullscreen to windows mode only strg+alt+f1 and after that strg+alt+f7 brings the screen back.
                  I think I'm experiencing the same issue. I filed a bug report at but haven't received a reply yet. Before reporting this as a bug, I asked on the Arch forums if anyone was able to reproduce this issue, but yours is the only similar report.

                  Have you by any chance found an explanation of what's wrong and/or maybe a solution?


                  • #69
                    Originally posted by srbungle View Post
                    and now i cant install any version of fglrx, 10.7, ubuntu repository, xteam, always same error

                    ubuntu 10.04 x64
                    Radeon HD 4870

                    any suggestion? help?

                    (sorry for my very very bad english)

                    I had the same problem and was going nuts. Found it to be an issue with linux kernel 2.6.32-24 (which made it's way to the Ubuntu repositories a few days ago - you probably just got it while running updates). I rolled back to 2.6.32-23 and now I can install any version of Catalyst again, including the new 10.9 (fglrx 8.771).

                    Just install the following from Synaptic:

                    It should update grub for you automatically. Next time you reboot, you should presented an option for which kernel you'd like to use. Select the -23 version and install Catalyst again. It shoudld work now.

                    You can either leave -24 there for now or remove it. I would also install StartupManager from synaptic to help you manage grub if you are going to keep several images to boot to.

                    Hope that helps! Frustrated the hell outta me for a bit.


                    • #70
                      There is definitely a problem with the new 2.6.32-x kernel and fglrx. Not sure yet what the final resolution will be.