No announcement yet.

How do I install Catalyst for Ubuntu 10.04 64-bit?

  • Filter
  • Time
  • Show
Clear All
new posts

  • How do I install Catalyst for Ubuntu 10.04 64-bit?

    Hi everybody. I just got a new laptop with an ATI Mobility 5650. I want to install the catalyst drivers but I'm having trouble. I tried installing the drivers from the restricted hardware drivers pop up, but when I rebooted, my screen was blank. What is the best way to install Catalyst, and if something goes wrong, how do I remove it without having to reinstall Ubuntu?

    Thanks for all the help.

    PS: I think I read two different ways of installing the drivers, but I can't find it. One was using some kind of script and another was installing the drivers provided by Ubuntu and then installing the official ATI drivers in that directory.

  • #2
    When you already tried installing fglrx it should have blacklisted the radeon module already, but i would still recommend using -z option and then reboot. the cleanest way is

    login into vt1 (ctrl+alt+f1)

    wget -N
    sudo /etc/init.d/gdm stop
    [in case of kubuntu:]
    sudo /etc/init.d/kdm stop
    sudo rm -f /etc/X11/xorg.conf*
    sudo sh -z
    sudo reboot

    In theory it works with -z option even inside X, but then amdcccle can report a wrong version when fglrx was installed before. in that case you would not stop gdm/kdm and use a DISPLAY= override.


    • #3
      I should mention that I completely reinstalled Ubuntu after getting a blank screen.

      So to follow your instructions, I should have already tried installing using the proprietary drivers? If I get an error saying that fglrx was installed before I login into vt1 and use the Display=override command?

      Sorry, I'm really new at installing drivers and stuff. I really appreciate your help.


      • #4
        EDIT: There's something wrong. I can't get into xterm with ctrl alt f1 and I can't boot into recovery mode. This prevents my from using the script, so unless I can some how find a way to get into xterm, it looks like I can't use the ATI drivers. Thanks anyways for the help.


        • #5
          thats the 2nd way:

          wget -N
          DISPLAY= sudo sh -z

          then reboot.


          • #6
            Ok, I ran the script and most things seemed to work well. I now have the ATI Catalyst link in my menu, but when I try and launch it I get this message:

            "There was a problem initializing Catalyst Control Center Linux edition. It could be caused by the following.

            No ATI graphics driver is installed, or the ATI driver is not functioning properly.
            Please install the ATI driver appropriate for you ATI hardware, or configure using aticonfig."

            I ran the script, rebooted, and then got a blank screen. So I had to use a live cd to delete the xorg.conf file.


            • #7
              EDIT: Ok, I re-ran the script again and then rebooted. I got a blank screen again, so I used the "nomodeset" option in Grub2 and received a couple errors:

              (EE) fglrx(0): Please disable switchable-graphics feature and configure the discrete card as the default adapter
              (EE) fglrx (0): GetBiosParamter failed
              (EE) fglrx (0): PreInitAdapter failed
              (EE) fglrx (0): PreInit failed
              (EE) Screen (s) found, but none have a usable configuration.


              • #8
                You can switch to the other BusID using

                sed -i /BusID/s/head/tail/

                in my script or disable one card in the bios completely. Of course you can manully change the /etc/X11/xorg.conf too, the output can be guessed by

                lspci -nn


                • #9
                  Ok, I was able to successfully switch the BusID. However, I still get a blank screen. Here's the log file:

                  The following error was encountered you may need to update your configuration to solve this.
                  (EE) Problem parsing the config file
                  (EE) Error parsing the config file

                  Data incomplete in file /etc/X11/xorg.conf
                  Undefined Screen "aticonfig-Screen[0]-0" referred by ServerLayout "aticonfig Layout"

                  Fatal server error:
                  no screens found

                  (WW) xf86CLoseConsole:KDSETMODE failed: Bad file description
                  (WW) xf86CLoseConsole:VT_GETMODE failed: Bad file description
                  (WW) xf86CLoseConsole:VT_GETSTATE failed: Bad file description

                  Will posting the xorg.conf file help?

                  Thanks for all the help again!


                  • #10
                    sudo rm -f /etc/X11/xorg.conf
                    sudo aticonfig --initial --nobackup

                    does that work? without any hacks...