No announcement yet.

problem after video card upgrade

  • Filter
  • Time
  • Show
Clear All
new posts

  • problem after video card upgrade

    Hello everyone, I am looking for some help getting X back up and running after my video card upgrade. I have openSuSE 11.1 32-bit, and the original video card when I installed it was an ATI radeon 4350. I recently upgraded it to an ATI radeon 5770, and now X will not start. I am not concerned about 3D at this point I will settle with basic vesa or what ever it takes to get X back up and running. I tried booting using the openSuSE LIVE CD that I have and it did auto-detect and X was working. So I mounted the hard drive and copied the conf file from the live image into the hard disk image and then rebooted but it still will not start up. I tried kicking off SAX2 from the command line to re-detect but it just hangs. Does anyone have any suggestions how I can got this working again? Thanks in advance.

  • #2
    Did you uninstall the old graphics driver before upgrading ?

    Does the system work if you put the old card back in ?


    • #3
      I did not uninstall the old driver before I switched, but once it had the problem I used rpm -e to remove the fglrx driver that I had previously installed however that did not fix it. When the SuSE "LIVE" CD boots to X, its just using a vesa driver. I copied that conf file to the hard drive so now when it boots it should be using that driver now but it still doesn't work. I know it CAN work, because of the "LIVE" CD... I just need to figure out how to get it back to that state...


      • #4
        Can you get an xorg log from the failed startup ?

        If so please pastebin rather than pasting extracts.


        • #5
          I think I can do that. I'll have to boot it with the live CD and then mount the drive but I should be able to get it. At the moment I can't upload it as an attachment; I think its because I am too new to this forum?


          • #6
            I think attachments are disabled. Use pastebin.


            • #7
              thanks for your replies before bridgman, it took me a while to get back around to dealing with this. For some unknown reason, when I went to start it up again and get the logs, it worked!!! I am as shocked as I could be. I had previously tried it dozens of times. I did nothing different this time but it worked. I should say, it worked with the vesa driver (the xorg.conf which was generated from a SUSE "Live" bootable CD.) Since I now had X, I downloaded the latest ATI catalyst and installed it. Now it works perfectly with fglrx and I am doing great. I only wish I knew what I had done wrong on the previous attempts so I could record it here for people that might have the same problem as me. Thanks again.


              • #8
                Glad to hear it's working.

                I guess "it works and we don't know why" is a better problem than "it doesn't work and we don't know why"


                • #9
                  I always find those "it works and I don't know why" situations to be unsettling. At least if you DO SOMETHING to get it to work, you know what you did and can tell if there is potentially something that is going to fail later on.

                  In this particular case, I would be concerned about any external power requirements that the card has. Is there a plug on the card for external power? Is there a plug on the MAINBOARD to add in extra power? Is it possible that you're running near the limit of your power supply? Is it possible that the card was improperly seated or that a contact wasn't connected perfectly?


                  • #10

                    (a) you were using the open source drivers which don't support HD5000 as of this writing

                    (b) you were using a Catalyst version so old that it didn't support HD5000 (would have to be fairly old)

                    (c) something else weird happened I'd blame SAX, based on my past experience with OpenSUSE...