No announcement yet.

Asus Radeon HD 4850 and Linux

  • Filter
  • Time
  • Show
Clear All
new posts

  • Asus Radeon HD 4850 and Linux

    Excuse me if this is the wrong place for technical questions.

    I have the Asus EAH TOP 4850 ATI card, connected with a HDMI cable to my TV screen, wich also have HDMI on it's end. ( also trid with several other monitor's.

    Have tried this setup in Debian, Ubuntu, Linux Mint, and many many other distro's.

    1) Screen flickering on and off, blanc screen 3 seconds, then in 0,5 seconds you can see the desktop.
    2) You can see the OS during boot. Also BIOS screen is visible, when you get to "starting gnome..." you get back to point 1 in this post.
    3) extremely large fonts, so desktop is impossible to navigate through.
    When using VESA driver you will get 640x480 resolution at most, but no more colours than 16.

    So... none of them have worked correctly, and after 3 months of intense and hard work to figure out what to do, I gave up. This was about one year ago..

    My idea is that you cannot get any signal because the HDMI signal is encrypted..? And Linux cannot decrypt this signal?

    However.. in Window$ this isn't even an issue.. not in XP or win7 anyway..And the card works just fine.

    Is there any point to try out Linux with this GPU now?

    Thanks for any help

  • #2
    which drivers did you use? fglrx or the OSS drivers?

    HDMI is not encrypted by default, but you can send HDCP-encrypted data over it. That's not the problem here.

    It's more likely either a driver issue, or an issue with a broken EDID on the TV's part. Trying to attach it via DVI might may a difference.

    A lot has happened with both drivers over the last year, so trying again isn't futile.

    In any case, should you try again, please provide the Xorg.0.log and dmesg output. It's difficult to help you otherwise.


    • #3
      Thanks for replying rohcQaH.

      I used fglrx and radeonhd drivers. OSS? Not sure if I used those drivers? Always zero hardware support, and therefore no good colours or resolution.

      I messed around with EDID but I didn't get around to really know the program. Tried some 10 meters long commands, but it didnt help me....
      Im used to use the commandline but its pretty hard to figure out what resolutions will work and how to adjust this to the TV. It's a 42" hitatchi. Not the newest..

      The command fglrx --initial ( or something ) DID make it work after the first reboot, sometimes.. In OpenSuse, and maybe twice in Debian. In ubuntu things was 100% impossible. It always went wrong. I had to hack the gnome desktop's init files to make it show some decent readable fonts, and other things.

      Thing is..The same happens when connecting to a regular LCD monitor, with DVI, or HDMI. Or even from DVI to VGA... Then after a week or so, it just craps out..
      And I know I have read on the net that others with 4850 makes it work very good and never have any problem..

      Perhaps my "ASUS EAH TOP 4850" is "very special"? And can only work in windows? hehe...

      Anyway.. as i really love linux I will give it another shot now, and see what happens
      Thought I'd try Or the newest linux mint and see what happens?
      Anyone here have a very good howto on EDID and HDMI connected TV's?


      • #4
        I should add that I have the internal graphics AMD 780G chipset on my motherboard too.( gigabyte GA-MA78GM-S2H )
        Disabled in BIOS.
        Could this GPU give me trouble in linux?


        • #5
          The onboard GPU shouldn't be a problem as long as it's disabled in your BIOS.

          OSS = Open Source Software, when I'm talking about OSS drivers that includes (but isn't limited to) radeonhd.

          You cannot use fglrx and OSS drivers at the same time, having both installed at the same time is asking for trouble. If you change drivers, you need to be extra-careful to remove all traces of the old one. Many packaging systems don't get that right, unfortunately

          If you're going for a new distro, I'd suggest Fedora, because it comes with a very recent version of the OSS driver stack. Chances are good that the 4850 will just work out of the box, even from the live-CD. If it doesn't, please provide the logs I mentioned.


          • #6
            Thanks for the tip. I'll try fedora from a usb stick and see how it goes. I'll get back to you!


            • #7
              If you run into problems, make sure you post the /var/log/Xorg.0.log file that is generated.



              • #8
                Originally posted by adamk View Post
                If you run into problems, make sure you post the /var/log/Xorg.0.log file that is generated.

                Well.. No problems so far
                Booting for the third time now.
                Running from a usb stick, and its even fast.
                Fedora detects my TV as Hitatchi LTD 7"
                Resolution 1280 x 720
                Refresh rate 50 Hz

                The DPI is set to 96.
                Compiz IS working 100%.
                But, how can i verify what ati drivers its using now?

                Im used to apt-get but I guess yum will do the work.
                Just for fun i tried:

                glxinfo |grep -i "\(render\|opengl\)"
                direct rendering: Yes
                OpenGL vendor string: Advanced Micro Devices, Inc.
                OpenGL renderer string: Mesa DRI R600 (RV770 9442) 20090101 TCL DRI2
                OpenGL version string: 2.0 Mesa 7.8.1
                OpenGL shading language version string: 1.10
                OpenGL extensions:
                [[email protected] liveuser]# glxgears
                And it seem to work just fine.
                I might even try a install now.


                • #9
                  You are using the open source radeon driver.