Announcement

Collapse
No announcement yet.

8.35.5 driver fails to load on recent Fedora Rawhide (upcoming F7)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 8.35.5 driver fails to load on recent Fedora Rawhide (upcoming F7)

    Hi all,

    First post to the forum although I have been reading the articles with keen interest. Now about my problem. I have a laptop with an X1300 and Fedora F7 Test 3 updated to the latest Rawhide. Today I build and installed the 8.35.5 drivers/apps, modified my xorg.conf and started X. No go. Apparently some versioning changed in the xorg server part which fglrx disagrees with causing X not to start. It gives this error:

    (II) LoadModule: "fglrx"
    (II) Loading /usr/lib/xorg/modules/drivers//fglrx_drv.so
    (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
    compiled for 7.1.0, module version = 8.35.5
    Module class: X.Org Video Driver
    ABI class: X.Org Video Driver, version 1.0
    [atiddxSetup] X version mismatch - detected X.org 1.3.-1.905, required X.org 7.1.0.0
    (II) UnloadModule: "fglrx"
    (II) Unloading /usr/lib/xorg/modules/drivers//fglrx_drv.so
    (EE) Failed to load module "fglrx" (module requirement mismatch, 0)

    Anyone have an idea if there is a fix for this issue?

  • hyfans
    replied
    enm, maybe you can replace the function call (if there is ) with you own "tricky version" by using "LD_PRELOAD" method.

    or just wait for another month


    Originally posted by gfxdrone View Post
    Since we can't change the ATI binary, is there any way to change what version X reports itself as? Maybe if we can trick ATI into thinking that it's seeing X 7.2 that would do it. Is there any way to do this? Currently with new stuff: X -version shows 1.3, which triggers the wrong version error message from fglrx on xorg start.

    Leave a comment:


  • gfxdrone
    replied
    Since we can't change the ATI binary, is there any way to change what version X reports itself as? Maybe if we can trick ATI into thinking that it's seeing X 7.2 that would do it. Is there any way to do this? Currently with new stuff: X -version shows 1.3, which triggers the wrong version error message from fglrx on xorg start.

    Leave a comment:


  • gfxdrone
    replied
    Now this is confirmed in debian sid too. And as soon as the 1.3 xserver-xorg-core drifts into Debian testing, ATI will have achieved the remarkable result of having NO drivers that work in new Linux systems like Debian or Fedora. And for users of newer cards unsupported by xorg ati or radeon drivers, they now have no real driver to run at all. I hope somebody at AMD can figure out just why ATI is doing this and solve the problem, very shortly ATI will become a total pariah in the Linux community, even worse than it currently is.

    I believe that Ubuntu solved this issue by recompiling their xorg parts to show the 7.x numbering.

    This is really impressive, if there was any doubt at all that ATI is completely either unwilling or unable to serve Linux users, it is now completely removed.
    Last edited by gfxdrone; 04-20-2007, 03:24 PM.

    Leave a comment:


  • lowlands
    replied
    Originally posted by Michael View Post
    I tried like 8.36.3 (internal) and it still didn't work with no luck but will try 8.36.5 shortly.
    Don't bother. Just tried it and it fails.

    Leave a comment:


  • Michael
    replied
    Originally posted by [email protected] View Post
    The New Driver will not work on Rawhide?

    oh man -.-
    The new driver will not

    Leave a comment:


  • Cheeky@Boinc
    replied
    The New Driver will not work on Rawhide?

    oh man -.-

    Leave a comment:


  • Michael
    replied
    Originally posted by janl View Post
    I tried last night to build the RPM packages on an up-to-date version of Rawhide and it failed to build, giving the same error as the 8.35 drivers. Was really hoping I might be surprised...
    I am hoping ATI will had server 1.3 support prior to Fedora 7... Otherwise there's going to be lots of hell.

    Leave a comment:


  • janl
    replied
    I tried last night to build the RPM packages on an up-to-date version of Rawhide and it failed to build, giving the same error as the 8.35 drivers. Was really hoping I might be surprised...

    Leave a comment:


  • Michael
    replied
    I tried like 8.36.3 (internal) and it still didn't work with no luck but will try 8.36.5 shortly.

    Leave a comment:

Working...
X