No announcement yet.

HD4850+lucid+fglrx = horrible performance

  • Filter
  • Time
  • Show
Clear All
new posts

  • HD4850+lucid+fglrx = horrible performance

    I think I'm doing something wrong here ...

    Today I updated to Ubuntu 10.04. I did a clean install, only migrating my /home which lies on a different partition. I then installed fglrx via Administration --> Hardware Drivers and did an "aticonfig --initial".

    Performance is absolutely abysmal, especially in OpenGL-applications. I get around 250fps in glxgears, while the OSS-driver reaches 1600fps. I don't know what numbers I had on Karmic, but fglrx used to outperform the OSS-drivers by a significant amount. Other apps (a small clutter-program i wrote and snes9x) are basically unusable.

    I'd use the OSS-driver, unfortunately it's deep frying my card. Using ForceLowPowerMode is not an option, because that means turning off kms which somehow destroys OpenGL completely ...

    I'm not using any Visual Effects ? strangely enough enabling them gives me better performance (around 900fps in glxgears).

    I already tried this:
    No use though.

    Any help is very much appreciated.

    Here's my xorg.0.log

    and my xorg.conf
    Section "ServerLayout"
    	Identifier     "aticonfig Layout"
    	Screen      0  "aticonfig-Screen[0]-0" 0 0
    Section "Files"
    Section "Module"
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]-0"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    Section "Device"
    	Identifier  "aticonfig-Device[0]-0"
    	Driver      "fglrx"
    	BusID       "PCI:4:0:0"
    Section "Screen"
    	Identifier "aticonfig-Screen[0]-0"
    	Device     "aticonfig-Device[0]-0"
    	Monitor    "aticonfig-Monitor[0]-0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24

  • #2
    What opengl applications are u talking about? glxgears?

    Well, certainly something happened to glxgears, i have to 300 fps too.

    Anyway glxgears (or wine) is not the correct way to measure drivers opengl performance.

    - glxgears is a simple test, sometype of memory copy function. It is not realistic.

    - wine developers own a nvidia hardware and mainly focus, test and develop on this hardware.

    Please could you try some *real* linux opengl application and post your numbers, before criticize fglrx, lucid...

    Here are some numbers for ati 4350:

    9.10 karmic, fglrx 9.10:

    - Unigine sanctuary: 10.0 fps, score 428
    - Lightsmark 2008 2.0: 40,7

    10.4 lucid, fglrx 10.4:

    - Unigine sanctuary: 10.7 fps, score 454
    - Lightsmark 2008 2.0: 38,9 fps


    • #3
      I neither criticized lucid nor glxgears, I merely asked what I was doing wrong.
      I'm aware that glxgears is not a benchmark, it's just that under normal circumstances the open source drivers are slower than fglrx.
      The other OpenGL-applications are, as mentioned, an app that uses the clutter-toolkit, which has become dead slow, and the snes9x-emulator, which is unplayable when using OpenGL (while with karmic + fglrx there was no issue).

      A small regression wouldn't have surprised me, but this feels more like there is no direct rendering (according to glxinfo, there is).

      Strangely enough, I just tried the lightsmark-test (via PTS), and got 275fps on average.


      • #4
        I really think there is not and opengl problem / regressions. But more tests on other *real* opengl applications should be fine to clearly see this.

        I see your point, and maybe there is something wrong with 2d (I got 300 fps on glxgears too), but I completely disagree on "Performance is absolutely abysmal, especially in OpenGL-applications".

        Are snes9x and clutter-toolkit opengl applications?? maybe you can try to enable 2d acceleration:

        aticonfig --set-pcs-str=DDX,Direct2DAccel,TRUE

        aticonfig --set-pcs-str=DDX,Direct2DAccel,TRUE


        • #5
          Tried your aticonfig-settings, no use unfortunately, performance is the same but i get screen corruption.

          But I think you're right, this might not be related to OpenGL after all. I just tested some videos and mplayer with the opengl-backend is actually running smoother than totem with xvideo.

          An observation I made was concerning KMS. The OSS-drivers with kms enabled give me normal performance, with kms disabled the system is basically not usable anymore. I get a similar performance hit with fglrx, which disables kms as well ... Of course I have no idea what to make of this

          And as I mentioned, the biggest performance increase I got was by turning Desktop Effects *on*.
          Are there other options for 2d-acceleration I should be aware of?


          • #6
            All is working fine on my pc, wine (the games that work), opengl demos and video with opengl output. Except for glxgears, this 300 fps appears to be symptomatic.

            I dont use snes9x and clutter-toolkit, but the bug / regression that is causing glxgears 300 fps should be affecting those applications too.

            Have you filled a bug at ubuntu or ati?


            • #7
              Yeah, it's not like overall performance is bad here either. The desktop in general (Firefox, Thunderbird, Inkscape and so on) is smooth. It's just those certain applications that are a lot slower than they should to be. The performance being below that of the oss-drivers is what leads me to believe I misconfigured something ...

              As you seem to have somewhat similar experiences, could you check how desktop effects affect your performance? As I said, with effects turned off i get around 250fps in glxgears. With effects turned on (Normal and Extra, there's no difference) i get roughly 1000fps.
              This is what puzzles me the most.


              • #8
                Now I am totally puzzled with this glxgears thing!

                ubuntu 10.04 fglrx 10.4 kde effects on
                glxgears 300 frames in 5 seconds

                ubuntu 10.04 fglrx 10.4 kde effects off
                glxgears 300 frames in 5 seconds

                ubuntu 9.10 fglrx 9.10 kde effects on
                glxgears 150 frames in 5 seconds

                ubuntu 9.10 fglrx 9.10 kde effects off
                glxgears 150 frames in 5 seconds

                no idea what is happening here, but i remember the last time I used glxgears on karmic the result was something like 5000 frames in 5 seconds or maybe 15000 frames in 5 seconds, I dont remember exactly.


                • #9
                  Looks like you are being limited by sync-to-vblank, ie you're running at 30 or 60 frames per second. Check in cccle and see if you have OpenGL vsync turned on.


                  • #10
                    Nope, it's turned off. Turning it on does limit me to the 300 frames per 5 seconds Jimbo experiences. Performance of the apps i mentioned is the same either way though.

                    What I don't get is why enabling compiz is actually increasing performance. Is there like a different mode when not using effects that isn't being accelerated (anymore)?