Announcement

Collapse
No announcement yet.

How to fix tearing with xv on fglrx?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sockpuppet
    started a topic How to fix tearing with xv on fglrx?

    How to fix tearing with xv on fglrx?

    Hi,

    it appears that tearing under xv is a rather old and known issue with fglrx. There are recurring reports about this problem since years.

    My system is running vdr, a linux-based DVB software. It is connected via HDMI to a full HD flatscreen TV. Tested it with fglrx: Low load, but tearing with xv output. Tested it with radeonhd: no tearing with xv, but high load (and most likely no working power management).

    Two years ago, I bought the 780G mainboard with an integrated HD3200 chipset specifically because of the promise of full HD HDMI output, yet the tearing issue is still unresolved by now.

    What can one do to fix it?

    Thanks!

  • Sockpuppet
    replied
    Yes. xv works better with the open source drivers, but the system's load goes up (from 0.6 to somewhere around 2).

    Leave a comment:


  • bridgman
    replied
    Have you tried the open source (radeonhd or radeon) drivers with UMS and the ForceLowPowerMode option ?

    Leave a comment:


  • rohcQaH
    replied
    AMD has already stated that adding vsync to xv would need some architectural changes in fglrx. It's not a quick fix, and so far other features (like XvBA) were deemed more important.

    so yeah, don't hold your breath, just stick to openGL.

    Leave a comment:


  • Kano
    replied
    Its more likely that the card will be a legacy device that xv will be fixed in fglrx. For your problem use just opengl.

    Leave a comment:


  • Sockpuppet
    replied
    Originally posted by salva84 View Post
    Buy a Nvidia Card or use the open source drivers, there is no other option, fglx will never fix this issue...
    I'd hope the fglrx guys would look into this problem. It's been around since a few years.

    Leave a comment:


  • Kano
    replied
    use opengl output with forced vsync in amdcccle. for xine you need:

    .xine/config
    Code:
    video.driver:opengl
    video.output.opengl_renderer:2D_Tex

    Leave a comment:


  • salva84
    replied
    Buy a Nvidia Card or use the open source drivers, there is no other option, fglx will never fix this issue...

    Leave a comment:

Working...
X