No announcement yet.

ati-drivers-8.27.10-r1 - possible scan rate control problem?

  • Filter
  • Time
  • Show
Clear All
new posts

  • ati-drivers-8.27.10-r1 - possible scan rate control problem?

    New forum member here. Thanks in advance for putting this forum together. It looks like it can be quite helpful.

    QUESTION: How do I set the monitor scan rates in xorg.conf for 8.27.0?

    I'll keep it moderately breif. I'm a Gentoo user with a MythTV network that's been up for about 16 months. I run a 2-tuner server, 3 Linux desktop machines that run mythfrontend, and two dedicated Pundit-R machines attached to TV. The network was in need of updating so all the machines got new kernels which necessitated new ati-drivers where appropriate. I have Myth running correctly and displaying to most machines but I have one Pundit-R machine that's having some problems. I suspect it's a scan rate issue, or would at least like to eliminate that as a problem.

    1) I have two Pundit-R machines. Here is how lspci shows the VGA:

    myth14 ~ # lspci
    01:05.0 VGA compatible controller: ATI Technologies Inc Radeon 9100 IGP
    myth14 ~ #

    2) Both of these machine have been updated and are running as much as possible exactly the same software. (Myth, ati-drivers, Gentoo stuff, fluxbox)

    3) Both machines use the S-Video output to drive TVs. The one that fails also uses the conposit video output.

    4) One machine works completely correctly driving the Sony in the bedroom.

    5) One machine fails with a blue screen on the Mitsubishi in the living room.

    6) The failing machine has mythfrontend and fluxbox running when I ssh into it. If I kill them I see the screen on the Mitsubishi come back to the console and the myth and fluxbox restart automatically by design. The TV then goes blue screen again like it's getting no signal, or a signal with the wrong scan rate or no signal output.

    7) Even though I used the aticonfig program to update the xorg.conf file it seems that there are still things that aren't correct:

    myth12 ~ # cat /var/log/Xorg.0.log | grep EE
    Current Operating System: Linux myth12 2.6.16-gentoo-r13 #1 PREEMPT Thu Jul 20 18:57:49 PDT 2006 i686
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (II) Loading extension MIT-SCREEN-SAVER
    myth12 ~ # cat /var/log/Xorg.0.log | grep WW
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/local/".
    (WW) fglrx(0): board is an unknown third party board, chipset is supported
    (WW) fglrx(0): MonitorLayout is no longer supported.
    (WW) fglrx(0): The hex number setting for DesktopSetup is deprecated,
    (WW) fglrx(0): Specified desktop setup not supported: 8
    (WW) fglrx(0): DRI is not supported on Radeon 9000/9100 IGP (RS300/RS350) hardware.
    (WW) fglrx(0): Option "IgnoreEDID" is not used
    (WW) fglrx(0): Option "NoTV" is not used
    (WW) fglrx(0): Option "VendorName" is not used
    (WW) fglrx(0): Option "ModelName" is not used
    myth12 ~ #

    If I can fix that stuff along the way that would be great also.

    7) In my /etc/X11/xorg.conf file I no longer see a command for setting the scan rate of the monitor. I have a vague recollection of having this problem using the driver 16 months ago and having to set the scan rate down to something low.

    I can post lots of other info here if needed. I'll stop for now and hope for some conversation on the problems.

    Thanks in advance,

  • #2

    Thanks for joining the forums, I hope you enjoy them.

    Are you able to post your complete xorg.conf ? (is it exactly identical to the working box?)

    Also, out of curiosity, what is the output of aticonfig --tv-info on the problematic system?

    What aticonfig option did you pass to update your xorg.conf? If you used aticonfig --initial I don't believe you should still be seeing those Option XXXXX is not used entries in your log, unless you had changed your configuration after running --initial. If you hadn't try using aticonfig --initial and see how it goes. More TV-specific options can be found from aticonfig --help
    Michael Larabel


    • #3
      Thanks for answering. I appreciate it.

      I believe the xorg.conf files are identical between the two Pundit-R's. They were at one time a week or two ago as I just copied the working from from myth12 to myth14 after I first got myth12 working. I Cannot get the myth12 file right now as my wife is asleep and that machine is currently off. I'll check it later this morning.

      If you think it's better that I remove the existing xorg.conf file and start from scratch let me know.

      I *think* that when I tried the --initial option I didn't understand the man page con aticonfig and probably used it wrong. As I remember it I didn't get a file at all. Later I took the xorg.conf that worked with ati-drivers circa 8.14.12 and used the --input option to let aticonfig modify the existing file. That's what I'm currently using.

      Reading through the man page again I found the horizontal and vertical sync commands so I got aticonfig to add those. I've set them to bogus values right now as I'm not able to find documentation on how they should be set to drive a TV. Those changes did not change my blue screen on the Mitsubishi so far but I'm sure the values are wrong.

      Here's the file in it's current state. I turned off DRI after posting yesterday:

      myth14 ~ # cat /etc/X11/xorg.conf

      # ************************************************** ********************
      # Module section -- this section is used to specify
      # which dynamically loadable modules to load.
      # ************************************************** ********************
      # ************************************************** ********************
      # Files section. This allows default font and rgb paths to be set
      # ************************************************** ********************
      # === ATI device section ===

      Section "ServerLayout"
      Identifier "Server Layout"
      Screen 0 "aticonfig-Screen[0]" 0 0
      InputDevice "Mouse1" "CorePointer"
      InputDevice "Keyboard1" "CoreKeyboard"

      Section "Files"

      # FontPath "/usr/share/fonts/Speedo/"
      # ModulePath "/usr/X11R6/lib/modules"
      RgbPath "/usr/lib/X11/rgb"
      FontPath "/usr/share/fonts/local/"
      FontPath "/usr/share/fonts/misc/"
      FontPath "/usr/share/fonts/75dpi/:unscaled"
      FontPath "/usr/share/fonts/100dpi/:unscaled"
      FontPath "/usr/share/fonts/Type1/"
      FontPath "/usr/share/fonts/75dpi/"
      FontPath "/usr/share/fonts/100dpi/"

      Section "Module"
      Load "dbe" # Double buffer extension
      SubSection "extmod"
      Option "omit xfree86-dga"
      Load "type1"
      Load "freetype"
      Load "glx" # libglx.a
      # Load "dri" # libdri.a

      Section "InputDevice"

      # Option "Protocol" "Xqueue"
      # Option "LeftAlt" "Meta"
      # Option "RightAlt" "ModeShift"
      # Option "XkbModel" "pc101"
      # Option "XkbLayout" "us"
      # Option "XkbVariant" ""
      # Option "XkbOptions" ""
      # Option "XkbDisable"
      Identifier "Keyboard1"
      Driver "kbd"
      Option "AutoRepeat" "500 30"
      # Option "Xleds" "1 2 3"
      Option "XkbModel" "pc104"
      Option "XkbLayout" "us"

      Section "InputDevice"

      # Option "BaudRate" "9600"
      # Option "SampleRate" "150"
      # Option "Emulate3Buttons"
      # Option "Emulate3Timeout" "50"
      # Option "ChordMiddle"
      Identifier "Mouse1"
      Driver "mouse"
      Option "Protocol" "PS/2"
      Option "Device" "/dev/input/mice"
      # Option "Protocol" "Xqueue"

      Section "Monitor"
      Identifier "aticonfig-Monitor[0]"
      HorizSync 30.0 - 30.0
      VertRefresh 55.0 - 65.0
      Option "VendorName" "ATI Proprietary Driver"
      Option "ModelName" "Generic Autodetecting Monitor"
      Option "DPMS" "true"

      Section "Device"
      Identifier "aticonfig-Device[0]"
      Driver "fglrx"
      Option "ForceMonitors" "nocrt1,nocrt2,tv"

      Section "Screen"
      Identifier "aticonfig-Screen[0]"
      Device "aticonfig-Device[0]"
      Monitor "aticonfig-Monitor[0]"
      DefaultDepth 24
      SubSection "Display"
      Viewport 0 0
      Depth 24
      Modes "640x480"

      #Section "DRI"
      # Mode 0666

      myth14 ~ #

      Again, thanks for any help you can lend. The family is cranky not having MythTV in the living room so I'd like to get it fixed for them.



      • #4
        Quickly scanning over the config file nothing jumps out.... Did you check on the config file if it matched that of myth12?

        You may just want to try starting a new xorg.conf and see if that works.
        Michael Larabel


        • #5
          Thanks for the response. Sorry for the slow reply. I've been spending time ensuring that both machines are as close to identical in terms of what they are running. That took a while. However, now they are just about as close as I can make them and still no improvement. Here's some status:

          1) myth12 functions correctly hooked *directly* to my Sony using both the old xorg.conf file and the new xorg.conf file. I get different warning messages in /var/log/Xorg.0.log but both files work on this machine.

          2) myth14 doesn't give a picture hooked to my Sony AV receiver which then goes to the Mitsubishi in the living room using either the old xorg.conf OR the new xorg.conf. However, with either file the Xorg.0.log file is identical to the appropriate myth12 log file. Basically all the software says everything is working identically. I just don't get a picture.

          3) I wondered about trying a completely new xorg.conf file but cannot master this simple program. If there is no xorg.conf file in the /etc/X11 directory I get this:
          myth14 X11 # ls -la
          total 32
          drwxr-xr-x 6 root root 4096 Aug 6 19:20 .
          drwxr-xr-x 46 root root 4096 Aug 5 17:53 ..
          drwxr-xr-x 2 root root 4096 Jul 28 16:52 Sessions
          drwxr-xr-x 2 root root 4096 Jul 28 15:19 app-defaults
          -rwxr-xr-x 1 root root 1506 Jul 28 15:38
          drwxr-xr-x 2 root root 4096 Jul 28 15:19 mwm
          -rwxr-xr-x 1 root root 922 Jul 28 15:38
          drwxr-xr-x 2 root root 4096 Jul 28 15:38 xinit
          myth14 X11 # aticonfig --initial --force
          Warning: Could not find configuration file
          Please copy configuration file template to /etc/X11

          If I copy an older file in it runs:

          myth14 X11 # cp /root/XORG/xorg.conf .
          myth14 X11 # aticonfig --initial --force
          Uninitialised file found, configuring.
          generate load 'dri' module
          Using xorg.conf
          Saved back-up to xorg.conf.fglrx-0
          myth14 X11 #

          I'm not sure what to make of any of this. I think I must be doing something silly but haven't figured it out. How do I create a real basic xorg.conf file using aticonfig from scratch? I don't seem to get that.

          One thing I have not done and really should do is drag MYth12 from the bedroom into the living room and hook it up to the receiver to make sure there isn't some problem beyond the machine. Possibly I can try that tomorrow.

          Again, thanks for your ideas and help.



          • #6
            BTW - I should have mentioned that on myth12, the good machine, both 8.26.18-r1 and 8.27.10-r1 work fine with both the old and new xorg.conf files. On myth14 however neither ati-driver with either xorg.conf file creates a usable output.

            Also, using the remote control I can navigate the MythTV menus blind. Doing this I can get to a recorded file and start it at which time I hear audio coming from the playback, so MYthTV is working and I'm just not able to configure the display correcctly.


            • #7
              To generate a completely new X configuration file, you should be able to do Xorg -configure, which is the default automatic way for Gentoo. It will then write it to /root/, and you then can test that configuration file without the ATI support, or immediately move it into the appropriate location, and then run aticonfig --initial. Hopefully that should work.
              Michael Larabel


              • #8

                Did you get your problem sorted out? Did you try the 8.28 drivers?

                ~ Michael
                Michael Larabel


                • #9
                  Hi Michael,
                  No, I'm afraid I didn;t. I then got quite frustrated and gave up. The family is not happy with me. Now that I've rested for a couple of weeks maybe it's time for me to try again. It would be nice to have it working.

                  I didn't know there was a new driver. I just updated Gentoo portage and it still shows 8.27.10-r1 as the newest so it appears I'll have to wait on that.

                  If you know of any online info about how to actually set up the ATI driver from scratch I would appreciate it. I seem to be unable to do this on my own.

                  Thanks for asking though.



                  • #10
                    I know some users on the forums have gotten the 8.28.8 drivers with Gentoo portage, but I am not much of a Gentoo user myself so I am not sure offhand on that issue.

                    Once you get the updated driver, try using aticonfig --initial as root, and see if that is able to fix your issues by using the default configuration.
                    Michael Larabel