No announcement yet.

Behavior of Sketchup under Wine + fglrx

  • Filter
  • Time
  • Show
Clear All
new posts

  • Behavior of Sketchup under Wine + fglrx

    Hi. I have two Fedora machines and one of them is experiencing some oddness running Google Sketchup 7 under Wine. Whenever the mouse pointer is positioned over the work area on the one machine, it is surrounded by an opaque white square making it almost impossible to position anything accurately. This doesn't happen in 2D apps (ie. Firefox) or when the mouse pointer is on the menubar. That suggests a 3D-specific problem.

    A google search shows a number of people have this problem and for the most part they're blaming Wine but I think the problem lies elsewhere...

    Both machines are x86-64, running identical versions of Sketchup under identical versions of Wine (compiled from source on both machines). The difference is the video drivers: the machine that works (no white square) is running the nVidia proprietary drivers; the machine with the white square is running the ATI proprietary drivers.

    Given this, it smells like the problem lies in the ATI OpenGL libraries.

    Does this sound like a known problem and is there a fglrx driver setting that might mitigate the problem?

    Catalyst Control Center reports:
    2D Driver Version: 8.67.4
    RandR Version: 1.2

    fglrxinfo reports:
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Mobility Radeon HD 3400 Series
    OpenGL version string: 2.1.9116

  • #2
    Have you tried with the open source driver?


    • #3
      Originally posted by krazy View Post
      Have you tried with the open source driver?
      Actually, I haven't tried them lately. When I initially installed Fedora 11 on this machine (a Thinkpad T400), I swapped between the ATI proprietary drivers and the F11's OSS drivers a couple times and noticed that the fan ran unusually high when using the OSS drivers so I haven't tried them since.

      I'll try the F11 OSS drivers again tonight...


      • #4
        I just tried it with radeon KMS+DRI2 on a 4850 and it crashed X while trying to open..