No announcement yet.

Fglrx locks after startup

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Kanotix Excalibur appears to be a cd's worth...... Hmmmmm I do have though rather very strange and individual (who said archaic?) taste in Linux though...... FVWM 4ever.


    • #12
      Still no joy.....

      Obtained the Hotfix file placed into /usr/src and ran the script. When wget tried to fetch the file failed with a 404 error "file not found"

      This happened twice, third time OK but script failed because it could not find any packages to install. A bit of clairvoyance then came up with the following. I have three kernels in the boot directory the debian installed kernel and two others I have compiled my self, first one being 2nd being 2.6.30 both have sources availible to them. The system was running on but the script was building the packages for 2.6.30 but trying to install packages for the first.

      Lilo changed to boot 2.6.30 script then ran OK and installed everything.
      Unfortuantely system still locks up on starting X. What happens exactly is the X starts draws the mouse pointer the window manager starts draws all its graphics then the system locks.

      I have had this with RadeonHD which was caused by there being modelines in the xorg.conf file.

      All versions of FGLRX behave the same way, I have tried 9-7, 9-12 and 9-12 Hotfix.
      The system is the following
      Motherboard ASUS P7P55D-E-Deluxe
      Processor I5 750
      Graphics Sapphire Radeon HD4870

      The Graphics card and the kernel both were OK in the previous motherboard this being an Gigabyte GA P35 DS03 and running Catalyst 9-7.

      It is appearing that FGLRX does not like the P7P55

      On the weekend will try an ASUS Nvidia EN9600 and see what happens
      Last edited by Blacksmith; 01-21-2010, 04:23 AM.


      • #13
        Because FGLRX is intended to be a stable enterprise driver not with all the latest and greatest I wonder if the problem could hardware (the ASUS MB) is to new and untested.


        • #14
          Just install Kanotix and try again. You must be using a hell of a hacked system even using LILO??! Nobody uses that anymore usually.


          • #15
            Stupid forums is stopping me from posting again,
            The system at this stage is standard minimum install of Debian testing, I usually hack Debian around but at this stage have not got the system running properly.
            I use lilo because I know EXACTLY how it works and I dislike complexity greatly. The more complex something is the easier it is to break it. See the current situation!!!!!!!!
            Problem with getting Kanotix is the download is 835 meg this will be pushing the three hour limit at the cafe.

            I will consider the situation at this stage will try the Nvidia to see if it works. I need antaliasing for a project I am working on and therefore require a closed src driver does not bother me which one.

            I will be getting a full set of DVD's for testing in a few weeks may wait till then.

            I believe FGLRX should work in the current instance (standard debian testing install) but does not!

            Last edited by Blacksmith; 01-21-2010, 04:39 PM.


            • #16
              Well i am used to 10 min or less for 800 mb download. Is your Internet cafe on dialup too?


              • #17
                We are talking about VERY rural Australia here. No large towns, Cable or Optic fibre to propertys and unlikely there ever will be because of the cost would be prohibitive. Satelite is almost useless. Cafe is probably on ADSL1 as ADSL2 has only recently been introduced in the area so we are not talking 100's of megabytes per second.
                I find few people even up to the Australian Gov understand the problem it is when almost everybody assumes you have high bandwidth internet when it is unlikely ever to be availible.

                Note: I like living here and this sort of problem comes with the territory along with having to provide own Water,waste displosal, power and such like.

                Anyway very much thanks for your help Kano been VERY much apreciated, going to put this problem on hold for a bit as it does not look like it will be resolved in a simple and timely manner.
                Will give the Nvidia a go to make sure it is not some weird anti LInux thing with the motherboard.

                Many Thanks
                Last edited by Blacksmith; 01-21-2010, 07:03 PM.


                • #18
                  Progress is being made, I have got FGLRX running without DRI and on testing the radeon driver works great. RadeonHD driver also works but scrambles and locks up the console on exit.

                  The major problem appears to be that Kano's script does not like the way I do things.
                  The way I do things is driven by two things,

                  1: I been have running linux for a long time and have significantly differing prioritys from the vast majority of users. I do not consider Linux difficult to use or configer. I do NOT need a window manager that looks or behaves like one from a very well known software company.

                  2: I am on dialup internet access given the location I live this is VERY unlikely to change anytime soon. It drives me totally mad the way that debian will cheerfully try and pull in 10 of megabytes of packages when you try and do something, this is something I simpley cannot do.

                  The problem that appears to be stopping the script from functioning properly is the way i have the source code laid out this is deffinitly confusing the script. Next time I head into town I am going to get all the header and src packages for the system this with any kind of luck will solve the problem, I hope.
                  Last edited by Blacksmith; 01-22-2010, 03:20 PM.


                  • #19
                    When you would compile your kernels the debian way it would definitely help - also you need correct header positions. When you compile it around the system then you run into troubles. When you use make-kpkg and create image+header packages (with initrd) you usually have to fix the symlinks in

                    /lib/modules/$(uname -r)/build

                    as soon as you delete the source. Manually installed it should be possible but as my script executes

                    m-a prepare

                    it will not do good things if you don't use packaged kernels. But that's definitely no error in the script.


                    • #20
                      Thanks for your help Kano, I will keep plugging along on my path I am on. I may not post again on these forums, It keeps on stopping me from posting (which is REALLY annoying) as far as I can see unless the posts are VERY short.

                      How other are doing long posts I do not know.

                      fglrx module now compiles but does not load saying "no version information for module layout"

                      As far as I can see system layout is now standard debian, Will give the Nvdia a go.
                      Last edited by Blacksmith; 01-23-2010, 04:38 PM.