No announcement yet.

ATI Radeon HD 5770 + Catalyst 9.12 + XBMC = Problems

  • Filter
  • Time
  • Show
Clear All
new posts

  • ATI Radeon HD 5770 + Catalyst 9.12 + XBMC = Problems

    Hi all,

    The title says it all: I can't get XBMC to start on a very new pc.
    The screen turns black, with just the XBMC-mouse cursor in the middle of the screen (unable to move it). All I can do is Ctrl-Alt-F1, then 'killall xbmc.bin' and return via Ctrl-Alt-F7 (after which the right-bottom part of the screen is a little bit "scrambled").
    I'm a long time XBMC user (always on NVidia before), but it doesn't work on my ATI/AMD card. I was hoping that any of you might confirm/disprove my problem. It would be even better if someone would have a solution/workaround. I'm willing to do as many kinds of test as needed in order to help.

    My setup:
    - CPU: AMD PhenomII X4 965
    - GPU: HD 5770 (on an Asus board)
    - OS: Ubuntu 9.10 (64 bit)
    - Catalyst 9.12 (with hotfix)
    - XBMC 9.11

    Things I have tried:
    - Compiz on/off
    - different resolutions
    - Catalyst 9.11 9.10 ...

    Thanks in advance,


    PS: I posted this on the XBMC forums, but they couldn't really help, so I'm trying Phoronix now (long time reader, first time poster)

  • #2

    I have recently testing XBMC on my Phenom X3 + ATI HD 4850.
    I got some random crashes but they were related to some weird settings I forced. I'm on 9.12+Hotifx using Ubuntu 9.10.

    If I use 2 screens when XBMC I got one completly black and the other with XBMC. Try to press "\" to see if you can use (or see at least) XBMC in windowed mode.


    • #3
      As far as I am concerned I don't have any weird settings at all. I just installed Ubuntu 64, then the latest drivers and finally xbmc 9.11. Didn't work.

      I have noticed that the screen doesn't turn black instantly, I can see the "xbmc" letters for a fraction of a second...


      • #4
        Why don't you test your nv card?


        • #5
          Because it's an AGP card and no matter how much I try, I can't get it into the PCI-Expres slot of my new mobo


          • #6
            Well then it is a bit harder, maybe you have got a friend to exchange cards.


            • #7
              Just in case somebody stumbles upon this thread: My problem went away since Catalyst 10.2. Everything works great now.


              • #8

                I have to use xbmc set to arb for ati, auto/glsl rendering does not work. Don't you think that was the change you did? I can not see any fglrx improvements at all with xbmc glsl code.


                • #9
                  Kano, I couldn't start the program at all using Catalyst 9.x, so there was no way for me to play with the video settings.
                  Due to time constraints I didn't try the Catalyst 10.1 driver.
                  When I installed Catalyst 10.2, I thought I'd try to install XBMC once again, just to see if it'd make any difference, and lo and behold, it all worked, without me fiddling with the settings at first.