Announcement

Collapse
No announcement yet.

ATI fglrx 8.27.10 Discussion (July 2006)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Michael
    started a topic ATI fglrx 8.27.10 Discussion (July 2006)

    ATI fglrx 8.27.10 Discussion (July 2006)

    ATI Linux fglrx 8.27.10 for x86 and x86_64 have just been released.

    # X.org 7.1 Support
    # Fedora Core Package Support
    # X1000 TV-out support
    Release Notes: https://a248.e.akamai.net/f/674/9206...x_8.27.10.html

    Phoronix Coverage

    After ATI's successful launch last month of the fglrx 8.26.18 drivers, which had delivered an external events daemon (atieventsd) and more, it is now time for us to discuss the changes in the newly released 8.27.10 Linux display drivers. Of the changes in this release include X11R7.1 support, Fedora Core packaging scripts, and Radeon X1000 TV-out support. As always, we have all of the details to share in our ATI fglrx 8.27.10 driver examination.
    http://www.phoronix.com/vr.php?view=7085

    Feel free to discuss, post questions, etc...

  • kramey
    replied
    Release Package

    I am using the .run file from ATI:

    ati-driver-installer-8.27.10-x86.run

    I used the "uninstall" script to remove the 8.26 version, which was working fine.

    ken

    Leave a comment:


  • Michael
    replied
    What distribution are you using? Did you use the packaging scripts for that distribution?

    Leave a comment:


  • kramey
    replied
    FC5 Problems

    I updated my ATI drivers tonight from 8.26 to 8.27.10 and am having a strange problem. If I execute "glxinfo" as myself, it says I only have "Indirect Rendering". If I run it as su, it says I have direct rendering. If, after doing "glxinfo" as root, I run it again as myself, it still reports "Indirect Rendering". "glxgears" gives about 200 FPS as my usual userid and just over 250 FPS as root. Clearly something is not right.

    The output of "uname -a":
    Linux myrthin 2.6.17-1.2174_FC5 #1 Tue Aug 8 15:30:55 EDT 2006 i686 i686 i386 GNU/Linux

    glxinfo as normal user:

    name of display: :0.0
    display: :0 screen: 0
    direct rendering: No
    server glx vendor string: SGI
    server glx version string: 1.2
    server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGIS_multisample, GLX_SGIX_hyperpipe, GLX_SGIX_swap_barrier,
    GLX_SGIX_fbconfig
    client glx vendor string: ATI
    client glx version string: 1.3
    client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
    GLX_ATI_render_texture
    GLX version: 1.2
    GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_multisample
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.4.2)
    OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
    GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_lod_bias
    glu version: 1.3
    glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

    glxinfo as root:
    name of display: :0.0
    display: :0 screen: 0
    direct rendering: Yes
    server glx vendor string: SGI
    server glx version string: 1.2
    server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGIS_multisample, GLX_SGIX_hyperpipe, GLX_SGIX_swap_barrier,
    GLX_SGIX_fbconfig
    client glx vendor string: ATI
    client glx version string: 1.3
    client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
    GLX_ATI_render_texture
    GLX version: 1.2
    GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_multisample
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: MOBILITY RADEON 9700 Generic
    OpenGL version string: 2.0.5946 (8.27.10)
    OpenGL extensions:
    GL_ARB_multitexture, GL_EXT_texture_env_add, GL_EXT_compiled_vertex_array,
    GL_S3_s3tc, GL_ARB_depth_texture, GL_ARB_fragment_program,
    GL_ARB_fragment_program_shadow, GL_ARB_fragment_shader,
    GL_ARB_multisample, GL_ARB_occlusion_query, GL_ARB_point_parameters,
    GL_ARB_point_sprite, GL_ARB_shader_objects, GL_ARB_shading_language_100,
    GL_ARB_shadow, GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
    GL_ARB_texture_compression, GL_ARB_texture_cube_map,
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
    GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
    GL_ARB_texture_mirrored_repeat, GL_ARB_transpose_matrix,
    GL_ARB_vertex_blend, GL_ARB_vertex_buffer_object, GL_ARB_vertex_program,
    GL_ARB_vertex_shader, GL_ARB_window_pos, GL_ARB_draw_buffers,
    GL_ATI_draw_buffers, GL_ATI_element_array, GL_ATI_envmap_bumpmap,
    GL_ATI_fragment_shader, GL_ATI_map_object_buffer, GL_ATI_separate_stencil,
    GL_ATI_texture_env_combine3, GL_ATI_texture_float,
    GL_ATI_texture_mirror_once, GL_ATI_vertex_array_object,
    GL_ATI_vertex_attrib_array_object, GL_ATI_vertex_streams,
    GL_ATIX_texture_env_combine3, GL_ATIX_texture_env_route,
    GL_ATIX_vertex_shader_output_point_size, GL_EXT_abgr, GL_EXT_bgra,
    GL_EXT_blend_color, GL_EXT_blend_func_separate, GL_EXT_blend_minmax,
    GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
    GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_framebuffer_object,
    GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels, GL_EXT_point_parameters,
    GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_shadow_funcs, GL_EXT_stencil_wrap,
    GL_EXT_texgen_reflection, GL_EXT_texture3D,
    GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
    GL_EXT_texture_edge_clamp, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
    GL_EXT_texture_lod_bias, GL_EXT_texture_mirror_clamp,
    GL_EXT_texture_object, GL_EXT_texture_rectangle, GL_EXT_vertex_array,
    GL_EXT_vertex_shader, GL_HP_occlusion_test, GL_NV_blend_square,
    GL_NV_occlusion_query, GL_NV_texgen_reflection, GL_SGI_color_matrix,
    GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays
    glu version: 1.3
    glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

    The ATI Control Panel shows Indirect Rendering.

    Any suggestions would be GREATLY appreciated.

    Thanks.

    ken

    Leave a comment:


  • dgvirtual
    replied
    8.27.10 supports 3d acceleration on my Radeon 9200 video card. On both 8.26 and 8.25 it was broken (had to use a patch from 8.24 driver version). I am running Kubuntu Dapper.

    Leave a comment:


  • steve
    replied
    Originally posted by Michael
    Did you try reinstalling kernel-devel?
    My problem was that my kernel and kernel-devel were out of step. When I installed kernel-devel with yum, it didn't mention that I needed to update the kernel package. The updated kernel package gives me the symlink to /lib/modules, which was missing before.

    Leave a comment:


  • Michael
    replied
    rpm -qf /lib/modules/2.6.17-1.2157_FC5/build/include/linux/version.h
    returns
    kernel-devel-2.6.17-1.2157_FC5

    rpm -qf /lib/modules/2.6.17-1.2157_FC5/build
    returns
    kernel-2.6.17-1.2157_FC5

    ls -l /lib/modules/2.6.17-1.2157_FC5/build
    returns
    lrwxrwxrwx 1 root root 47 Jul 15
    21:59 /lib/modules/2.6.17-1.2157_FC5/build -> ../../../usr/src/kernels/2.6.17-1.2157_FC5-i686

    At first glance, something's broken on his end. Or he doesn't actually have
    kernel-devel installed.

    Niko
    Did you try reinstalling kernel-devel?

    Leave a comment:


  • Michael
    replied
    What specific kernel version are you using? I haven't come across such an issue with kernel-devel myself, though I will try to get an answer for you from Niko (the author of the main Fedora packaging scripts).

    Leave a comment:


  • steve
    replied
    Originally posted by Michael
    Are you trying to use the automatic installer? or generating the RPMs using --buildpkg Fedora/FC5 ?

    kernel and kernel-devel should be the only kernel-related packages you need.

    If you're using the --buildpkg, what is the complete output.
    Yes, I'm using --buildpkg. The complete output is:

    --------------------------------
    Creating directory fglrx-install
    Verifying archive integrity... All good.
    Uncompressing ATI Proprietary Linux Driver-8.27.10........................................... .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. ........................................
    ==================================================
    ATI Technologies Linux Driver Installer/Packager
    ==================================================
    Generating package: Fedora/FC5
    Please install an appropriate Linux kernel module build package.
    Probably kernel-devel in this case.
    If you've compiled a custom kernel, make sure /usr/src/linux exists
    and the source tree matches the currently running kernel.
    -----------------------------------

    I've looked in the script ati-packager.sh that generates the message,
    and it is testing for /lib/modules/${kernel_variant}/build/include/linux/version.h, as I mentioned. I think the problem is that the kernel-devel package has put include/linux/version.h under /usr/src/kernels/${kernel_variant}.
    I don't know whether the rest of the script actually depends on the files being under /lib/modules.

    Leave a comment:


  • Michael
    replied
    Are you trying to use the automatic installer? or generating the RPMs using --buildpkg Fedora/FC5 ?

    kernel and kernel-devel should be the only kernel-related packages you need.

    If you're using the --buildpkg, what is the complete output.

    Leave a comment:

Working...
X