Announcement

Collapse
No announcement yet.

AMD Catalyst 9.10 Linux Driver Released

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • phoronix
    started a topic AMD Catalyst 9.10 Linux Driver Released

    AMD Catalyst 9.10 Linux Driver Released

    Phoronix: AMD Catalyst 9.10 Linux Driver Released

    Available over at AMD.com is now the Catalyst 9.10 Linux driver update. The release notes for this driver have yet to be uploaded there, but the Catalyst 9.10 Linux driver offers support for arbitrary transformations with RandR 1.3, support for loading the fglrx kernel module when an open-source DRM kernel module is still loaded, a fix for the fglrx kernel module when using DKMS 2.1.0, an AMDCCCLE menu item issue has been resolved, support for the Radeon HD 5750/5770 Juniper graphics cards, and other bug fixes...

    http://www.phoronix.com/vr.php?view=NzYzMg

  • BlackStar
    replied
    Originally posted by DarthFrog View Post
    Which I did and they do recognise my HD5770 card. But I have encountered a number of bugs with them that pretty much make them unusable, as they destabilise the system and corrupt video in some of the main apps I use (wine and MythTV). I have my fingers crossed that beta testers in the closed beta caught these bugs but I seem to have no way to give feedback to the developers.
    The 9.11 drivers are supposed to include official support for 57x0, so (with some luck) these issues may be fixed...

    Leave a comment:


  • DarthFrog
    replied
    Originally posted by BlackStar View Post
    You don't need to be part of the beta group to download these files. Just create an account on amd.com and you can download them.
    Which I did and they do recognise my HD5770 card. But I have encountered a number of bugs with them that pretty much make them unusable, as they destabilise the system and corrupt video in some of the main apps I use (wine and MythTV). I have my fingers crossed that beta testers in the closed beta caught these bugs but I seem to have no way to give feedback to the developers.

    Leave a comment:


  • BlackStar
    replied
    Originally posted by skytja View Post
    I'll wait. I don't much like beta-ware, since I'm not a developer/coder. People don't seem to have patience anymore these days.

    When 9.11 comes-out of Beta, I'll shift back from other projects to the box I put the 5770 into. I'm out of practice dishing and planishing, anyway. (My Japanese bosses are in a tizzy over some things, so fiddling with software isn't enough of a frustration-release right now. Luckily for me, cold-working metal is. )

    The links all say:

    http://developer.amd.com/gpu/ATIStre...s/default.aspx

    Login
    You must be logged in to download tools from AMD Developer Central

    But yes, that is the page, if you are a part of the beta-group:

    Linux? (openSUSE™ 11.0, Ubuntu? 9.04)
    ati-opencl-beta-driver-v2.0-beta4-lnx.zip (82.3MB) 10/13/2009 32-bit / 64-bit Required to run ATI Stream SDK v2.0-beta4 on AMD GPUs on 32-bit and 64-bit Linux?
    ati-stream-sdk-v2.0-beta4-lnx32.tgz (24.0MB)
    10/13/2009 32-bit ATI Stream SDK built for 32-bit Linux?
    ati-stream-sdk-v2.0-beta4-lnx64.tgz (42.5MB)
    10/13/2009 64-bit ATI Stream SDK built for 64-bit Linux?
    You don't need to be part of the beta group to download these files. Just create an account on amd.com and you can download them.

    Leave a comment:


  • Qaridarium
    replied
    Originally posted by Melcar View Post
    Nope. The fglrx beta program is closed to the general public and you need to sign a NDA to join. There are leaked copies of the beta drivers out there if one is so inclined to search, usually posted by individuals who don't care about contracts or managed to hack into tester's email accounts (or the mailing list itself).
    "or managed to hack into tester's email accounts (or the mailing list itself)."

    wohooo realy bad people! we sould doom them all.

    Leave a comment:


  • skytja
    replied
    9.11 Beta drivers are part of a closed-beta.

    Originally posted by RealNC View Post
    Actually, that link *is* the 9.11 beta talked about in this forum.

    I'll wait. I don't much like beta-ware, since I'm not a developer/coder. People don't seem to have patience anymore these days.

    When 9.11 comes-out of Beta, I'll shift back from other projects to the box I put the 5770 into. I'm out of practice dishing and planishing, anyway. (My Japanese bosses are in a tizzy over some things, so fiddling with software isn't enough of a frustration-release right now. Luckily for me, cold-working metal is. )

    The links all say:

    http://developer.amd.com/gpu/ATIStre...s/default.aspx

    Login
    You must be logged in to download tools from AMD Developer Central

    But yes, that is the page, if you are a part of the beta-group:

    Linux? (openSUSE? 11.0, Ubuntu? 9.04)
    ati-opencl-beta-driver-v2.0-beta4-lnx.zip (82.3MB) 10/13/2009 32-bit / 64-bit Required to run ATI Stream SDK v2.0-beta4 on AMD GPUs on 32-bit and 64-bit Linux?
    ati-stream-sdk-v2.0-beta4-lnx32.tgz (24.0MB)
    10/13/2009 32-bit ATI Stream SDK built for 32-bit Linux?
    ati-stream-sdk-v2.0-beta4-lnx64.tgz (42.5MB)
    10/13/2009 64-bit ATI Stream SDK built for 64-bit Linux?

    Leave a comment:


  • RealNC
    replied
    Actually, that link *is* the 9.11 beta talked about in this forum.

    Leave a comment:


  • Melcar
    replied
    Originally posted by smitty3268 View Post

    Nope. The fglrx beta program is closed to the general public and you need to sign a NDA to join. There are leaked copies of the beta drivers out there if one is so inclined to search, usually posted by individuals who don't care about contracts or managed to hack into tester's email accounts (or the mailing list itself).

    Leave a comment:


  • smitty3268
    replied
    Originally posted by DarthFrog View Post
    Where did you get them from, please? Could you be so kind as to provide a link? I can't find anything about Catalyst and Linux on the ATI site and am having to use the vesa driver with my 5770. :-(
    Is it this one, maybe?

    http://developer.amd.com/gpu/ATIStre...s/default.aspx

    Leave a comment:


  • DarthFrog
    replied
    Originally posted by shaker View Post
    I gave up on the 9.10 drivers and installed the 9.11 beta drivers and everything seems to be perfect now
    Where did you get them from, please? Could you be so kind as to provide a link? I can't find anything about Catalyst and Linux on the ATI site and am having to use the vesa driver with my 5770. :-(

    --
    Cheers,
    Rob

    Leave a comment:

Working...
X