Announcement

Collapse
No announcement yet.

wine + fglrx ==> Please

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • storma
    replied
    It makes sure your using the fglrx openGL implementation, not mesa. Why it should change back, I'm not sure.

    Leave a comment:


  • gforum
    replied
    umm... ok so this is yet another env, good.
    now... what does it do exactly?


    cheers

    Leave a comment:


  • fermulator
    replied
    Originally posted by storma View Post
    What I've gotten into the habit of doing is creating a wrapper script for my games, so it's just a matter of adding it before the line to start the game.
    I've done the same thing (I have a master "game_launcher" script which handles lots of stuff like this, including replacing compiz with metacity), but the point is that we shouldn't have to, and it would be interesting to see the reason for this environment variable being present..

    Leave a comment:


  • storma
    replied
    What I've gotten into the habit of doing is creating a wrapper script for my games, so it's just a matter of adding it before the line to start the game.

    Leave a comment:


  • fermulator
    replied
    Actually, could someone from ATI please comment on this "bug"? -- When/How/Why could this environment variable be set?

    It has caused at least some of us some grief, and it would be good to figure out how to avoid this for future users.

    Leave a comment:


  • fermulator
    replied
    Originally posted by gforum View Post
    hey storma, where do you put that?(unset LIBGL_ALWAYS_INDIRECT)

    in the shortcut for the program you trying to use or whatnot?
    This works!

    The LIBGL_ALWAYS_INDIRECT is an environment variable in your terminal. So before you would run (simplified)
    Code:
    wine $my_game
    You'll want to do:
    Code:
    unset LIBGL_ALWAYS_INDIRECT

    Leave a comment:


  • gforum
    replied
    Originally posted by storma View Post
    whenever you see that, 'unset LIBGL_ALWAYS_INDIRECT'

    I'm not sure why it drops back, I thought it might of been something that I did in setting up compiz but I could never find it.
    hey storma, where do you put that?(unset LIBGL_ALWAYS_INDIRECT)

    in the shortcut for the program you trying to use or whatnot?

    Leave a comment:


  • storma
    replied
    OpenGL version string: 1.4 (2.1.8918)
    whenever you see that, 'unset LIBGL_ALWAYS_INDIRECT'

    I'm not sure why it drops back, I thought it might of been something that I did in setting up compiz but I could never find it.

    Leave a comment:


  • Ant P.
    replied
    From what I've read, the WINE devs were using nVidia cards, so instead of writing to standards they went and implemented its 3D stuff using a bunch of nVidia-proprietary GL extensions. Complaining about fglrx "catching up" enough to run WINE would be like complaining that Opera needs to catch up to run the windowsupdate site.

    Yeah, let's all just use Windows and IE... it's better!!11</sarcasm>

    Leave a comment:


  • fermulator
    replied
    What do you mean by "catch up"? -- Using the latest fglrx drivers I'm able to run native linux games without issues (Heroes of Newerth, QIII, UT2K4, DoomIII, etc.) --- what is the difference between "OpenGL 2" working on native apps, and "OpenGL 2" not working in WINE? (I quite honestly don't know) ;-)

    Leave a comment:

Working...
X