No announcement yet.

Radeon x1300 windows not updating

  • Filter
  • Time
  • Show
Clear All
new posts

  • Radeon x1300 windows not updating

    CPU: Pentium D
    Kernel: 2.6.20-1.2933.fc6
    X Server Version:7.1.1
    Video Card: VisionTek XGE : ATI Radeon x1300

    I have finally got DRI enabled, but now I'm having trouble with screen updates.

    Web browser windows when scrolled dont update until I click on another window and then back to the browser window.

    When I move a window it disappears until I can find the title bar and click on it, then the window redraws itself

    Catalyst Control Center reports DRI enabled

    Glxinfo reports Direct Rendering

    glxgears window is completely transparent (no geards, no background, desktop shows through).

    Here are parts of my xorg.conf file. I have tried many Options as I've found them on the internet, but none seem to make any difference. I have searched the Internet, the ATI buzilla site and this site, but found no mention of my exact problem. It seems that the drivers are almost working, but im missing something small.

    Section "Device"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    Option "VideoOverlay" "on"
    # Option "TexturedVideo" "on" #Tried this it didnt help
    Option "OpenGLOverlay" "off"

    Section "Extensions"
    Option "Composite" "false"

    Section "ServerFlags"
    Option "AIGLX" "off"

    My card is a third party VisionTek XGE with ATI X1300 chipset. It claims to be factory overclocked at 600MHz, if that makes a difference.

    XOrg.0.log reports no problems that I can see,

    Any help will be greatly appreciated.

  • #2
    I am using an Envision H193Wk flat panel widescreen display with a resolution of 1440x900. Could this be part of the trouble? I noticed that when in 1280x1024 mode, terminal windows come up with no background. You can see the desktop through the window. But when I put it in 1440x900 the terminal windows look fine when they come up, though I still have trouble with the screen updates when I move them or type anything.


    • #3
      What is the output of glxinfo and cat /var/log/Xorg.0.log | grep WW
      Michael Larabel


      • #4
        I thought it must be something I was missing. Everything seemed to be setup right with the exception of the lagging screen updates. Playing around in bios I set my AGP Aperture settings from 128Mb to 256Mb and that fixed the problem.