No announcement yet.

Arch64+Wine+Fglrx=failsauce STUMPED

  • Filter
  • Time
  • Show
Clear All
new posts

  • Arch64+Wine+Fglrx=failsauce STUMPED

    Hey guys, I just wanted to run a few things by the community before I started trying to run 3 year old workarounds from the Ubuntu forums

    The problem is this, I have installed (yaourt -S catalyst catalyst-utils), have successfully installed 9.8 fglrx, have the module active through rc.conf and am trying to test out a few games with wine. Im reading about fellow arch users being able to play games on arch so I am hopeful, but have yet to find a solution.

    Direct Rendering is working

    glxinfo | grep direct
    direct rendering: Yes

    Driver is working properly
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Radeon HD 4870
    OpenGL version string: 2.1.8918

    I am using compiz, (have tried fluxbox on games as well, just to see if gnome or compiz were the culprits)
    I have the lib-32 catalyst-utils installes
    I am using vlc with open-gl output (so I know for sure it works)
    I have tried wine app.exe -opengl (get the same crash and output as without the -opengl option) (glxgears and fgl_gears work as well)

    Now that that is cleared up (not trying to sound arrogant just trying to provide the maximum amount of info possible)

    This is the output when I try to run one of the games I am attempting to play

    fixme:mixer:ALSA_MixerInit No master control found on HDA ATI HDMI, disabling mixer
    fixme:mixer:ALSA_MixerInit No master control found on HDA ATI HDMI, disabling mixer
    err:module:load_builtin_dll failed to load .so lib for builtin L"winemp3.acm": cannot open shared object file: No such file or directory
    fixme:ntdll:server_ioctl_file Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
    fixme:win:EnumDisplayDevicesW ((null),0,0x32e95c,0x00000000), stub!
    X Error of failed request: BadMatch (invalid parameter attributes)
    Major opcode of failed request: 160 (GLX)
    Minor opcode of failed request: 5 (X_GLXMakeCurrent)
    Serial number of failed request: 525
    Current serial number in output stream: 525

    NOTE: I dont think that the content above "X Error of failed blah blah blah" is pertinent to this particular problem, but being the nubzilla that I am, included it just in case it is.

    This is my xorg.conf

    Please help! Thanks in advance!

  • #2
    restarting X always fixes this error for me.