No announcement yet.

No DRI with fglrx (any version) and I really tried hard :(

  • Filter
  • Time
  • Show
Clear All
new posts

  • No DRI with fglrx (any version) and I really tried hard :(

    Hi people!

    I'm running a Debian testing on my Thinkpad T60 with an ATI X1400. For a couple of days I'm trying to get the fglrx work correctly but it just doesn't want to. I googled a lot and tried tons of hints, tips and tricks...

    To install the driver I'm using the Kanotix Script and I configured it to use the 8-12 version of the driver (with the newer ones I can't get the Powerstates working).

    The running kernel version is self compiled 2.6.26 but I also tried stock kernels which don't work either.

    As I'm kind of desperate cause I need more 3D performance for an OpenGL project, I also tried the radeonhd but it is way to bad.

    If you need any further information let me know and I'll provide asap.

    [email protected]:~$ fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: Mesa project:
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.4 (2.1 Mesa 7.0.4)
    my xorg.confxorg.conf
    my Xorg.0.log

  • #2
    radeon (not radeonhd) is quite good. radeon should be in a package called "xf86-ati" or similar (as opposed to radeonhd that should be in something like "xf86-radeonhd").

    With that being said, "OpenGL vendor string: Mesa project" means the driver is not installed correctly; the opengl libs of fglrx are missing.


    • #3
      The fgrlx kernel module was not compiled or libdrm is too new.
      Last edited by Kano; 09-12-2009, 12:18 PM.


      • #4
        Well, the Kanotix script compiles the module correctly as I can load via modprobe. How do I figure out if the libdrm is too new?

        And how do I check for the OpenGL libs of the fglrx?


        • #5
          The libdrm2 in lenny is ok, but in squeeze is too new. You could only update to sid, then the libdrm matches the new Xorg or use lenny. In the case you update to new Xserver you have to rerun the script - as it installs another driver then.
          Last edited by Kano; 09-13-2009, 06:35 PM.


          • #6
            So I need the libdrm2 out of sid and that should work with the 8-12? Do I need to upgrade the xserver etc to sid too?
            I need the xserver and libdrm2 out of stable (lenny)?
            Last edited by moritz; 09-14-2009, 03:51 AM.


            • #7
              libdrm2 is the same in squeeze and sid, but in order to make fglrx work the libdrm2 version must match the xserver version. nvidia does not have got this problem, but fglrx really sucks - in order to use a newer intel driver you need a new libdrm2, therefore i have to create a special intel iso...


              • #8
                Okay thanks for that help but I gave up on the fglrx and switched to the radeon driver. After a bit of try'n'error with the configuration it's working pretty good now