Announcement

Collapse
No announcement yet.

ATI FC6 + Kernel 2.6.20

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ATI FC6 + Kernel 2.6.20

    Hey all,
    since I've upgraded my kernel to 2.6.20(be it 2.6.20-1.2925.fc6-i686 or 2.6.20-1.2933.fc6-i686) the ATI drivers are not compiling properly anymore :-(
    Even the new driver release didn't fix my problems.
    Here is a link to the install log

    http://pastebin.ca/418553
    Can sum1 help me out with that?

    Thanks

  • #2
    Do you have kernel-headers and kernel-devel installed? More difficult reading a foreign log.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      I have the 2.6.20 Kernel and the rpms compiled, but when i went to install them i got conflict errors. Any ideas?

      Comment


      • #4
        Originally posted by gene6482 View Post
        I have the 2.6.20 Kernel and the rpms compiled, but when i went to install them i got conflict errors. Any ideas?
        What errors do you get?
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          I'm not at the machine right now (at work), but it said something to the effect of it conflicted with the old driver that was already there.

          Comment


          • #6
            Just use --force then
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #7
              will i need to use the script that i hear about everywhere to make it work, or just install the rpms that i got from ati?

              Comment


              • #8
                ok here's the error message

                error Failed dependencies:
                kmod-fglrx conflicts with ATI-fglrx-8.35.5-1.fc6.i386
                xorg-x11-drv-fglrx conflicts with ATI-fglrx-8.35.5-1.fc6.i386
                ATI-fglrx conflicts with xorg-x11-drv-fglrx-8.34.8-10.lvn6.i386

                Comment


                • #9
                  Originally posted by gene6482 View Post
                  ok here's the error message

                  After building the drivers and then generating the RPMs, just use:

                  rpm -ivh --force *.rpm

                  For those drivers. Should work.
                  Michael Larabel
                  http://www.michaellarabel.com/

                  Comment


                  • #10
                    here's the output

                    [[email protected] Desktop]# rpm -ivh --force *.rpm
                    error: Failed dependencies:
                    kmod-fglrx conflicts with ATI-fglrx-8.35.5-1.fc6.i386
                    xorg-x11-drv-fglrx conflicts with ATI-fglrx-8.35.5-1.fc6.i386
                    ATI-fglrx conflicts with xorg-x11-drv-fglrx-8.34.8-10.lvn6.i386
                    ATI-fglrx-devel conflicts with xorg-x11-drv-fglrx-8.34.8-10.lvn6.i386
                    [[email protected] Desktop]#

                    Comment

                    Working...
                    X