No announcement yet.

Can't get out of VESA...

  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    man radeon doesn't specifically say what it does, just that it enables or disables DRI.

    I'll reinstall in the morning... vanilla install - no updates, get Xorg working anyway I can... my pile of homework :P

    Thanks for all your help today... it is really appreciated, if nothing else I don't have to live in 1024x768 anymore... =)


    • #32
      OK, see you tomorrow


      • #33
        Ok... fresh install... setup a new user, to rule out any profile issues as well. No updates have been applied yet, setup SSH access and that's it. Progress as of now:

        Removed kernel parameter "xforcevesa" from grub boot line - had to install in safe graphics mode.

        Replaced "vesa" with "radeon" in xorg.conf

        reboot... and a really expensive paper-weight is what I have... =) I think it's important to note, that I setup a new user after this install. GDM is not set to auto-login, and the lock up happens before I even see a login screen. X flashes like it's about to start, and the machine locks up.


        for your perusal... no obvious errors, it should be working...

        Had to add the Option "DRI" "false" to xorg.conf to get a desktop... Maybe it's just me, but the DRI option seems to be a bit more functional that the NoAccel option. I notice the difference when scrolling through Synaptic mostly. NoAccel is horrendous...


        • #34
          Just a wild guess but noticed from dmesg you're loading agpart so is it an AGP display card? If so, could try the normal radeon.agpmode=X switch to see if it affects the situation. (X is a numeric value, iirc -1 implies it's out of operation altogether)


          • #35
            Wild guesses are welcome! that's really all I have at this point anyways... :P

            It's actually a PCIE card on a laptop (according to Xorg.log), not sure why agpgart loads - it also loads intel_agp as well... It's one of those things, it's just always been that way.

            How would I use that switch? As a kernel parameter?

            thanks for taking the time!


            • #36
              Originally posted by internalkernel View Post
              How would I use that switch? As a kernel parameter?
              I think that option is only for the kernel modesetting radeon module, if you aren't using that then instead you could try in the device section of your xorg.conf -

              Option "BusType" "PCIE"

              Edit: Although looking at your log it doesn't look like it would if you were really using AGP.

              Perhaps you could blacklist the agp modules, /etc/modprobe.conf is where to do it for me, I am not sure where with distros.
              Last edited by legume; 08-11-2009, 06:51 AM.


              • #37
                I tried blacklisting both agp modules, intel_agp and agpgart - along with the option "BusType" PCIE in xorg.conf - but no love. Radeon doesn't seem to load without agpgart, but I left intel_agp blacklisted... still no difference.

                I think I'm going to put an email into the Xorg mailing list and see if anyone has seen this behavior before. Xorg is the main issue here, what's causing the problem with Xorg is still unknown... but at least they may point me in the right direction.