No announcement yet.

Can't get out of VESA...

  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Thanks. Looking at it now.

    BTW I expect the message was actually that XAA *Render* was not supported (ie a specific function within XAA) -- XAA itself should be supported just fine, not the Render commands.


    • #22
      Hmmm. No obvious problems there, everything looks fine.

      Maybe try XAA and see if that helps.

      Looks like you are running a non-standard kernel; did you rebuild/update the kernel at some point ?


      • #23
        Originally posted by bridgman View Post
        Thanks. Looking at it now.

        BTW I expect the message was actually that XAA *Render* was not supported (ie a specific function within XAA) -- XAA itself should be supported just fine, not the Render commands.
        On that you are correct... but Xorg still locks up.

        (II) RADEON(0): XAA Render acceleration unsupported on Radeon 9500/9700 and newer. Please use EXA instead.

        In regards to the kernel - it's the kernel out of TuxOnIce ppa. It's the stock Ubuntu kernel with modules for hibernating through TuxOnIce.


        • #24
          OK... are you running some kind of non-standard kernel ? If so when did you change it relative to when you started having problems ? I was under the impression you were running vanilla Jaunty...


          • #25
            I've always used TuxOnIce kernels with this computer, with all my boxes actually.

            But, for the purposes of this experiment I'd be happy to boot into the previous kernel - 2.6.28-11 - and still the same issue.

            I saw no issues with xorg log either... which is another reason this is so baffling for me.


            • #26
              Isn't Jaunty 2.6.28-13 ?

              Can you just walk me through the sequence of events again when you re-installed Jaunty ? I had been under the impression this was vanilla Jaunty, ie nothing changed. Was anything else changed from stock ?


              • #27
                Most recent vanilla Jaunty is - from Jaunty Proposed and currently the one I will be booting into from now on. I have grub set to the TuxOnIce patched kernel for hibernation support.

                The first time I ever installed Jaunty on this laptop, everything "just worked". It was a first for my ATI card, desktop effects and all that was working fine. I've reinstalled at least twice since then for various reasons and never had a problem with the video.

                Replaced this laptop with a smaller one for traveling, and left the problem child at home... it had been used by friends, wife, and finally the kids. They wanted to play a certain game at one point, which really was not functional with the Open Source Radeon driver. So, I went and found the latest ATI (9.6) - it had been a while since I had messed with installing it... Didn't read anything really - I know, I'm still kicking myself for it...

                Got a memory cannot be allocated error when the fglrx module went to insert... so I removed it, dpkg --purge, killed /usr/share/ati, replaced my backed up xorg.conf and rebooted. That was when this problem cropped up. After about an hour and a half of trying to figure out WTF, I decided to wipe the system... I always have a solid backup, so it never takes more than 30 minutes...

                But... no love and here we are... dealing with the same issue. This issue comes up with livecd's as well - which makes me start to think it's a hardware problem...

                I've tried rolling back to Intrepid with Catalyst 9.3, upgrading to xorg-edgers, I even rolled back to Hardy... which is where I had the most luck. I'm about to install Windows just to see what the hell happens. I just can bear the thought...

                The process I go through after an install, is just to update sources.list with a few ppa's (none that affect Xorg TuxOnIce is the only one with a flavored kernel), uncomment proposed and backports, etc. Upgrade... Replace a few config files in /etc from my back up - ssh, nfs, stuff like that...

                thanks for the help... Whenever you want to call it a night feel free to do so...
                Last edited by internalkernel; 08-08-2009, 09:07 PM.


                • #28
                  Here's my problem. I know the drivers usually work with everything stock (ie download 9.04, install, run). I don't know how well everything works on a non-standard system, and nothing in the stack is sufficiently verbose to effectively debug a mystery problem.

                  Normally what we do in the case of mystery problems is go back to a known good configuration, which is "totally completely and unequivocally stock" 9.04 in your case. No PPAs, no kernels, no nothing. Not Jaunty Proposed. Nothing uncommented. No different config files.

                  Wipe, install, boot, see what happens and paste logs if it doesn't work the way you expect. Get it working and *then* customize.

                  Anything else is guessing, and I think we're running out of guesses
                  Last edited by bridgman; 08-08-2009, 09:22 PM.


                  • #29
                    I absolutely and totally agree... and that's just what I've done when I boot into the LiveCd in safe mode, Alt+F1 over to console, rmmod video and output. Edit xorg.conf and replace "vesa" with "radeon", insmod radeon and restart X - and the machine locks up tight... I mean the livecd is about as stock as you can get... unless I'm missing something here - that should be it, correct? And since we've started this thread, I've tried adding the "NoAccel" option to the xorg.conf and it will work under those circumstances...

                    I'm starting to think this a hardware issue...

                    Interestingly enough, it will also work with the "DRI" option set to False. Seems to be the culprit... just have no idea what to do about it.


                    • #30
                      No. Not liveCD. Not mmod video and edit config. Wipe, install, observe.

                      LiveCD is probably fine but I don't know that

                      Disabling DRI turns off most of the acceleration. It may turn off all acceleration with radeon, I forget. Does "man radeon" say anything about it ?