No announcement yet.

Radeon HD 4650 AGP

  • Filter
  • Time
  • Show
Clear All
new posts

  • Radeon HD 4650 AGP

    Hi, I've just bought a Gigabyte Radeon HD 4650 AGP as my previous AGP card died & this card looked pretty good. I've managed to get it working with the Gigabyte drivers in Windows & I've managed to get into X in Debian Lenny after 'dexconfig' created a rather vanilla xorg.conf & now i can get to the desktop (I don't know what driver its actually using). I was wrestling with trying to get either the non-free repo Lenny ATI drivers installed or the 9.7 Catalyst ones from AMD's website, but so far no success.

    The furthest I got was point 6 on this guide:

    But I encountered an error as follows when modprobing the fglrx module:

    Error inserting fglrx (/lib/modules/2.6.26-2-686-bigmem/nonfree/fglrx/fglrx.ko) : Cannot allocate memory.

    My system is an Athlon X2 4200+, MSI Neo2 Platinum mobo, 4Gb Ram, dual-boot with WinXP.

    I've found that my carg is somewhat odd in that its AGP & I don't think the drivers from AMD's website work for Windows even, hence I'm sticking to the Gigabyte-suppied ones for now. Is the 4650 AGP an absolute no-go in Linux at this time, or is Linux not so concerned with the socket-type? Any ideas?


  • #2
    I haven't really got a clue what causes that error, it may be your card isn't supported or it may be some other reason.

    There may be some extra info in /usr/share/ati/fglrx-install.log.

    I have an AGP HD3850 and with my mobo, it won't work properly with fglrx or the OSS drivers unless I set the AGP Aperture size in the bios to 256.

    3D support is coming along with the OSS drivers and your card should already get accelerated 2D and xv. If by chance it is not supported, then someone can just add the pcid

    If you ever really need to try different drivers in windows, then try the drivers here (I know they don't list 4xxx, but they may work, if not now, in the future).


    • #3
      Someone knows any solution? I have tried with fglrx and I obtain black screen when GDM starts.
      Them, I have tried with radeonhd and I obtain:
      (EE) No devices detected.

      Fatal server error:
      no screens found
      And now I use with radeon driver, althought glxinfo says "direct rendering: Yes", glxgears says abot 100 fps

      Debian testing
      Linux 2.6.30-2-amd64


      • #4
        Biker3, can you post some more info, eg what kind of GPU etc ?


        • #5
          Originally posted by bridgman View Post
          Biker3, can you post some more info, eg what kind of GPU etc ?
          Of course

          GPU: GV-R465D2-1GI (Gigabyte HD 4650 AGP 1GB GDDR2)
          Kernel: 2.6.30-2-amd64 #1 SMP Fri Sep 25 22:16:56 UTC 2009 x86_64 GNU/Linux
          Distro: Debian testing
          xserver-xorg-core (2:1.6.5-1)
          xserver-xorg-video-radeon (1:6.12.3-1)
          xserver-xorg-video-radeonhd (1.2.5-1)

          (I did not know where else to upload small files)
          Xorg.0.log for fglrx I haven't because when I try this driver I obtain at start GDM black screen and keyboard not respond, only at Alt+SysReq+REISUB

          And these files have these errors and warnings:
          - for radeon:
          (EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM
          (EE) RADEON(0): Acceleration initialization failed
          (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
          (WW) RADEON(0): Direct rendering disabled
          (WW) RADEON(0): Option "VendorName" is not used
          (WW) RADEON(0): Option "ModelName" is not used

          - for radeonhd:
          (EE) No devices detected.
          (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.

          With fglrx I have tried:
          aticonfig --acpi-services=off
          and put in grub "noput", but the problem with black screen persists.


          • #6
            Hi again, I've just given the Catalyst drivers another shot & managed to get them to work, well partially at least. I'm running on a Debian Lenny 5.0.3 installation & followed the following:

            Download latest ATI driver package, e.g.

            $ su
            $ aptitude install linux-source linux-headers-2.6-686 module-assistant
            $ sh

            Follow the instructions, if any problems do the following:

            m-a update
            m-a prepare
            m-a a-i fglrx

            I get some error messages about the last one but I've not got it noted down at the moment.

            Then re-run;
            $ sh

            I get some error messages at the end but it doesn't read as being very important & again I've not got it noted down at the moment, sorry.

            This makes the KDE OpenGL screensavers work properly & I was even surprised as I could use the Live For Speed skinning program via WINE. Hence, fglrx was working so far so good & even the control centre was rather nice.

            My problem now is that Kaffeine won't work at this point without tinkering a bit further (I use it for watching TV via my DVB-T card). I get a green-effect on the lower half of the video image & it then hard crashes my system.

            After further searching I found that there might be an issue between fglrx & the 'xv' (XVideo) playback engine XINE was using. I tried all the various engines available in Kaffeine within the 'xine Engine Parameters' menu & changed it in the Beginners area from auto (it was defaulting to the 'xv' engine), to xshm. This works fine but the image quality looks the same as when I wasn't using the fglrx drive, that is to say fairly poor; colour graduation is not smooth & there are sharp bits where it is not resizing the image very well. It is passable but I know it should be better.

            I think this is a general issue between fglrx & xv rather than the two errors I encountered during installation as neither read as being show-stoppers to the process. Does anyone know if this is resolvable?

            Last edited by mr_marmalade; 01-27-2010, 03:46 PM.


            • #7
              If you combine the ati installer with m-a then you get a completely unmanageable system. Complete crap what your write.


              • #8
                Thanks for the quick response. I was just following some other online guide I had found. I'll step back from that bit & see what else I can do & try to give better details if I have any further problems. Thanks for the constructive advice though.

                I'll try to refrain from doing "complete crap what your write" in future too, with regards to the method I used.


                • #9

                  Clean install of Lenny 5.0.3 on spare drive, aptitude updated & upgraded etc. got few more packages as follows;
                  $ aptitude install build-essential linux-headers-2.6-686 kaffeine

                  Downloaded latest ATi Catalyst linux driver, released only today!
                  $ sh ./
                  It ran without any error messages.
                  $ aticonfig --initial

                  This method is indeed simpler, therefore better. Unfortunately the problem I described, where the lower-half of the screen in Kaffeiene is green & garbled, still occurs exactly the same as before. The same interim workaround of changing the Xine engine from XV to XSHM still gets round it, but if anyone knows a better way I'd be greatful.



                  • #10
                    That's the basic variant to install, which breaks on every dist-upgrade with mesa drivers (just like nvidia binary installer) With lenny you don't get dkms support normally (until you install it before). Basically you do not need to reboot all the time. I currently work on directly supporting 10-1 driver with my script. The interesting thing is that it works already when i use the integrated (in my script of course) packaging script update feature (like i mentioned before -uv10-1 where -u stands for update). It looks like ATI just wants that i spend lots of time just for fixing errors they could have avoided VERY easy. I have also scripts to modifiy ati run installers, even I could fix that directly - without rebuilding all from scratch.


                    As fglrx tends to crash on X shutdown you may want to use extra -z option and do a reboot manually if you change from another fglrx driver. That's somehow often also the case with U and oss driver, with Kanotix in live mode it usually works.
                    Last edited by Kano; 01-27-2010, 08:45 PM.