Announcement

Collapse
No announcement yet.

ATI HD4870 and Catalyst 9.6 & 9.7 flickering

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • nizce
    started a topic ATI HD4870 and Catalyst 9.6 & 9.7 flickering

    ATI HD4870 and Catalyst 9.6 & 9.7 flickering

    Hi,

    I have read so many threads about people having problem with their ATI cards.
    But i haven't found any answer to my problem:

    I just bought a ATI HD4870. I've installed the new Catalyst 9.7 from ATI (also tried the proprietary one).
    But my problem is that when i start for example Xbox Media Center, a game or just try to bring up the preferences for my screen it starts to flicker and while it flickers the computer gets terribly slow.
    I don't have this problem when I'm watching movies with VLC or Mplayer(though it flickers while the program is starting) or starting any other "dekstop" programs.

    btw i've tried to disable all effects in compiz but it makes no difference, have even tried Metacity with the same result.


    Does any one else have this problem? or even better, a solution.


    /Daniel

  • nizce
    replied
    Thanks!

    I'll try that as soon as i get home from work!

    Leave a comment:


  • poofyyoda
    replied
    The problem is a broken randr implementation in fglrx.

    To disable randr, issue this command

    Code:
    aticonfig --set-pcs-str=DDX,EnableRandR12,FALSE

    http://www.phoronix.com/forums/showthread.php?t=17863
    Last edited by poofyyoda; 07-28-2009, 03:20 AM.

    Leave a comment:


  • MakotoTheKnight
    replied
    Looks like I'm in the same boat as you. I'm not exactly sure what's causing the problem, either. I went back to Catalyst 9.6 and it still does the same thing. Even with Metacity. Same exact symptoms.

    I'll scour around looking for a solution to this, but for now, I'm stumped.

    Leave a comment:

Working...
X