No announcement yet.

9.5 doesnt support hd4770

  • Filter
  • Time
  • Show
Clear All
new posts

  • 9.5 doesnt support hd4770

    I installed ati drivers 9.5 in my gentoo to be able to use my new HD4770. But when I run xorg -configure to reconfig X, I get an error. This is the log:

    X.Org X Server 1.5.3
    Release Date: 5 November 2008
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 2.6.25-gentoo-r7 x86_64 
    Current Operating System: Linux serenity 2.6.25-gentoo-r7 #1 PREEMPT Sat Oct 4 05:02:49 CDT 2008 x86_64
    Build Date: 29 March 2009  08:26:34PM
    	Before reporting problems, check
    	to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jun 19 09:16:26 2009
    (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
    (II) No APM support in BIOS or kernel
    (II) Loader magic: 0x3200
    (II) Module ABI versions:
    	X.Org ANSI C Emulation: 0.4
    	X.Org Video Driver: 4.1
    	X.Org XInput driver : 2.1
    	X.Org Server Extension : 1.1
    (II) Loader running on linux
    (--) using VT number 7
    (--) PCI:*([email protected]:0:0) ATI Technologies Inc unknown chipset (0x94b3) rev 0, Mem @ 0xd0000000/268435456, 0xcffe0000/65536, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
    List of video drivers:
    (II) LoadModule: "fglrx"
    (II) Loading /usr/lib64/xorg/modules/drivers//
    (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
    	compiled for, module version = 8.61.2
    	Module class: X.Org Video Driver
    (II) LoadModule: "radeon"
    (II) Loading /usr/lib64/xorg/modules/drivers//
    (II) Module radeon: vendor="X.Org Foundation"
    	compiled for 1.5.3, module version = 6.12.1
    	Module class: X.Org Video Driver
    	ABI class: X.Org Video Driver, version 4.1
    (II) LoadModule: "ati"
    (II) Loading /usr/lib64/xorg/modules/drivers//
    (II) Module ati: vendor="X.Org Foundation"
    	compiled for 1.5.3, module version = 6.12.1
    	Module class: X.Org Video Driver
    	ABI class: X.Org Video Driver, version 4.1
    (II) System resource ranges:
    	[0] -1	0	0xffffffff - 0xffffffff (0x1) MX[B]
    	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
    	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
    	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
    	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
    	[5] -1	0	0x00000000 - 0x00000000 (0x1) IX[B]
    (II) Primary Device is: PCI [email protected]:00:0
    (WW) Falling back to old probe method for fglrx
    (II) ATI Proprietary Linux Driver Version Identifier:8.61.2
    (II) ATI Proprietary Linux Driver Release Identifier: 8.612                                
    (II) ATI Proprietary Linux Driver Build Date: Apr 28 2009 21:45:06
    (II) Loading PCS database from /etc/ati/amdpcsdb
    (WW) This ATI Proprietary Linux Driver does not guarantee support of video driver ABI higher than 2.0
    (WW) Video driver ABI version of the X server is 4.1
    (II) AMD ASIC control file status: R312 S1 B129 N128 T128
    (WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:0:1) found
    (**) ChipID override: 0x94B3
    (**) Chipset Supported AMD Graphics Processor (0x94B3) found
    0: Xorg(xorg_backtrace+0x26) [0x4d7f9e]
    1: Xorg(xf86SigHandler+0x39) [0x470171]
    2: /lib/ [0x7f1f867ce430]
    3: /usr/lib64/xorg/modules/drivers// [0x7f1f8622f26b]
    4: Xorg(xf86CallDriverProbe+0x1cc) [0x4606a3]
    5: Xorg(DoConfigure+0x1bd) [0x46ba0f]
    6: Xorg(InitOutput+0x652) [0x460ef5]
    7: Xorg(main+0x24e) [0x4304ca]
    8: /lib/ [0x7f1f867bbb74]
    9: Xorg [0x42fb09]
    Fatal server error:
    Caught signal 11.  Server aborting
    Any idea about wahts happening here? Perhaps the manufacturer (HIS) touched something?

  • #2
    rm -f /etc/X11/xorg.conf*
    touch /etc/X11/xorg.conf
    aticonfig --initial


    • #3
      That freezes the whole system. Also, I cant find any error message in the logs.


      • #4
        Was X running when you executed the commands ?


        • #5
          No. There is no way to execute X. Running startx freezes the system. Running Xorg -configure doesnt produces any config. Running with old config=freeze, running with aticonfig --initial=freeze.
          I reemerged xorg-server after emerging ati-drivers and nothing, always the same.


          • #6
            I be confused. Your reply to Kano indicated that the freezing happened *after* running the aticonfig command, so I assumed that X was working before that... which implied that you could have run aticonfig while X was running...

            Your first message indicated (if I read it correctly) that you have a problem running xorg-configure, which you don't need with fglrx AFAIK. I think I'm hearing that you didn't get past xorg-configure the first time and running X normally after aticonfig didn't work either ?

            When you say "running with aticonfig --initial=freeze" do you mean aticonfig freezes or X freezes after running aticonfig ?
            Last edited by bridgman; 06-20-2009, 01:43 PM.


            • #7
              Sorry, my mistake!


              • #8
                So is my understanding of the sequence correct ? Can you fill in some gaps ?

                - install gentoo (running with open source ati driver ? vesa ?)

                - install 9.5 (building packages, native installer, someone else packaged for you ?)

                - ran xorg-configure (manually ? automatically by the package ?)

                - xorg-configure failed, log in your first post (did you run aticonfig --initial before attempting to run xorg-configure ?)

                - ran the commands Kano recommended (did the system freeze when running the commands or only next time you started X ?)

                - re-emerged xorg and ati-drivers (what does ati-drivers get you, fglrx or open source ?)

                - still hanging on x start


                • #9
                  Lets see, I had a previous ATI card (hd2600) working with 8.x (when installed gentoo) and later with 9.2. got a new one, waited until an ebuild for 9.5 was available and installed it (it is recommended to avoid manual install of ati drivers under Gento, better use ebuilds and emerge system). First tried Xorg -configure, which didnt worked (I did it because the old configuration didnt worked). Then tried an empty xorg.conf and aticonfig, neither worked this.
                  Usually an ati-drivers ebuild installs fglrx, then you run eselect opengl set ati to make xorg use the fglrx driver.
                  Im really confused here, when I run startx, fglrx seems to properly identify the card, but for some reason, something crashes.


                  • #10
                    Yeah, so that probably means the driver is fine in terms of supporting the GPU but isn't getting along with something in your system.

                    Guessing here, but a number of "crash at startup" problems have been resolved by using aticonfig to disable acpi-services. The usage might be covered in aticonfig --help, or I can try to find the right syntax.