No announcement yet.

4850 blank screen, no input

  • Filter
  • Time
  • Show
Clear All
new posts

  • 4850 blank screen, no input

    I've been having a very weird problem recently.
    I have a 4850 and it works with all operating systems. (XP/Win7/Ubuntu)
    But recently when i disconnected (accidentally) one of my monitors in dual screen mode (in ubuntu). That particular monitor does not get any input on startup in ubuntu no matter what i try. (i've even reinstalled the OS a few times)
    When I mean no input, I mean the monitor doesn't get any signal. So basically.

    - The monitor doesn't get input when ubuntu loads the GDM (But can be sorted by pressing CTRL+ALT+F1 and then CTRL+ALT+F7 again, then everything works perfect! Until a GDM restart/reboot)
    - The monitor receives input in all other operating systems apart from ubuntu.
    - Output works with another monitor
    - Monitor definitely works!
    - Seems to be doing the same thing regardless of Ubuntu version or catalyst version. (I've reinstalled everything 3 times, with different ubuntu versions paired with different catalyst versions.

    Any help would be greatly appreciated! =D
    Maybe i should draw a picture if the above is too confusing

  • #2
    When you do an initial install of Ubuntu Jaunty / 9.04, after installing Ubuntu but before installing fglrx, does that monitor work with the open source drivers ?


    • #3
      Yes it does,
      Only when i install the fglrx drivers does the monitor get no output on startup.
      I have even tried it with just the "no input" monitor connected, when installing ubuntu and it still happens! Its as if the monitor is blacklisted or something
      I have also tried switching the cables around and the sockets around too, to no avail.


      • #4
        OK, try deleting the amdpcsdb file - it's in /etc or /etc/ati or some such. There will be a backup file as well, don't delete that one.