No announcement yet.

Multiseat getting closer.

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    yes i remember your posts i referred to them a couple of times. Yeah i think the DPMS issue you had is solved, I had exact same problem. Maybe 9.5 fixed it(I'm not sure but thats my guess). but monitors will, turn off, not just blank. Yeah of course, I haven't gotten suspend, resume to work yet. I've been concentrating on this shutdown problem.

    I think all these issues really get better once they get consolekit up and running with multiseat. Anyone good ideas with sound in multiseat. I've seen some stuff on pulseaudio. It would be nice if could throw the usb sound devices in xorg.conf as another device. Maybe you can but i haven't seen anything on that.


    • #12
      I've been meaning to try this out (

      The MDM (Multiseat Display Manager) WIKI seems like it has some good resources regarding some of these issues.

      For me, I eventually ended up removing PulseAudio and have been using standard ALSA. I don't have it running perfectly, as very occasionally other users will login and my speakers will start playing their sounds.

      If you do try the solution I posted, please let me know how well it works. I just haven't had the time / patience to mess around with it right now.


      • #13
        Well, I got the sound working. I actually used kind of a derivation of the method cmorrow pointed to. I used pulseaudio with user sessions, and writing a short script that launches pulseaudio with different (eg. Doing this you have to modify . Comment out all the restore default devices options ( at least I did) And then add one line to set the default sink as the one you want per seat. This allows hotseating. The sound card will be now tied to the seat instead of the user. I talked to some of the pulseaudio developers. And they recommended that I should fix console kit. And not do this hackery with there precious. They also suggested if i wanted a temporary fix I should make some udev rules and disable something with hal. But it is all working perfect for me so.