Announcement

Collapse
No announcement yet.

ATI 9200 + FC6+ Kernel 2.6.20-1.2925.fc6 problem Please HELP

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    The open-source driver is the one that comes default in FC6.

    If you want to use Beryl, the drivers that come installed by default will work.

    More clarifications: http://www.michaellarabel.com/?k=blog&i=109
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #12
      First, I want to thank Michael for his work on the patches/scripts:

      THANK YOU.

      Second, I am in the same boat with an older chip (mobility radeon 9000) in a Dell laptop and I can only use the 8.28.08 drivers from ATI. I need reasonable OpenGL performance, so the opensource radeon driver doesn't seem to be a viable option for me.

      The recent FC6 yum update brought me kernel 2.6.20, but I was unable to regenerate the fglrx rpms since the firegl code won't compile anymore. I rolled back to 2.6.19 for the time being. Have I reached the end of the line with this laptop?

      Comment


      • #13
        You have not reached the end of the road. By following the steps I previously mentioned, you should be able to get any R200 card up and running with the 2.6.20 kernel.

        I can update the legacy driver later this month once the new driver is publicly out. I have already written the patches for 8.35 so the legacy script can be released on the same day as the new official driver this month. If I have the time this weekend, I can backport the changes to 8.34 so the patch will work and then push it out as the new firegl_public code.
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #14
          Success!

          I got the 2.6.20 patch from http://www.phoronix.net/forums/showthread.php?t=1033

          I hacked the original script you wrote from http://www.phoronix.net/forums/showthread.php?t=342 so that it applied the patch after the cp build_mod

          and I got fresh (old 8.28) rpms that installed under 2.6.20. Interestingly, a benchmark OpenGL program I wrote gives me 30% higher FPS than it did under 2.6.19. How about that for an unexpected bonus.

          Thanks, Michael!

          P.S. The last part of the patch didn't take, I couldn't even find the INIT_WORK call that it is patching in the code anywhere...

          Comment


          • #15
            Your welcome.

            Can you post some more detailed instructions so others with the problem can see?

            The INIT_WORK was introduced recently into the firegl_public. If you don't see it, no problem.
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #16
              Hey Michael,

              Great article, it answered many of my questions. I guess my big mistake was installing the kmod-fglrx driver. Whenever I installed it, x would not start, So I guess my question now is when do you use that driver? Are there any special circumstances/cards/applications/etc when it is need?

              Thanks everyone,

              Comment


              • #17
                You use the R200 legacy driver mainly when you want to use TV-out to your TV or other monitor. Or want a bit better gaming performance. Or you don't care about the desktop effects.
                Michael Larabel
                http://www.michaellarabel.com/

                Comment


                • #18
                  Or want a bit better gaming performance
                  If we call twice de performance a little bit better.

                  Comment


                  • #19
                    Still the same..

                    I am trying to install gl driver for 9200SE on FC6/2.6.20 for several days already. Still the same result..

                    Is it really a fact that v.8.35 will not be working with 9200?

                    So, the only hope is to build 8.28, as I may understand.
                    But I am unable to do it. Even Michael's "legacy" pack gives me an error with many "+++".

                    Kmod-fglrx won't work. 8.35 ATI driver builds great, but won't work.
                    Ohh...nothing works except pre-installed FC6 driver. Total disaster.

                    If anyone can give an advice - please, give.
                    Last edited by kirsche; 03-29-2007, 04:28 AM.

                    Comment


                    • #20
                      Originally posted by kirsche View Post
                      I am trying to install gl driver for 9200SE on FC6/2.6.20 for several days already. Still the same result..

                      Is it really a fact that v.8.35 will not be working with 9200?

                      So, the only hope is to build 8.28, as I may understand.
                      But I am unable to do it. Even Michael's "legacy" pack gives me an error with many "+++".

                      Kmod-fglrx won't work. 8.35 ATI driver builds great, but won't work.
                      Ohh...nothing works except pre-installed FC6 driver. Total disaster.

                      If anyone can give an advice - please, give.

                      The 9200 will not work with any driver past the 8.28.8 release.

                      I'll update the legacy scripts today -- check back on the forums in a few hours and then run the scripts and it should work for 2.6.20.
                      Michael Larabel
                      http://www.michaellarabel.com/

                      Comment

                      Working...
                      X