No announcement yet.

Radeon HD 3650 in Toshiba Satellite Notebook produces black screen under Ubuntu 9.04

  • Filter
  • Time
  • Show
Clear All
new posts

  • Radeon HD 3650 in Toshiba Satellite Notebook produces black screen under Ubuntu 9.04

    Hello phoronix-forum,

    I recently installed Ubuntu on my Toshiba Satellite A350-12D and neither the proprietary flgrx-driver nor the open source "ati" driver works.

    I am currently using "vesa" with a resolution of 1024x768.

    I tried to install flgrx via envyng and vie the ati-installer in the newest catalyst 9.4 package, then I removed everything and installed the xorg-xserver-video-radeon package.

    When I restart the computer, the screen turns black as soon as X starts. When I use the open source driver, a console-login-screen flashes up all 20 seconds and then it goes back to black.

    I'm not sure, if the notebook does responde to any keystroke, but if I hit the power button, it shuts down normally.

    So, here are my Xorg.0.log files. First is fglrx, second "ati"-flag in xorg.conf.

    Anyone with similar problems or a solution?

    Thank you very much, kw
    Last edited by kwandtum; 04-28-2009, 02:25 PM.

  • #2
    There seems to be a general consensus that envy and the fglrx drivers don't mix very well.

    When you do a fresh install of Ubuntu (I assume you're using 9.04 ?) I believe it installs the radeon drivers by default. Is this what happened for you, and if so how did they work ?

    Neither of the rafb links are working for me.


    • #3
      Good evening

      Yeah, strange, rafb seems to be down, I changed the links to

      You are right, I am using Ubuntu 9.04. When I try to install it just by booting from CD-ROM, I get a black screen. I had to use grafics-save mode to access the installation manager. At the moment, I am using xorg.conf.failsafe as xorg.conf with a "vesa" driver and a resolution of 1024x768, which does not look good on my 1366x768 display.

      The first thing I tried after clean installation was substituting Driver "vesa" with Driver "ati" in my xorg.conf. Then I tried to install the proprietary ati driver via "jockey-kde", then I tried Catalyst 9.4 from ati's homepage, then I tried envy.

      Of course, I removed everything of the drivers in between these tries. Xorg.0.log had similar errors during all of these tries.

      Ok, I hope, there is nothing I forgot



      • #4
        The log from the "ati" driver looks ok at first glance (other than the screen being black, of course). Maybe someone else will see something I missed.

        There is an "invalid output device for dac detection" message but don't think that should affect your laptop panel.

        EDIT - forget the DPMS message I mentioned earlier... I did some searching and it looks like a message which normally appears.
        Last edited by bridgman; 04-28-2009, 03:28 PM.


        • #5

          in line 389 of the "ati"-log, there is a warning.
          # (WW) RADEON(0): LVDS Info:
          # XRes: 1366, YRes: 768, DotClock: 69860
          # HBlank: 108, HOverPlus: 48, HSyncWidth: 32
          # VBlank: 22, VOverPlus: 2, VSyncWidth: 5
          I do not understand what that is going to tell me. It seems to me, the ati driver recognizes the right resolution of my screen. Which is a good thing to start with. Vesa does not recognize the right resolution.

          fglrx has a lot more errors.
          Line 219:
          (EE) fglrx(0): Unknown EDID version 0
          and Line 262:
          # (EE) fglrx(0): [pcie] Failed to gather memory of size 0Kb for PCIe. Error (-1)
          These seem important to me. DRI also fails to start, but I do not need 3D that desperately. All I need is a resolution of 1366x768 and clear, unstretched fonts to please the eye.
          Google tells me, there are some more people with the last error, but I did not find anyone with a solution yet.

          greetz, kw


          • #6
            Well, it seems to me, I am not the only one with these problems:


            or german ubuntu forum:



            • #7
              I'm using a hp elitebook with 3650 (1680x1050 screen resolution).

              I did have the black screen after installing the repository version of fglrx (but none of the other problems you're having).
              What worked was booting in recovery mode, root shell and running;
              aticonfig --initial
              aticonfig --acpi-services=off

              I then upgraded to 9.4 from ati's site and it still works, guess it kept that option.


              • #8
                Hi apocalypse,

                do you still have your Xorg.0.log files from the time you had a black screen? It would be nice to compare them with mine, just to see, if you had the same errors before I try your suggestion.
                And I have to find out, what this acpi-service is...


                • #9
                  There are news!

                  It seems, the driver does not understand that it cannot have my full memory of 4GB:

                  (II) RADEON(0): Detected total video RAM=4194303K, accessible=524288K (PCI BAR=524288K)

                  this is from my Xorg.0.log.ati. This problem can be fixed by a workaround, if you decrease your Ram to 2GB or less. I think, fglrx has the same problem.

                  There are various other users with this problem:


                  Even after a BIOS upgrade, I am not able to set the amount of Ram for my videocard.

                  Any suggestions?


                  • #10
                    Something seems wrong there. That message is talking about video ram, not system ram, and it's highly unlikely that you have 4GB of video ram. AFAIK you have 512M of video RAM; that information should come from the video BIOS, not sure why the system thinks you have more.

                    This is an Intel CPU, right - ie there is no separate ATI integrated graphics involved ? Is there an Intel IGP on the board maybe ?

                    EDIT - OK, looks like your original xorg log has the same problem :

                    (II) RADEON(0): Detected total video RAM=4194303K, accessible=524288K (PCI BAR=524288K)
                    I don't know if the devs are aware of this one, will ask today.
                    Last edited by bridgman; 04-30-2009, 06:57 AM.