Announcement

Collapse
No announcement yet.

ATI x1550, dual monitor setup?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ATI x1550, dual monitor setup?

    You'd think this would be easier, but apparently this is a recurring problem and I've already spent 3 hours trying various options in xorg.conf to no avail. I can't really afford to continue experimenting since this is my work PC and I need to get back to development.

    Running Ubuntu 8.04. I'm only slightly experienced in Linux, and I'm not sure how much of this info is useful, so I'll just throw it ALL out there.

    Hardware:
    ATI Raden x1550 (legacy PCI)
    Dell 2007WFP (native 1680x1050)
    Dell E198WFP (native 1440x900)

    Desired setup:
    19" on the right, rotation 0
    20" on the left, rotation 90 CCW

    Using the latest Catalyst drivers, and the checkbox is enabled in the Proprietary Drivers section.

    fglrxinfo gives:
    Code:
    display: :0.0  screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: Radeon X1300 / X1550 Series 
    OpenGL version string: 2.1.8494 Release
    I've also read that pair mode might be the way to go, but "aticonfig --list-pairmode" says:
    Code:
    Error: pair mode is not supported when RandR 1.2 is enabled!
    Running "xrandr" gives:
    Code:
    Screen 0: minimum 320 x 200, current 1440 x 900, maximum 1680 x 1050
    DFP1 disconnected (normal left inverted right x axis y axis)
    DFP2 disconnected (normal left inverted right x axis y axis)
    CRT1 connected 1440x900+0+0 (normal left inverted right x axis y axis) 408mm x 255mm
       1440x900       59.9*+
       1280x1024      75.0     60.0  
       1280x960       60.0  
       1152x864       75.0     60.0  
       1280x768       59.9  
       1280x720       60.0  
       1024x768       75.0     70.1     60.0  
       800x600        72.2     75.0     70.0     60.3     56.2  
       720x480        60.0  
       640x480        75.0     72.8     60.0  
       640x432        60.0  
       640x400        75.1     59.9  
       512x384        60.0     74.9  
       400x300        75.0     60.7  
       320x240        75.6     60.0  
       320x200        75.5     60.1  
    CRT2 connected 1440x900+0+0 (normal left inverted right x axis y axis) 434mm x 270mm
       1680x1050      60.0 +
       1400x1050      60.0  
       1280x1024      75.0     60.0  
       1440x900       59.9* 
       1280x960       60.0  
       1152x864       75.0     60.0  
       1280x768       59.9  
       1280x720       60.0  
       1024x768       75.0     60.0  
       800x600        75.0     60.3  
       720x480        60.0  
       640x480        75.0     60.0  
       640x432        60.0  
       640x400        75.1     59.9  
       512x384        60.0     74.9  
       400x300        75.0     60.7  
       320x240        75.6     60.0  
       320x200        75.5     60.1  
    TV disconnected (normal left inverted right x axis y axis)
    COMPONENT_VIDEO disconnected (normal left inverted right x axis y axis)
    And lastly, my xorg.conf file:

    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
    	Screen	0 	"aticonfig-Screen[0]-0" 0 0
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
    	Load		"glx"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Monitor"
    	Identifier	"aticonfig-Monitor[0]-0"
    	Option		"VendorName"	"ATI Proprietary Driver"
    	Option		"ModelName"	"Generic Autodetecting Monitor"
    	Option		"DPMS"	"true"
    EndSection
    
    Section "Device"
    	Identifier	"aticonfig-Device[0]-0"
    	Driver		"fglrx"
    	Busid		"PCI:3:0:0"
    	Option		"VideoOverlay"	"on"
    	Option		"OpenGLOverlay"	"off"
    
    
    	# --- The following was added for dual-head support:
    	Option		"DesktopSetup"	"horizontal,reverse"	# Enable Big Desktop
    	Option		"PairMode"	"1440x900+1680x1050"	# Pair mode resolutions
    	Option		"DesktopSetup"	"LCD,LCD"		# Types of monitors connected LVDS = LCD, CRT, AUTO
    	Option		"HSync2"	"65"			# This sets the horizontal sync for the secondary display. 
    	Option		"VRefresh2"	"60"			#This sets the refresh rate of the secondary display.
    	Option		"EnablePrivateBackZ"	"yes"		#Enable 3d support
    #	Option		"Mode2"		"1680x1050"		# Resolution for second monitor
    EndSection
    
    Section "Screen"
    	Identifier	"aticonfig-Screen[0]-0"
    	Device		"aticonfig-Device[0]-0"
    	Monitor		"aticonfig-Monitor[0]-0"
    	Defaultdepth	24
    	SubSection "Display"
    		Viewport	0	0
    		Depth	24
    		Virtual		1680	1050
    	EndSubSection
    EndSection
    With all this, my right 19" shows up fine, but the left 20" stays black. These monitors are both connected to a KVM (using VGA if that makes a difference), and the dual monitor works as expected on my Windows box. I'm at a loss. Any help is appreciated!
Working...
X