No announcement yet.

Playing around with fglrx -> broken xserver

  • Filter
  • Time
  • Show
Clear All
new posts

  • Playing around with fglrx -> broken xserver


    In the trying of finding the perfect fglrx for my use, I have tried several fglrx drivers. But last time I removed the fglrx and installed a new, my xserver broke for some reason. I am running ubuntu/intrepid and have always used the --buildpkg command for the fglrx installer, so it should be clean deb only installations I have made. But now, with the newly installed fglrx it cannot boot into X anymore.

    This is from my Xorg.0.log:
    (II) fglrx(0): Creating default Display subsection in Screen section
    	"Default Screen" for depth/fbbpp 8/8
    (EE) fglrx(0): Given depth (8) is not supported by fglrx driver
    (EE) fglrx(0): PreInitVisual failed
    (EE) fglrx(0): PreInit failed
    (II) fglrx(0): === [atiddxPreInit] === end
    SetVBEMode failed
    (II) UnloadModule: "fglrx"
    (II) UnloadModule: "vgahw"
    (II) Unloading /usr/lib/xorg/modules//
    (EE) Screen(s) found, but none have a usable configuration.
    Fatal server error:
    no screens found
    Thiese are the last lines from the log file. Right now I am using the plain old vesa driver. This is what I have been doing to fix my problem without luck:

    1) Purged every fglrx related package and reinstalled it again.
    2) Reinstalled every Xorg, dri and mesa related packages.
    3) Removed /etc/ati before installing fglrx again.

    Neither of thiese things works. The errors from the Xorg.0.log started when I uninstalled fglrx 9.4 and tried to install 9.1 again. (I know it was an alpha and shouldn't have installed it), but that I take the fully responsibility for. Actually I liked 9.4, but some minor things with some games and my hdmi wouldn't work correctly, so back to 9.1.

    Anybody got the slightest idea what have happened and how I fix this? I could force X running in 24 bit, but I don't wan't to specify any unnecessary in my xorg.conf, and it has to be fixable without. 9.1 worked fine before.
    Last edited by tball; 03-14-2009, 10:20 AM.

  • #2
    Hmm worked doing a DefaultDepth 24, but that just doesn't seem to be a nice workaround


    • #3
      But after 9.1 starts to work again, I have the same problem as before with 9.4 :|

      The world is all dark in QuakeWars and Savage 2. What could it be? Do they use sdl both? Nexuiz, cube etc works fine.