No announcement yet.

Rv670 + fglrx == fail fail fail

  • Filter
  • Time
  • Show
Clear All
new posts

  • Rv670 + fglrx == fail fail fail

    Hey Phoronix,
    Yea im the new hi all

    I have very very similar problems like many have in a few related threads, trying to get fglrx up and running with hw accel.

    Never got it working, all time "booting into black screen",
    X -configure with fglrx enabled really fails and give me a backtrack ( i havent noted but i can reproduce it if someone needs it)

    Got the famous sb600 Mainboard and following stuff

    SB600 ALiveXFire eSATA2
    AMD64 X2 6000+
    4GB RAM (mem=2048 wont help)
    ATI Technologies Inc RV670PRO [Radeon HD 3850] CardExpert Technology Device 0401

    full lspci output:

    The really funny and blaming part is really all components are from AMD / ATI AND THEY DONT EVEN GET WORKING DRIVERS FOR OUR WOUNDERFULl OPENSOURCE COMMUNITY ?!?! WTF (sorry capslock)

    No , really....I have spend my whole life to get it working, stuck 2-3 Month with that, i had NO success to get it proberly working w/ full hw accel.

    @ kizo
    he described this issue in his thread
    see this ahci 0000:00:12.0: controller can't do 64bit DMA, forcing 32bit
    your right, We definitely have some DMA issues but i think they are not the reason...
    I tried another board with that system too, dont remember the SB but it was a nforce board. It produced the same issues

    I tried Debian with many different kernel versions and Xorg configurations - No succes.

    Then i read here ati does test drivers more on ubuntu etc so i gave it a try.
    Ubuntu says at booting something about memory hole IOMMU stuff but i dont have option to disable that.

    Anyway same issus booting into black
    same X -configure fail w/ fglrx and backtrack

    i dont get it... i have absolutely no clue where to go further...
    Hope someone can get a little light into this one

    Im glad if i can help or test a little if someone has an idea about that - ill try it out

    im attching a few logs maybe theyr helpfull...
    That was on Ubuntu 8.10 w/ config described above

    xorg.log after "booting into blackscreen"

    so far

    keep the moon shining

  • #2
    Originally posted by Luna View Post
    keep the moon shining
    Das das so leuft tut mir so schrecklich leid!
    Hoffendlich kann man das irgentwie wieder gut machen.
    Ich hatte ?hnliche probleme 8.11,8.12,9,1 liefen bei mir total Amok.
    9.2 solltest du mit Kanos installskript zum laufen bekommen (ich mein nicht den orginal installer sondern kanos skript)
    aber das ist ne notl?sung.
    ab 9-3 und 9-4 sollte dieses Blackscreen debian problem gel?st sein.

    Bleib am Ball du schaftst das !
    Phantom circuit Sequence Reducer Dyslexia