No announcement yet.

Catalyst 9.2 Released, Still Fails To Deliver XvBA

  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by RealNC View Post
    Full of problems and bugs.
    I'm going to have to agree.

    XV playback may have improved, but wow.. I'm getting random freezes when X starts, random crashes when I restore applications in KDE, and all sorts of other random oddities. I've reinstalled the drivers twice, so I'm just not sure what's going on.


    • #32
      Finally! With this release, my ATI Mobility Radeon 9600 (M10) works again in Ubuntu with fglrx! Though, it seems that it requires manual screen configuration instead of using Xorg's automatic detection. Now I won't be bothered anymore until the PCSX2 guys clean up their segfaulting in their Linux sources... But at least ZeroGS doesn't complain anymore


      • #33
        So, the 780G has no improvements at all? Maybe AMD needs a class action suit to convince them to stop raping their customers. They have an implicit contract to get their hardware working properly. If they can't or won't do so, they should have to compensate all the customers that were provided the faulty graphics hardware, both for the hardware itself and the time wasted because of problems caused by their faulty drivers. If this means that they go bankrupt, then good riddance. Another company will eventuallyt take it's place in the market, likely nVidia after they've been given the right to manufacture x86 CPUs by Intel to keep up the x86 processor Duopoly.


        • #34
          Originally posted by rotarychainsaw View Post
          XV under compiz almost works now. The only problem is that video is sized for the whole window's size, not the window minus player controls.
          +1, I hope the devs are aware of it


          • #35
            Fails to deliver XvBA? Buddy, it fails to deliver regular old Xv, being all shaky. I don't think Xv can be fixed unless they rewrite it, so I guess the verdict is out. This is like Windows releases: some version in the future will be the fix.


            • #36
              For 64 bit lenny the kernel module builds ok, but fails to load:


              is missing.

              C'mon guys this kind of crap shouldn't be happening. The fix doesn't look too difficult, but we shouldn't need to hack the code.

              Fortunately the fix is quite trivial. For 64 bit edit arch/x86/kernel/tlb_64.c by adding "EXPORT_SYMBOL(flush_tlb_page);" (it is present in tlb_32.c so I'm guessing 32 bit systems aren't seeing this problem) right after the end of the flush_tlb_page function. Rebuild and install both kernel and fglrx module and voila, you're good to go.

              Now if 9.2 actually yields any meaningful improvements that remains to be seen.
              Last edited by nbi1; 02-21-2009, 04:23 AM.


              • #37
                Xv is still a disaster. OpenGL is marginally passable if the playback window isn't made too big.


                • #38
                  I managed to get it working:

                  - Ubuntu 8.04.2
                  - hybrid crossfire
                  - HD3450 and internal HD3200 (AMD 780G chipset)
                  - a monitor and my old analog TV connected to the HD3450


                  I had to disconnect the TV when installing the driver and setting up crossfire. When that ran properly, I connected the TV and it ran properly as well.

                  Whenever I tried to install with the TV connected, my TV became my main monitor and after trying to setup crossfire I got booted into a black screen.

                  I also don't dare to touch the Catalyst control center, because it seems that as soon I do that, I am booting into black screens again.

                  These kind of problems are already in the driver since version 8.9 (changing overscan options of the TV, cause booting into a black screen). When will it be fixed? I'm running a default Ubuntu 8.04.2 installation. I didn't compile any kernels myself or whatsoever...


                  • #39
                    I cannot build the driver on fresh Debian Lenny installation.

                    dpkg-shlibdeps: failure: couldn't find library needed by debian/fglrx-driver/usr/bin/fglrx_xgamma (its RPATH is '').
                    Note: libraries are not searched in other binary packages that do not have any shlibs or symbols file.
                    To help dpkg-shlibdeps find private libraries, you might need to set LD_LIBRARY_PATH.
                    dh_shlibdeps: command returned error code 512
                    make: *** [binary] Error 1
                    dpkg-buildpackage: failure: debian/rules binary gave error exit status 2
                    Removing temporary directory: fglrx-install.WNzDfC
                    Any hints?


                    • #40
                      Good release for me so far: Kaffeine (Xine backend) didn't yet crash the machine with Xv output for me. Let's see if this is pure luck or if this nasty and longstanding bug is finally fixed.