No announcement yet.

fglrx - final attempt to get it working (black screen freeze/crash)

  • Filter
  • Time
  • Show
Clear All
new posts

  • fglrx - final attempt to get it working (black screen freeze/crash)


    I've been using the open source radeon/radeonhd drivers for a long time, but I've recently done an upgrade and want to use fglrx again, mainly for 2 reasons:
    - I want my card to power down and stfu when it's not doing anything
    - I got my X3 a while a ago, and it's been gathering dust

    I've been having various problems with the fglrx drivers since the beginning though (most of the time, X would crash). Most recently, my system crashes with a black screen during X startup. It doesn't seem to be just a display corruption, as I cannot change VT, login & reboot by typing blindly (but Magic SysRq still works). fglrx does seem to initialize properly though, as my card immediately enters a lower power state and turns down its fans.

    Some logs and sysinfo from my last attempt:
    Kernel info messages
    Kernel warn messages
    uname -a:
    Linux ultrabeeper #2 SMP Tue Feb 10 13:58:35 EST 2009 i686 Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz i386 GNU/Linux
    Hardware: Intel x48-based motherboard & Asus EAH4870x2

    The system doesn't crash anymore if I disable DRI with "Option "DRI" "off"" in Xorg.conf, and I get a somewhat usable X server, but no 2d or 3d acceleration.

    I searched the forum for something similar, but couldn't find anything, so I apologies if a solution for this problem has already been posted on phoronix (but please give me a link ).

    Any help or suggestion for fixing this problem is appreciated.

    EDIT: the xorg.conf I pasted is my current one (as of this edit). In my last attempt, the Option "DRI" was commented out.
    Last edited by Xipeos; 02-11-2009, 07:12 PM.

  • #2
    Have you tried disabling composite? I also get a black screen when composite is enabled.


    • #3
      Originally posted by egon2003 View Post
      Have you tried disabling composite? I also get a black screen when composite is enabled.
      Yeah, I tried that and still had the problem.


      I noticed now that, contrary to my original post, I *can* actually reboot by typing blindly if I disable the login manager (SLiM - most likely init restarted the process before I could finish typing). It's obvious now that X crashes, but there's no crash log in Xorg.log (only in the the kernel warn messages). So it's just a display corruption, not a total system freeze (another indication is that my monitor stays on after the "crash" so it's still receiving signal).


      • #4
        I'm having the same problem with my system, 4870 X2 on Gentoo AMD64. It goes away if I use the 8.12 or older drivers, but with the 9.1, leaked 9.1 or leaked 9.2 drivers they all cause this problem.

        Turning DRI off fixes the freezing for me, but it just makes X fail and kick me back to my tty1. Which is an improvement at least, but I still can't get into X.


        • #5
          Also, an interesting dmesg from after I disabled DRI, which stopped it from locking my system...

          Looks like fglrx crashed and left a bunch of errors and bug info. bridgeman following this thread?


          • #6
            None of the leaked betas work for me either.

            I just tried the 8.12 driver and, to my huge surprise, it actually works. About two weeks ago, 8.12 caused a similar problem (but different error log), and I only changed the kernel in the meantime (same config though).


            • #7
              I've been trying to fix this for weeks. I think I'm done with Linux for now... and by 'for now' I mean until I find a buyer for my 4870 X2 and I can replace it with a GTX 295. I was hoping the new, more open source friendly AMD would be a little better off than this, but it doesn't seem like fglrx is any better than it used to be... and the OSS drivers don't support the nice compositing and 3d effects that I want.


              • #8
                Originally posted by Vash63 View Post
                and the OSS drivers don't support the nice compositing and 3d effects that I want.
                I actually get faster 2d compositing with radeon/radeonhd than with fglrx. Don't know about compiz though since I'm running fluxbox.

                A note for whoever needs this:
                aticonfig may complain about missing for some weird reason. The problem is actually that it can't find (it doesn't seem to respect To fix this:
                LD_PRELOAD=/usr/X11/lib/ aticonfig --odgt
                (or something similar depending on your lib dirs).


                • #9
                  I had problems with drivers later than 8.11. But after I installed 9.1 and ran aticonfig --initial -f everything worked fine.