No announcement yet.

Catalyst 9.1 is out

  • Filter
  • Time
  • Show
Clear All
new posts

  • #81
    9.1, so far, acts just like 8.12 (Ubuntu 8.10)

    --buildpkg Ubuntu/8.10

    aticonfig --initial


    I guess you could say GDM comes up, but nothing is clear. Its a very light color and I can only barely make out the input field, and everything else for that matter. I can still log in though by just blindingly putting in the username and password.

    On log in, barely anything comes up. There is a 2"x2" sq. where the mouse pointer is. Right click brings up nothing. There is also a 3x3" sq. on the bottom right.

    If I try to switch to a VT, the screen blinks (1 sec. intervals) various colors. Switching back, and the "desktop" screen is just as above.

    Is there something special I need to add? The xorg.conf is basically generated by "dpkg-reconfigure -phigh xserver-xorg" and then "aticonfig --initial".


    • #82
      I also have a lot of problems with ati and wine. I just tried to play fifa 09 and I get a lot of artefacts. See picture:


      • #83
        Does any one experience random black screens for a second or two every now and then? I am currently using drivers 8.12?

        Now I am waiting for 9.1 Ebuid for Gentoo and it would be nice to watch tearless movies.

        For all those which are experiencing hangs on log out this might help. It helped me a lot, hang ups on log out and console corruption have nearly disappeared

        Check if /var/lib/xdm/authdir/authfiles exists for your distribution (this is needed by atieventsd)
        ls -l /var/lib/xdm/authdir/authfiles

        Otherwise you can fix it by creating one
        sudo mkdir -p /var/lib/xdm/authdir
        sudo ln -s /var/run/xauth /var/lib/xdm/authdir/authfiles

        Check script execution bit I think it should be set for executing the script or am I wrong!?
        ls -l /etc/ati/

        You can fix it by setting excution bit
        chmod 755 /etc/ati/

        or instead of this it is also possible to simply kill hanged process showing up something as sh -c "/etc/ati/ ..." before Xorg restart :?

        Some people also say that it is not a bad idea to force restart X server on log out, so this depends on the DM you are using

        for KDM ( I use kdm-4.1.4 before I've always used GDM with ATI and dual head configurations)
        vi /usr/share/config/kdm/kdmrc
        Uncomment the following line under the section titled [X-:*-Core]:


        for GDM
        add following in /etc/X11/gdm/custom.conf


        I am using Gentoo x86_64 on

        AMD Phenom(tm) 9950 Quad-Core Processor,
        ATI Technologies Inc Device 9442 HD 4850 (broke down so I am currently using HD4550 as short term replacement),
        Asus M3A32MVP Deluxe


        • #84
          Unsupported hardware

          Originally posted by digital_aneurysm View Post
          With 9.1 I now get an "Unsupported Hardware" message in the lower right of the screen.

          This is with a Sapphire 2600HD XT AGP. Now can anyone confirm whether this is a change of behaviour from previous Catalyst releases for Linux or if there's simply something wrong with my install?

          I've checked that both /etc/ati/signature and /etc/ati/control match those from the install package.

          Should it be the case that all future Catalyst releases will mark this kind of card as such is there a way to disable the logo? After all I really don't need to be continually reminded...
          I'm having the same problem, just upgraded to 9.1 from 8.12 and running aticonfig results in "No supported adapters detected". If I copy in my old xorg.conf file, I can start X, but get an "Unsupported hardware" logo in the bottom right corner.
          I'm running Ubuntu 8.10 x64 on a Dell XPS with two Radeon HD 3870 x2 cards.

          Any ideas?


          • #85
            Use the /etc/ati/control file from old driver.


            • #86
              Originally posted by Kano View Post
              Use the /etc/ati/control file from old driver.
              Sweet! - that worked great thanks.

              I've got 2 screens running with Xinerama, do you know if its possible to use 3 screens - all my attempts have so far failed?


              • #87
                Using 2 cards?


                • #88
                  Originally posted by Kano View Post
                  Using 2 cards?
                  Yep - I've previously managed to get three screens running as individual desktops, but when I enable Xinerama, bad things happen and I loose the 3rd screen (which is on the second card).

                  I've tried playing around with amdccle which detects both cards, but when I apply changes and restart the machine, either I'm back with 2 screens or the system locks up after gdm starts and I have to press the power button an reboot and change xorg.conf manually.

                  Things now seem to have now gone worse, with amdccle giving me a "Floating point exception".

                  Are there any other config files other than xorg.cong which I may need to tinker with?


                  • #89
                    Originally posted by Gujs View Post
                    I also have a lot of problems with ati and wine. I just tried to play fifa 09 and I get a lot of artefacts. See picture:

                    I get similar problems in Oblivion with my R500. What card do you have?


                    • #90
                      Originally posted by EmbraceUnity View Post
                      I get similar problems in Oblivion with my R500. What card do you have?
                      I have Sapphire ATI Radeon HD4670 512MB PCI-E card.