Announcement

Collapse
No announcement yet.

Multiple X-Server on ATI Card!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Raybuntu
    started a topic Multiple X-Server on ATI Card!

    Multiple X-Server on ATI Card!

    Hi I'm trying to make 2 different X Servers running on one maschine. I'm added multiple Server Layouts and trying to start x with:

    startx -- :1 -layout LCD

    But I'm geting this errors: http://paste.ubuntuusers.de/393495/

    My xorg.conf: http://paste.ubuntuusers.de/393496/

    Is there something I'm doing wrong?

    EDIT: What I exactly want are 2 independent xservers. The first on screen 1 (xserver :0.0) a monitor and the second xserver on screen 2 (xserver :1.1). I wish to see them both at one time and switch with Ctrl.+Alt+F7 and Ctrl.+Alt+F9 between the servers.


    greetings
    Ray
    Last edited by Raybuntu; 12-31-2008, 11:15 PM.

  • Raybuntu
    replied
    Thanx djurny!!
    Unfortunately the "2 Xserver" problem doesn't affect me anymore, but for the future this could be very useful . Right now I'm quite happy with the Xinerama mode.

    Leave a comment:


  • djurny
    replied
    dude, i have had almost the same problem here, wanting twinview on onboard graphics and seperate x screens on an addon card.. running 2 x servers fixed that!
    after 4 days of googling and trial/error/busting-head-against-wall i found an interesting article somewhere..
    by using the options the guy describes and having 2 seperate ServerLayouts in my xorg.conf, i was able to launch 2 x servers with 2 seperate displays, one with twinview and one with 2 seperate x screens..
    be sure to use the correct pci busids for your own setup as well as the correct ServerLayouts of course..

    hope this helps! it helped me (eventually)!

    Code:
    #!/bin/sh
    
    sudo killall -KILL Xorg
    
    sudo Xorg :0 -layout Desktop -sharevts -novtswitch -isolateDevice PCI:3:0:0 &
    sudo Xorg :1 -layout Theatre -sharevts -novtswitch -isolateDevice PCI:2:0:0 &
    
    sleep 5
    
    DISPLAY=:0 startkde &
    DISPLAY=:1.0 xbmc &
    
    # EOF

    Leave a comment:


  • gsmd
    replied
    Coming from a working dual-screen setup, I can't make the screens work separately.
    So the idea is to be able to separately start/kill servers on any screen.
    The X server can be launched either with startx,xinit or plain X. The first two seem of no use in this case as they'd keep telling the X server is already running and prevent from launching a second copy (both startx -- -layout vga :1 and xinit -layout vga :1) so I reverted back to X.
    Now, that's where the fun begins:
    X -layout vga :1
    Works as expected: got image on the second screen, hdmi left intact.
    X -layout hdmi :0
    This would reset vga and bring the very same X that appears on hdmi screen.
    What's interesting it that killing the latter would reveal the X previously started on vga. In any other combination killing one server would bring the second one as well.


    The sidenotes:
    0) Trying to mix fglrx for one screen with radeonhd for another either prevents X from starting or brings the entire system down. That's totally acceptable as radeonhd might not like the fglrx kernel module. What's not is that radeonhd keeps crashing on it's own in a dual-X setup.
    1) Option "Xinerama" "off" doesn't seem to change anything.
    2) Having Screen declaration under "Device" section like
    Code:
    Section "Device"
            Identifier  "vga-device"
            Driver      "fglrx"
            BusID       "PCI:1:5:0"
            Screen      1
    EndSection
    Is required to run a dual-head config with fglrx but won't let X start in a single-display mode (what's I've been trying to achieve).
    So having
    Code:
    Section "ServerFlags"
            Option "DefaultServerLayout" "dual"
    EndSection
    
    
    Section "ServerLayout"
            Identifier     "dual"
            Screen      0  "hdmi-screen"
            Screen      1  "vga-screen" LeftOf "hdmi-screen"
    EndSection
    
    Section "ServerLayout"
            Identifier     "hdmi"
            Screen      0  "hdmi-screen" 0 0
    EndSection
    
    Section "ServerLayout"
            Identifier     "vga"
            Screen      1  "vga-screen" 0 0
    EndSection
    in order to start in dual-headed mode by default and custom mode manually launching X is not technically possible.

    Here's my xorg.conf:

    Code:
    Section "ServerLayout"
            Identifier     "hdmi"
            Screen      0  "hdmi-screen" 0 0
    EndSection
    
    Section "ServerLayout"
            Identifier     "vga"
            Screen      1  "vga-screen" 0 0
    EndSection
    
    Section "ServerFlags"
            Option "Xinerama" "off"
    EndSection
    
    Section "Monitor"
            Identifier   "hdmi-monitor"
            ModeLine     "1920x1080" 138.5 1920 1968 2000 2080 1080 1083 1088 1111 +vsync
            Option      "VendorName" "LG"
            Option      "ModelName" "42LF75"
            Option      "DPMS" "true"
    EndSection
    
    Section "Monitor"
            Identifier   "vga-monitor"
            ModeLine     "1280x1024" 135.0 1280 1296 1440 1688 1024 1025 1028 1066
            Option      "VendorName" "Samsung"
            Option      "ModelName" "740BF"
            Option      "DPMS" "true"
    EndSection
    
    Section "Device"
            Identifier  "hdmi-device"
            Driver      "fglrx"
            BusID       "PCI:1:5:0"
    EndSection
    
    Section "Device"
            Identifier  "vga-device"
            Driver      "fglrx"
            BusID       "PCI:1:5:0"
    EndSection
    
    Section "Screen"
            Identifier "hdmi-screen"
            Device     "hdmi-device"
            Monitor    "hdmi-monitor"
            DefaultDepth     24
            SubSection "Display"
                    Depth     24
                    Modes    "1920x1080"
            EndSubSection
    EndSection
    
    Section "Screen"
            Identifier "vga-screen"
            Device     "vga-device"
            Monitor    "vga-monitor"
            DefaultDepth     24
            SubSection "Display"
                    Depth     24
                    Modes    "1280x1024"
            EndSubSection
    EndSection
    P.S.
    You won't be able to initialize more
    than one X server so soon. That's the reason why people is still using
    nested servers (like Xephyr) under a multi-head Xorg to deploy the
    multiseat model.
    http://www.mail-archive.com/xorg@lis.../msg03640.html
    Last edited by gsmd; 01-07-2009, 04:35 AM.

    Leave a comment:


  • Raybuntu
    replied
    My problem is that when I configure seperate screens I share the screensaver. Let me explain: When I watch videos with mythtv on my LCD I have to turn off my monitor because the screensaver is blocked. If I find a way to activate xscreensaver only on the screen that is temorarily not used, i would be happy with this configuration.

    Leave a comment:


  • adamk
    replied
    You shouldn't need to make any changes to your xorg.conf file to run multiple X servers. Just running 'startx -- :1' should do it.

    EDIT: Sorry, I just saw your edit in the first post. So you have two monitors, and you want separate x servers on each monitor? I'm not sure that's possible... What is the purpose of this instead of having separate screens of the same X server on each monitor?

    Adam

    Leave a comment:


  • Raybuntu
    replied
    You can find my xorg.conf in my first post! Or do you need other config files?

    Leave a comment:


  • gsmd
    replied
    Plz share your config as you make this work.

    Leave a comment:


  • Raybuntu
    replied
    Ok, I think I know what the problem is. I have in my section "Device" "Screen 0" and "Screen 1" defined. If I choose an Server Layout it seems that it must have a Device with "Screen 0" if I choose a Server Layout with only a Device with "Screen 1" I got this error!

    Leave a comment:


  • Raybuntu
    replied
    Ok, i tried to put in new section device, monitor and screen for "radeon" and make a server layout for the radeon screen. Still the same error: http://paste.ubuntuusers.de/393517/

    Code:
    (WW) RADEON: No matching Device section for instance (BusID PCI:2:0:0) found
    comand was: startx -- :1.1 -layout LCD

    I thing that I miss something or do something wrong!?

    Leave a comment:

Working...
X