No announcement yet.


  • Filter
  • Time
  • Show
Clear All
new posts

  • Googleearth

    Does anyone else have problems with the latest fglrx driver and Google Earth? I have a Radeon 9200SE and the textures of Google Earth are disappearing in some random way.

  • #2
    What fglrx driver are you using? Seeing as there is the R200 OpenGL API Entrypoint issue with 8.25 and 8.26.

    Anyhow, I haven't run into any problems myself with various fglrx usage on Google Earth for Linux. Have you tried using the open-source drivers?
    Michael Larabel


    • #3
      I was using last month's drivers, but upgraded yesterday to the new ones. Didn't try Google Earth though (no time).

      I had been using the DRI drivers, but somehow I wasn't able to get direct rendering running (I had it running some months ago). Anyhow -- with the DRI drivers I often experienced lockups after some time, sometimes hours, when using 3D apps. No problems so far with fglrx.

      I will try Google Earth tomorrow with the new drivers. What is this API entrypoint issue? Don't spare technical details, I am quite fluent in OpenGL and stuff.


      • #4
        8.26.18 Release Notes

        Attempting to use 3D applications on Radeon 9000/9100/9200/9250 and FireGL 8x00 products fails to start and reports back something similar to ?[fglrx] API ERROR: could not register entrypoint for SelectTextureSGIS?. Further details can be found in topic number 737-22639
        Here is the BugZilla entry.
        Michael Larabel


        • #5
          Hm, I don't get the entrypoint error messages, but: fgl_glxgears shows a solid box, too, just like in the bug report. so pbuffer does not seem to work. Since it is an extension, maybe the two problems are related. Actually, glxinfo doesn't show that extension at all.


          • #6
            So, I played a bit around with googleearth and the fglrx drivers. It seems to be the API entrypoint problem. When I installed the of the fglrx 8.14.x driver, everything started working again. Even googleearth looks fine now. I hope this will get fixed in the next release of the driver!


            • #7
              Update: So as I said with the 8.14.x libGL, googleearth works. My first problem remains, but now I know when it happens. Whenever some other window, or one of googleearth's popups and bubbles intersects the OpenGL widget of googleearth, the textures will flicker, and sometimes completely disappear. If no window overlaps, everything is fine. I guess this is a bug in the driver? Haven't tried if that also happens with other OpenGL applications.